MDVA-39966: en_US 이외의 로케일을 배포할 수 없음

MDVA-39966 패치는 사용자가 en_US 이외의 로케일을 배포할 수 없는 문제를 해결합니다. 이 패치는 품질 패치 도구(QPT) 1.1.2가 설치된 경우에 사용할 수 있습니다. 패치 ID는 MDVA-39966입니다. 이 문제는 Adobe Commerce 버전 2.4.1에서 해결되었습니다.

영향을 받는 제품 및 버전

Adobe Commerce 버전에 대한 패치가 만들어졌습니다.

  • Adobe Commerce(모든 배포 방법) 2.3.5-p2

Adobe Commerce 버전과 호환:

  • Adobe Commerce(모든 배포 방법) 2.3.0 - 2.3.5-p2, 2.4.0 - 2.4.0-p1
NOTE
이 패치는 새로운 품질 패치 도구 릴리스가 있는 다른 버전에 적용할 수 있습니다. 패치가 Adobe Commerce 버전과 호환되는지 확인하려면 magento/quality-patches 패키지를 최신 버전으로 업데이트하고 Quality Patches Tool에서 호환성을 확인합니다. 패치 검색 페이지. 패치 ID를 검색 키워드로 사용하여 패치를 찾습니다.

문제

en_US 이외의 로케일을 배포할 수 없습니다.

재현 단계:

  1. 서로 다른 로케일로 두 개의 스토어 뷰를 구성합니다(예: en_US 및 de_DE).
  2. 다음 명령을 실행하여 이러한 로케일에 정적 콘텐츠를 배포하십시오.
bin/magento setup:static-content:deploy --language=en_US
bin/magento setup:static-content:deploy --language=de_DE

예상 결과:

de_DE 로케일이 배포되었습니다.

bin/magento setup:static-content:deploy --language=de_DE

Deploy using quick strategy
adminhtml/Magento/backend/de_DE         2416/2416           ============================ 100%   9 secs
frontend/Magento/blank/de_DE            2486/2486           ============================ 100%   7 secs
frontend/Magento/luma/de_DE             2504/2504           ============================ 100%   8 secs

Execution time: 27.062166929245

실제 결과:

de_DE 대신 배포된 en_US 로케일:

bin/magento setup:static-content:deploy --language=de_DE

Deploy using quick strategy
adminhtml/Magento/backend/en_US         2416/2416           ============================ 100%   2 secs
frontend/Magento/blank/en_US            2486/2486           ============================ 100%   1 sec
frontend/Magento/luma/en_US             2504/2504           ============================ 100%   2 secs

패치 적용

개별 패치를 적용하려면 배포 방법에 따라 다음 링크를 사용합니다.

관련 읽기

품질 패치 도구에 대한 자세한 내용은 다음을 참조하십시오.

QPT에서 사용할 수 있는 다른 패치에 대한 정보는 개발자 설명서에서 QPT에서 사용할 수 있는 패치를 참조하십시오.

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a