MDVA-43731: '일치할 최소 용어'에 값을 추가하면 검색 동의어가 작동하지 않습니다.

MDVA-43731 패치는 "일치하는 최소 용어"에 값이 추가되면 검색 동의어 작동이 중지되는 문제를 해결합니다. 이 패치는 다음 경우에 사용할 수 있습니다. 품질 패치 도구(QPT) 1.1.12가 설치되어 있습니다. 패치 ID는 MDVA-43731입니다. 이 문제는 Adobe Commerce 2.4.5에서 수정됩니다.

영향을 받는 제품 및 버전

패치는 Adobe Commerce 버전에 대해 만들어집니다.

  • Adobe Commerce(모든 배포 방법) 2.4.3

Adobe Commerce 버전과 호환:

  • Adobe Commerce(모든 배포 방법) 2.4.3 - 2.4.3-p1
NOTE
이 패치는 새로운 품질 패치 도구 릴리스가 있는 다른 버전에 적용할 수 있습니다. 패치가 Adobe Commerce 버전과 호환되는지 확인하려면 magento/quality-patches 최신 버전으로 패키지하고 Quality Patches Tool: 패치 검색 페이지. 패치 ID를 검색 키워드로 사용하여 패치를 찾습니다.

문제

"일치시킬 최소 용어"에 값이 추가되면 검색 동의어 작동이 중지됩니다.

재현 단계:

  1. 샘플 데이터를 사용하여 Adobe Commerce을 설치합니다.
  2. Elasticsearch7을 검색 엔진으로 구성합니다.
  3. "Jacket"이라는 단어를 검색합니다. 제품 목록이 표시됩니다.
  4. 매개 변수 추가 [4<60%] 위치: 구성 > 카탈로그 > 카탈로그 검색 > 일치시킬 최소 용어.
  5. 구성 캐시를 지우고 다시 인덱싱합니다.
  6. 다시 "재킷"이라는 단어를 검색하고 제품 목록이 표시됩니다.
  7. 다음으로 이동 마케팅 > SEO 및 검색 > 동의어 검색.
  8. jacket, bagtecs, express plus 와 같은 동의어를 추가하여 검색 동의어를 생성합니다.
  9. 색인 재지정
  10. 동의어를 사용하여 제품 검색을 수행합니다. 예, 재킷.

예상 결과:

검색 결과에서 이전과 동일한 제품 목록을 가져옵니다.

실제 결과:

검색 결과에 제품이 표시되지 않습니다.

패치 적용

개별 패치를 적용하려면 배포 방법에 따라 다음 링크를 사용합니다.

관련 읽기

품질 패치 도구에 대한 자세한 내용은 다음을 참조하십시오.

QPT에서 사용할 수 있는 다른 패치에 대한 정보는 다음을 참조하십시오. QPT에서 사용 가능한 패치 개발자 설명서에서 확인할 수 있습니다.

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a