MDVA-42790: REST API를 통해 특정 웹 사이트에 대해 제품 가격 특성을 업데이트할 수 없습니다.

MDVA-42790 패치는 사용자가 REST API를 통해 특정 웹 사이트에 대한 제품 가격 속성을 업데이트할 수 없는 문제를 수정했습니다. 이 패치는 다음 경우에 사용할 수 있습니다. 품질 패치 도구(QPT) 1.1.11이 설치되었습니다. 패치 ID는 MDVA-42790입니다. 이 문제는 Adobe Commerce 2.4.5에서 수정됩니다.

영향을 받는 제품 및 버전

패치는 Adobe Commerce 버전에 대해 만들어집니다.

  • Adobe Commerce(모든 배포 방법) 2.4.3-p1

Adobe Commerce 버전과 호환:

  • Adobe Commerce(모든 배포 방법) 2.4.3 - 2.4.3-p1
NOTE
이 패치는 새로운 품질 패치 도구 릴리스가 있는 다른 버전에 적용할 수 있습니다. 패치가 Adobe Commerce 버전과 호환되는지 확인하려면 magento/quality-patches 최신 버전으로 패키지하고 Quality Patches Tool: 패치 검색 페이지. 패치 ID를 검색 키워드로 사용하여 패치를 찾습니다.

문제

사용자는 REST API를 통해 특정 웹 사이트에 대한 제품 가격 속성을 업데이트할 수 없습니다.

재현 단계:

  1. 관리에서 다음으로 이동 스토어 > 구성 > 카탈로그 > 가격 > 및 설정 카탈로그 가격 범위 (으)로 이동합니다.

  2. REST API를 사용하여 번들 제품의 특별 가격 업데이트, POST rest/V1/products/.

    code language-json
    {
      "product": {
        "id": 46,
        "sku": "24-WG080",
        "name": "Sprite Yoga Companion Kit",
        "attribute_set_id": 4,
        "price": 10,
        "status": 1,
        "visibility": 1,
        "type_id": "bundle",
        "weight": 0,
        "custom_attributes": [
          {
            "attribute_code": "special_price",
            "value": "2"
          }
        ]
      }
    }
    

예상 결과:

다음 경우에 번들 제품에 대한 특별 가격이 업데이트됩니다. 카탈로그 가격 범위 을 웹 사이트로 설정합니다.

실제 결과:

다음과 같은 경우에는 번들 제품에 대한 특별 가격이 업데이트되지 않습니다. 카탈로그 가격 범위 을 웹 사이트로 설정합니다.

패치 적용

개별 패치를 적용하려면 배포 방법에 따라 다음 링크를 사용합니다.

관련 읽기

품질 패치 도구에 대한 자세한 내용은 다음을 참조하십시오.

QPT에서 사용할 수 있는 다른 패치에 대한 정보는 다음을 참조하십시오. QPT에서 사용 가능한 패치 개발자 설명서에서 확인할 수 있습니다.

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a