MDVA-34474: API 구매요청 목록 갱신 결과 오류 발생

MDVA-34474 패치는 API를 사용하여 구매요청 목록에 제품을 추가하면 오류가 발생하는 문제를 수정합니다. 이 패치는 다음 경우에 사용할 수 있습니다. 품질 패치 도구(QPT) 1.0.19가 설치되었습니다. 패치 ID는 MDVA-34474입니다. 이 문제는 Adobe Commerce 2.4.3에서 해결되었습니다.

영향을 받는 제품 및 버전

패치는 Adobe Commerce 버전에 대해 만들어집니다.

클라우드 인프라의 Adobe Commerce 2.4.0

Adobe Commerce 버전과 호환:

Adobe Commerce 온-프레미스 및 Adobe Commerce on cloud infrastructure 2.3.0 - 2.4.2

NOTE
이 패치는 새로운 품질 패치 도구 릴리스가 있는 다른 버전에 적용할 수 있습니다. 패치가 Adobe Commerce 버전과 호환되는지 확인하려면 magento/quality-patches 최신 버전으로 패키지하고 Quality Patches Tool: 패치 검색 페이지. 패치 ID를 검색 키워드로 사용하여 패치를 찾습니다.

문제

API를 사용하여 구매요청 목록에 제품을 추가하면 오류가 발생합니다.

재현 단계:

  1. 관리자의 구매요청 목록 활성화(스토어 > 구성 > 일반 > B2B 기능 > 구매요청 목록 활성화 = ).
  2. 고객을 만듭니다.
  3. 이 고객 발신 통화에 대한 새 구매요청 목록 생성 json POST rest/all/V1/requisition_lists json 페이로드가 첨부된 경우.

예상 결과:

오류가 없고 목록이 만들어집니다.

실제 결과:

400 오류.

{"message":"Could not save Requisition List"}

패치 적용

개별 패치를 적용하려면 배포 방법에 따라 다음 링크를 사용합니다.

관련 읽기

품질 패치 도구에 대한 자세한 내용은 다음을 참조하십시오.

QPT에서 사용할 수 있는 다른 패치에 대한 정보는 다음을 참조하십시오. QPT에서 사용 가능한 패치 섹션.

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a