MDVA-34469: 장바구니에 지정된 스토어 코드가 잘못되었습니다.

MDVA-34469 패치는 사용자가 오류 메시지를 받는 문제를 해결합니다. 장바구니에 대해 잘못된 스토어 코드가 지정됨 스토어 보기를 전환한 후 장바구니에 제품을 추가할 때. 이 패치는 다음 경우에 사용할 수 있습니다. 품질 패치 도구(QPT) 1.0.15가 설치되어 있습니다. 패치 ID는 MDVA-34469입니다. 이 문제는 Adobe Commerce 2.4.2에서 해결되었습니다.

영향을 받는 제품 및 버전

패치는 Adobe Commerce 버전에 대해 만들어집니다.

클라우드 인프라의 Adobe Commerce 2.4.1

Adobe Commerce 버전과 호환:

Adobe Commerce on cloud infrastructure 및 Adobe Commerce on-premise 2.4.1 - 2.4.1-p1

NOTE
이 패치는 새로운 품질 패치 도구 릴리스가 있는 다른 버전에 적용할 수 있습니다. 패치가 Adobe Commerce 버전과 호환되는지 확인하려면 magento/quality-patches 최신 버전으로 패키지하고 Quality Patches Tool: 패치 검색 페이지. 패치 ID를 검색 키워드로 사용하여 패치를 찾습니다.

문제

사용자에게 장바구니 쿼리 오류가 표시됩니다. "장바구니에 대해 잘못된 스토어 코드가 지정되었습니다.": 스토어 보기를 전환할 때 사용합니다.

전제 조건:

  • Adobe Commerce 2.4.0.
  • 하나의 스토어와 두 개의 스토어 보기가 있는 단일 웹 사이트가 구성됩니다.
  • 고객 계정이 생성됩니다.

재현 단계:

  1. Adobe Commerce 백엔드는 두 개의 스토어 보기(스토어 코드 포함: 기본값, 초)가 있도록 구성되어 있습니다.
  2. 사용자가 기본 스토어 코드를 사용하여 장바구니를 만듭니다.
  3. 사용자는에서 두 번째 스토어 코드를 사용하여 이 장바구니를 검색하려고 합니다 Store 요청 헤더입니다.

예상 결과:

스토어를 전환하면(에서 새 코드를 보냄) 장바구니가 표시됩니다. Store request header)를 통해 장바구니를 요청된 저장소에 연결합니다.

실제 결과:

장바구니 쿼리가 오류를 반환하며 장바구니가 표시되지 않습니다.

패치 적용

개별 패치를 적용하려면 배포 방법에 따라 다음 링크를 사용합니다.

관련 읽기

품질 패치 도구에 대한 자세한 내용은 다음을 참조하십시오.

QPT에서 사용할 수 있는 다른 패치에 대한 정보는 다음을 참조하십시오. QPT에서 사용 가능한 패치 섹션.

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a