接触チャネルクロークにより、サイトにアクセスできない
この記事では、クラウドインフラストラクチャー上のAdobe Commerceのステージングまたは実稼動サイトのストアフロントや管理者がアクセスできない場合の解決策を説明します。
影響を受ける製品とバージョン
- クラウドインフラストラクチャー上のAdobe Commerce 2.3.x、2.4.x
問題
https://mydomain.com.c.<projectid>.magento.cloud/にはアクセスできなくなりました。
再現手順:
- プロジェクトにログインします。
- URL と SSH のリストを表示するには、「プロジェクトにアクセス」をクリックします。
実績:
次のエラーでページの読み込みに失敗します。
NET::ERR_CERT_INVALID**TLS アラート、不正な証明書(554):
期待される結果:
ページが正常に読み込まれました。
原因:
オリジンクロークが有効になっているので、オリジンに直接アクセスできなくなりました。
オリジンクロークは、DDoS 攻撃を防ぐために、クラウドインフラストラクチャ(オリジン)に送信される非 Fastly トラフィックをAdobe Commerceがブロックできるようにするセキュリティ機能です。
解決策
- クラウドサイトがライブの場合は、https://mydomain.com/に切り替えます。
- アクティブなサイト(クラウド以外)がある場合は、https://mydomain.com/ ドメインを使用してサブドメイン
mcprod.mydomain.com
を設定し、ベース URL を https://mcprod.mydomain.com に更新して、DNS を Fastly に指定ます。
関連資料
Fastly オリジンクローキングのイネーブルメントに関する FAQ (サポートナレッジベース内)
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