遅延支払サービスレポートデータ

この記事では、Adobe Commerceでの支払いサービスのレポートデータの遅延の理由と、この問題を解決する方法について説明します。

説明 description

環境

Adobe Commerce, v2.4.0 -2.4.4#キョウ#

問題

支払いサービスのレポートデータ(支払いおよび注文の支払いステータスレポートの場合)は、すぐに同期されない場合があります。

注文に対して請求(キャプチャ)を行った後、または注文に関するクレジット・メモを発行した後は、注文のステータスがすぐに利用できなくなる場合があります。

再現手順:

前提条件:支払いサービス機能を使用して注文が行われます。

  1. 注文は管理者で請求(またはキャンセル、またはクレジットメモによる返金)されます。
  2. 注文支払ステータスレポートに移動して、その注文に関する情報を表示します。
  3. ステータスは「承認済」として表示されます。これは、請求またはその他の注文処理の前の注文ステータスです。

Commerceはデータを同期して支払いサービスに送信していないので、新しい注文ステータスはまだレポートで認識されません。

メモ : これは一般的なユースケースの 1 つにすぎません。 注文アクションが発生し、該当するレポートですぐにデータを使用できない場合は、他の使用例が考えられます。

期待される結果:
レポートデータは、注文に対するアクションが発生した直後に入力されます。

実際の結果:
完了したばかりの注文アクションの場合、表示されるレポートデータに遅延が生じる場合があります。 支払いレポートには、24~48 時間の遅延が発生する場合があります。 注文支払いステータスレポートには、数時間の遅延が発生する場合があります。

原因
管理画面に表示されるデータのこの遅延に影響する要因は 2 つあります。

  • 管理者の設定を使用して、Commerceからデータを同期(エクスポートおよび保持)する頻度。
  • PayPal がレポートデータを公開する期間。

解決策 resolution

注文支払いステータスレポートの場合:

  1. Sales に移動します。 > 支払いサービス
  2. 注文支払ステータス をクリックして、注文支払ステータスレポートテーブルを表示します。
  3. 再同期を強制するには、「レポート」テーブルの右上隅にある 再同期を強制 アイコンをクリックします。 最後に更新されたタイムスタンプの変更と新しいトランザクションがレポートテーブルに読み込まれているのが確認できます。

PayPal の支払いレポートの場合、PayPal のデータ公開期間に依存しているため、予想結果は 24~48 時間の遅延となります。

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