遅延決済サービスレポートデータ

この記事では、Adobe Commerceで支払いサービスのレポートが遅れた理由と、その問題を解決する方法について説明します。

説明 description

環境

Adobe Commerce, v2.4.0 -2.4.4

問題

決済サービスのレポートデータは、決済と注文支払い状況レポート用に、すぐに同期されない場合があります。

例えば、注文の請求書(キャプチャ)を作成したり、注文のクレジットメモを発行したりした後、注文のステータスをすぐに利用できない場合があります。

再現手順:

前提条件:支払いサービス機能を使用して注文が行われます。

  1. 注文は管理画面で請求(またはクレジットメモを介してキャンセルまたは返金)されます。
  2. 注文支払い状況レポートに移動して、その注文に関する情報を確認します。
  3. ステータスは「承認済」と表示されます。これは、請求書またはその他の注文アクションの前の注文ステータスです。

Commerceはデータを同期しておらず、決済サービスに送信していないため、新しい注文ステータスはまだレポートで認識されていません。

メモ : これは一般的な使用例の1つにすぎません。 注文アクションが発生し、データが該当するレポートですぐに利用できない場合は、他のユースケースが発生する場合があります。

期待される結果:
レポートデータは、注文に対するアクションが発生した直後に入力されます。

実際の結果:
完了したばかりの注文アクションに関する表示レポートデータに遅延が発生する場合があります。 支払いレポートには、24~48時間の遅延が発生する場合があります。 注文支払い状況レポートには数時間遅れがかかる場合があります。

原因
管理画面で表示されるデータのこの遅延に影響を与える2つの要因があります。

  • 管理者の設定を使用して、Commerceからデータを同期(書き出しと保持)する頻度を選択します。
  • PayPalがレポートデータを公開する時間枠。

解決策 resolution

注文支払い状況レポートの場合:

  1. Salesに移動します > 決済サービス
  2. 注文支払い状況をクリックして、注文支払い状況レポート テーブルを表示します。
  3. レポートテーブルの右上隅にあるforce resync アイコンをクリックして、再同期を強制します。 最後に更新されたタイムスタンプの変更と、新しいトランザクションがレポートテーブルに読み込まれます。

PayPalの支払いレポートの場合、予想される結果は、PayPalのデータ公開期間に依存しているため、24~48時間の遅延です。

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