キャッシュが無効化されると、レスポンス・タイムが低下する

この記事では、Adobe Commerce ストアのパフォーマンスが低下する原因となる可能性のあるキャッシュの無効化を回避する方法について説明します。

影響を受ける製品とバージョン:

  • Adobe Commerce オンプレミス 2.2.x、2.3.x
  • クラウドインフラストラクチャー上のAdobe Commerce 2.2.x、2.3.x

問題

サイトの応答が遅い。

原因:

キャッシュが無効化(フラッシュ)されることで、応答時間が長くなる場合があります。

キャッシュは、サイト訪問者のリクエストに対する高速な応答を生成するために使用されます。 使用可能な適切なキャッシュデータがない場合、Adobe Commerce アプリケーションはデータベースからデータを取得し、計算して集計し、キャッシュストレージに保存します。 キャッシュ生成プロセスには、追加のシステムリソースが必要になり、全体的な応答時間の低下を引き起こします。

Adobe Commerceには次の 2 種類のキャッシュがあります。

  1. 内部:

    • サーバーにデータを格納
    • 特定のデータ(設定、製品詳細、カテゴリ詳細など)を保存
  2. 外部:

    • CDN または Varnish (クラウドインフラストラクチャー上のAdobe Commerceの場合 – Fastly CDN)
    • 生成済みの完全なページを格納します。 例えば、カタログ/カテゴリ、カタログ/製品ページなどです。

キャッシュが無効になっていないかどうかを確認します

無効化されたキャッシュタイプに関する情報は、<install_directory>/var/log/debug.log ファイルで確認できます。

手順は次のとおりです。

  1. Open <install_directory>/var/log/debug.log

  2. cache_invalidate」メッセージを検索します。

  3. 次に、指定したタグを確認します。 フラッシュされたキャッシュを示します。 特定のエンティティ ID が指定されていないタグが表示された場合、キャッシュが無効になっていることが原因で問題が生じる可能性があります。次に例を示します。

    • cat_p - カタログ製品キャッシュを表します。
    • cat_c - カタログカテゴリのキャッシュ。
    • FPC - フルページキャッシュ。
    • CONFIG – 設定キャッシュ。

    そのうちの 1 つでもフラッシュすると、web サイトの応答が遅くなります。 タグにエンティティ ID (例:category_product_1258)が含まれる場合は、特定の製品またはカテゴリのキャッシュが示されます。 特定の製品またはカテゴリのキャッシュをフラッシュしても、応答時間が大幅に短縮されることはありません。

次に、フラッシュされた cat_p および category_product_15044 キャッシュに関するレコードを含む debug.log の例を示します。

debug.log コンテンツのサンプル

通常、キャッシュは次の理由で無効になります。

  • フル再インデックス。
  • 手動または cron を使用して CLI からキャッシュを点滅させる。

推奨事項

  1. Commerce CLI からキャッシュをフラッシュしないでください。
  2. 保存時に更新 ではなく、スケジュールに従って更新 をインデクサーに設定します。後者は完全なインデックス再作成をトリガーするためです。 詳しくは、開発者向けドキュメントの インデクサーの管理/インデクサーの設定を参照してください。
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