キャッシュが無効化されると、レスポンス・タイムが低下する
この記事では、Adobe Commerce ストアのパフォーマンスを低下させる可能性のある、キャッシュの無効化を防ぐ方法について説明します。
説明 description
環境
Adobe Commerce オンプレミス
クラウドインフラストラクチャー上のAdobe Commerce
問題/症状
- 部位反応遅延
原因
キャッシュが無効化(フラッシュ)されると、応答時間が長くなる場合があります。
キャッシュは、サイト訪問者のリクエストに対する迅速な応答を生成するのに役立ちます。 適切なキャッシュデータがない場合、Adobe Commerceはデータベースからデータを取得し、計算および集計してキャッシュに保存します。 このプロセスには追加のシステムリソースが必要なため、応答時間が低下する可能性があります。
Adobe Commerceでは、次の 2 種類のキャッシュを使用します。
- 内部 設定、製品の詳細、カテゴリの詳細などのデータをサーバーに保存します。
- 外部 CDN またはワニス(Fastly CDN for Adobe Commerce on cloud)。 カタログ/カテゴリページやカタログ/製品ページなどの完全なページを格納します。
キャッシュが無効になっていないかどうかを確認します
<install_directory> /var/log/debug.log で無効化されたキャッシュタイプを確認するには、以下を行います
-
Open
<install_directory> /var/log/debug.log. -
「cache_invalidate」を検索します。
-
指定したタグを確認します。
cat_p- カタログ製品キャッシュcat_c- カタログ カテゴリのキャッシュFPC- フルページキャッシュCONFIG– 設定キャッシュ
そのうちの 1 つでもフラッシュすると、web サイトの応答が遅くなります。 タグにエンティティ ID (例:category_product_1258)が含まれている場合は、その製品またはカテゴリのキャッシュのみがフラッシュされました。通常、応答時間には大きな影響を与えません。
次に、フラッシュされた debug.log および cat_p キャッシュに関するレコードを含む category_product_15044 の例を示します。
キャッシュ無効化の一般的な理由:
- 完全な再インデックス
- 手動または cron 経由で CLI からキャッシュをフラッシュ
解決策 resolution
レコメンデーション
- Commerce CLI からキャッシュをフラッシュしないでください。
- 完全なインデックス再作成を防ぐには、 保存時に更新 の代わりに スケジュールに従って更新 をインデクサーに設定します。 開発者向けドキュメントの インデクサーの管理
>インデクサーの設定 を参照してください。