MDVA-38526:管理者ユーザーが SWAT ツールにアクセスできない

MDVA-38526 パッチは、管理者ユーザが SWAT ツールにアクセスできない問題を解決します。 このパッチは、 品質向上パッチツール(QPT) 1.1.9 がインストールされています。 パッチ ID は MDVA-38526。 この問題はAdobe Commerce 2.4.4 で修正される予定であることに注意してください。

影響を受ける製品とバージョン

Adobe Commerce バージョン用のパッチが作成されます。

  • Adobe Commerce(すべてのデプロイメント方法) 2.4.1-p1

Adobe Commerce バージョンとの互換性:

  • Adobe Commerce(すべてのデプロイメント方法) 2.4.1 ~ 2.4.3-p1
NOTE
パッチは、新しい Quality Patches Tool リリースを使用する他のバージョンにも適用される可能性があります。 パッチがお使いのAdobe Commerceのバージョンと互換性があるかどうかを確認するには、 magento/quality-patches を最新バージョンにパッケージ化し、 Quality Patches Tool:パッチの検索ページ. パッチ ID を検索キーワードとして使用して、パッチを見つけます。

問題

管理者ユーザーが SWAT ツールにアクセスできません。

再現手順:

~に手を伸ばそうとする ../swat/key/index

期待される結果:

  1. ../swat/key/index returns 200.
  2. 管理者ユーザーは、SWAT にアクセスできます。

実際の結果:

500 エラーは、次のエラーログでトリガーされます。 値をシリアル化解除できません。 エラー:構文エラー.

パッチの適用

個々のパッチを適用するには、デプロイメント方法に応じて、次のリンクを使用します。

関連資料

品質向上パッチツールの詳細については、次を参照してください。

QPT で使用可能なその他のパッチについては、を参照してください。 QPT で使用可能なパッチ 開発者向けドキュメントを参照してください。

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a