MDVA-41597:設定可能な商品を買い物かごに複数追加する際にエラーが発生しました

MDVA-41597 パッチでは、GraphQLを使用して複数の設定可能な商品を買い物かごに追加するとエラーが発生する問題が修正されています。 このパッチは、Quality Patches Tool (QPT)1.1.6 がインストールされている場合に使用できます。 パッチ ID は MDVA-41597。 この問題はAdobe Commerce 2.4.4 で修正される予定であることに注意してください。

影響を受ける製品とバージョン

Adobe Commerce バージョン用のパッチが作成されます。

Adobe Commerce(すべてのデプロイメント方法) 2.4.2-p1

Adobe Commerce バージョンとの互換性:

Adobe Commerce(すべてのデプロイメント方法) 2.4.2 - 2.4.3-p1

NOTE
パッチは、新しい Quality Patches Tool リリースを使用する他のバージョンにも適用される可能性があります。 パッチがAdobe Commerceのバージョンと互換性があるかどうかを確認するには、magento/quality-patches パッケージを最新バージョンに更新し、Quality Patches Tool: Search for patches page で互換性を確認します。 パッチ ID を検索キーワードとして使用して、パッチを見つけます。

問題

GraphQLを使用して設定可能な複数の商品を買い物かごに追加すると、エラーが発生します。

再現手順 :

GraphQL mutation:addConfigurableProductsToCart を使用して、設定可能な複数の商品を買い物かごに追加します。

期待される結果 :

設定可能なすべての製品が買い物かごに追加されます。

実際の結果 :

最初の製品のみが買い物かごに追加されます。

パッチの適用

個々のパッチを適用するには、デプロイメント方法に応じて、次のリンクを使用します。

関連資料

品質向上パッチツールの詳細については、次を参照してください。

QPT で使用可能なその他のパッチについては、QPT で使用可能なパッチの節を参照してください。

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a