ACSD-47669:カスタマイズ可能なオプションを含む製品をインポートする際の内部サーバーエラー

ACSD-47669 パッチは、カスタマイズ可能なオプションを使用して製品の読み込み中に内部サーバーエラーが発生する問題を修正します。 このパッチは、 Quality Patches Tool (QPT) 1.1.38 がインストールされています。 パッチ ID は ACSD-47669 です。 この問題は、Adobe Commerce 2.4.6 で既に修正されています。

影響を受ける製品とバージョン

Adobe Commerce バージョン用のパッチが作成されます。

  • Adobe Commerce(すべてのデプロイメント方法) 2.4.4-p1

Adobe Commerce バージョンとの互換性:

  • Adobe Commerce(すべてのデプロイメント方法) 2.4.2 ~ 2.4.5-p4
NOTE
パッチは、新しいを含む他のバージョンにも適用される可能性があります。 Quality Patches Tool リリース。 パッチがお使いのAdobe Commerceのバージョンと互換性があるかどうかを確認するには、 magento/quality-patches を最新バージョンにパッケージ化し、 Quality Patches Tool:パッチの検索ページ. パッチ ID を検索キーワードとして使用して、パッチを見つけます。

問題

カスタマイズ可能なオプションを含む製品をインポートする際に、内部サーバーエラーが発生します。

再現手順:

  1. 追加のストア表示を作成します。 ストアビューが 2 つあることを確認します(例:英国、英国)。
  2. prod1 と prod2 など、2 つのシンプルなプロダクトを作成します。
  3. 各ストア表示の製品と向けの両方のカスタムオプションを追加する csv ファイルを準備します すべてのストア表示 スコープ。 この csv ファイルを読み込みます。
  4. 2 つのレコードを含む別の csv ファイルを準備します。 最初のレコードは「prod1」のカスタムオプションを特に英国のストアビュースコープ向けに更新し、2 番目のレコードは「prod2」のカスタムオプションを英国向けに更新する必要があります すべてのストア表示 スコープ。 この 2 つ目の CSV ファイルを読み込みます。

期待される結果:

エラーなくオプションをカスタマイズできるはずです。

実際の結果:

整合性制約違反エラーが発生しました。

パッチの適用

個々のパッチを適用するには、デプロイメント方法に応じて、次のリンクを使用します。

関連資料

について詳しくは、 Quality Patches Toolを参照してください。

QPT で使用可能なその他のパッチについては、を参照してください。 Quality Patches Tool:パッチの検索 が含まれる Quality Patches Tool ガイド。

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a