MDVA-39305:有効なGoogle reCAPTCHA でのログインの問題

MDVA-39305 パッチにより、登録されたお客様が有効なGoogle reCAPTCHA でログインできない問題が修正されました。 このパッチは、 品質向上パッチツール(QPT) 1.1.1 がインストールされています。 パッチ ID は MDVA-39305。 この問題は、Adobe Commerce バージョン 2.4.4 および 2.4.7 で修正される予定であることに注意してください。

影響を受ける製品とバージョン

Adobe Commerce バージョン用のパッチが作成されます。

  • クラウドインフラストラクチャー上のAdobe Commerce 2.4.2-p1、2.4.3-p3、2.4.5-p2

Adobe Commerce バージョンとの互換性:

  • Adobe Commerce(すべてのデプロイメント方法) 2.4.1-p1 ~ 2.4.3-p3、2.4.4-p1 ~ 2.4.4-p5、2.4.5 ~ 2.4.6-p2
NOTE
パッチは、新しい Quality Patches Tool リリースを使用する他のバージョンにも適用される可能性があります。 パッチがお使いのAdobe Commerceのバージョンと互換性があるかどうかを確認するには、 magento/quality-patches を最新バージョンにパッケージ化し、 Quality Patches Tool:パッチの検索ページ. パッチ ID を検索キーワードとして使用して、パッチを見つけます。

問題

登録されたお客様は、有効なGoogle reCAPTCHA を使用してログインすることはできません。

再現手順:

  1. に移動 ストア > 設定 > セキュリティ > Google reCAPTCHA ストアフロント および有効化 Google reCAPTCHA.
  2. に移動 フロントエンド.
  3. 開く 開発者ツールコンソール ブラウザーで確認します。

期待される結果:

コンソールに CSP 警告はありません。

実際の結果:

コンソールでの CSP 警告。

パッチの適用

個々のパッチを適用するには、デプロイメント方法に応じて、次のリンクを使用します。

関連資料

品質向上パッチツールの詳細については、次を参照してください。

QPT で使用可能なその他のパッチについては、を参照してください。 QPT で使用可能なパッチ 開発者向けドキュメントを参照してください。

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a