AEM: la versione del bundle OOTB è inferiore al previsto

Descrizione description

Problema

Nei bundle OSGi della console OSGi, è presente un bundle la la cui versione è inferiore a quella prevista per l’SP/CFP installato. Questo problema non può essere trattato come un problema isolato. Di solito, si verifica un evento critico (ad es. un login per AEM non riuscito) e le indagini lo rivelano come una causa intermedia.

Causa

È possibile che l'aggiornamento del bundle non sia riuscito durante l'installazione di SP/CFP. Una delle possibili cause dell’errore di aggiornamento è che qualcuno ha avviato AEM come utente root prima e poi ha iniziato come utente normale. Durante l’esecuzione come utente root, crx-quickstart/launchpad/felix/bundleXX era di proprietà di root. Al momento dell’installazione di SP/CFP, AEM in esecuzione in quanto l’utente normale non può scrivere in bundleXX, l’aggiornamento del bundle non è riuscito.

Risoluzione resolution

Controlla il proprietario del file o della directory in crx-quickstart. Se alcuni file/directory non sono di proprietà dell’utente normale per il processo AEM, effettua le seguenti operazioni.

(1) Arrestare l’AEM.

(2) Ripristina l'utente normale.

(3) Avviare AEM.

(4) Reinstallare SP/CFP.

recommendation-more-help
3d58f420-19b5-47a0-a122-5c9dab55ec7f