Richiesta rifiutata gateway PayPal - problema fattura duplicata

Questo articolo fornisce una correzione per la richiesta rifiutata del gateway PayPal - emissione di fattura duplicata.

Quando si sottomette il pagamento, i clienti potrebbero visualizzare un errore per una fattura duplicata:

Il gateway PayPal ha rifiutato la richiesta. Il pagamento per questo ID fattura è già stato eseguito (#10412: fattura duplicata)

Il problema si verifica quando le fatture con gli stessi ID vengono inviate a PayPal più volte.

Per risolvere il problema, consenti più pagamenti per ID fattura nelle Preferenze di ricezione pagamento di PayPal. Quando viene modificato, PayPal accetta pagamenti senza messaggi di errore, anche per le fatture con ID duplicati.

Versioni interessate

  • Adobe Commerce on-premise, tutte le versioni
  • Adobe Commerce su infrastruttura cloud, tutte le versioni

Problema

Quando si invia il pagamento, i clienti visualizzano il messaggio di errore:

... main.CRITICAL: Exception message: PayPal gateway has rejected request. Payment has already been made for this InvoiceID (#10412: Duplicate invoice).

PayPal non può elaborare il pagamento e completare l'ordine.

Causa

Il messaggio di errore viene visualizzato quando le fatture con lo stesso ID vengono inviate a PayPal più volte.

Ciò può verificarsi quando si utilizzano le stesse credenziali in diversi siti di Adobe Commerce (anche negli ambienti locali e di staging). Di seguito sono riportati alcuni scenari particolari:

  • Più magazzini inviano le fatture a PayPal e utilizzano gli stessi ID fattura
  • Un nuovo archivio invia una fattura con un ID precedentemente inviato da un vecchio archivio

Per impostazione predefinita, PayPal non consente di elaborare due volte la stessa fattura.

Soluzione

Modifica il tuo profilo PayPal per consentire più pagamenti per ID fattura. Devi apportare queste modifiche tramite PayPal.

  1. Accedi al tuo account all'indirizzo https://www.paypal.com.
  2. Fai clic su Profilo > Profilo e impostazioni (angolo superiore destro).
  3. Vai a I miei strumenti di vendita.
  4. Passa a Pagamento e gestione dei rischi > Blocca pagamenti e fai clic su Aggiorna.
  5. Preferenze di vendita, fai clic su Preferenze di ricezione pagamento.
  6. In Blocca pagamenti accidentali, scegliere No, consenti più pagamenti per ID fattura. paypal_allow_multiple_payments_per_invo_id.png
  7. Scorri verso il basso e fai clic su Salva.

Ulteriori informazioni

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a