Metodi di pagamento non visualizzati al momento del pagamento con più indirizzi
Questo articolo spiega che la maggior parte dei metodi di pagamento non vengono visualizzati al momento del pagamento quando vengono utilizzati più indirizzi di spedizione, perché solo Cybersource supporta questa funzione.
Nota: l'integrazione del pagamento Adobe Commerce Cybersource di base è obsoleta a partire dalla versione 2.3.3 e verrà completamente rimossa nella versione 2.4.0. Utilizza invece l'estensione ufficiale dal marketplace.
Descrizione
Ambienti
- Adobe Commerce on-premise 2.x.x
- Adobe Commerce sull’infrastruttura cloud 2.x.x
Problema/Sintomi
Quando i clienti utilizzano più indirizzi di spedizione al momento del pagamento, la maggior parte dei metodi di pagamento non viene visualizzata. Questa funzione è supportata solo da Cybersource.
Prerequisiti:
In Commerce Admin, abilita e configura i metodi di pagamento PayPal e Cybersource. Abilita inoltre il multishipping per il tuo archivio.
Passaggi da riprodurre:
- Nella vetrina, aggiungi più prodotti al carrello.
- Vai alla pagina del carrello e fai clic su Estrai con più indirizzi.
- Accedi o crea un account.
- Nella pagina Spedisci a più indirizzi, dividi i prodotti tra gli indirizzi e fai clic su Vai alle informazioni sulla spedizione.
- Selezionare i metodi di spedizione per ogni spedizione e fare clic su Continua con informazioni fatturazione.
Risultato previsto:
PayPal e Cybersource vengono visualizzati come opzioni di pagamento disponibili.
Risultato effettivo:
Solo Cybersource viene visualizzato come opzione di pagamento disponibile.
Risoluzione
Causa
A partire dalla versione 2.2.4, Cybersource è l'unico metodo di pagamento live supportato per il pagamento multishipping. Il supporto per altri metodi di pagamento sarà probabilmente aggiunto uno alla volta. Non sono ancora presenti date di rilascio o numeri di versione confermati.