Impossibile salvare il backend Adobe Commerce dell’entità
Questo articolo fornisce una soluzione per i casi in cui non è possibile salvare un’entità nel backend di Adobe Commerce. Ad esempio, quando non è possibile modificare e salvare una regola cart_price
specifica.
Prodotti e versioni interessati
Questo problema può interessare tutte le versioni di Adobe Commerce in cui è configurata la dimensione massima della sessione. È stato aggiunto a partire dal Magento Open Source 2.3.7-p1 e da Adobe commerce (tutti i metodi di distribuzione) 2.4.3.
Problema
Quando tenti di riconfigurare lo store, la pagina viene ricaricata e le modifiche non vengono salvate. È possibile visualizzare un messaggio in var/log/system.log
:
Rapporto [2021-11-27 00:30:52].AVVISO: la dimensione della sessione di 418056 ha superato la dimensione massima di 256000 consentita per la sessione. [][]
Passaggi da riprodurre:
Esempio di configurazione dell’archivio non salvata:
- Seleziona una regola nell'archivio Adobe Commerce in Produzione > Marketing > Regole prezzo carrello.
- Scegliere una regola e impostarla su Inattiva e salvare la modifica.
Risultato previsto:
La regola è impostata su inattiva.
Risultato effettivo:
- La pagina viene ricaricata senza alcun messaggio.
- La regola è ancora impostata su attiva.
Causa
Questo problema è relativo alle nuove funzionalità introdotte di recente che hanno interessato la dimensione massima della sessione. Consulta Gestione delle sessioni nella documentazione per gli sviluppatori.
Soluzione
Aumentare il valore "Dimensione massima sessione" in (Archivi > Configurazione > Avanzate > Sistema > Sicurezza > Dimensione massima sessione).
Lettura correlata
- Menu Marketing nella guida utente.