Prestazioni lente a causa di pagine non memorizzabili in cache

Questo articolo fornisce soluzioni per l’aumento dei tempi di caricamento dei siti web o delle interruzioni dovute alla disattivazione della cache di pagina completa (ad esempio Fastly) per qualsiasi blocco su qualsiasi pagina/e che deve essere memorizzata in cache.

Prodotti e versioni interessati

  • Adobe Commerce sull’infrastruttura cloud 2.x.x
  • Adobe Commerce on-premise 2.x.x

Problema

Le prestazioni del sito sono rallentate perché nelle pagine sono presenti blocchi di cache che devono essere memorizzabili nella cache ma sono stati impostati su cacheable="false".

Causa

Alcune pagine devono essere memorizzate nella cache da Adobe Commerce. Queste pagine hanno il throughput più elevato. Ogni richiesta di questi tipi di pagine non dalla cache rallenta le prestazioni di Adobe Commerce.

Queste pagine sono:

  • Categoria catalogo (PLP)
  • Pagina dettagli prodotto (PDP)
  • Pagine di contenuti statici (home page, contattaci, ecc.)

I termini "memorizzabile in cache" e "non memorizzabile in cache" indicano se una pagina deve essere memorizzata in cache o meno. Per impostazione predefinita, tutte le pagine sono memorizzabili in cache. Tuttavia, se qualsiasi blocco in un layout è designato come non memorizzabile in cache, l’intera pagina non è memorizzabile in cache.

La schermata seguente mostra un blocco con un'impostazione cacheable="false" **​ ** che crea una pagina non memorizzabile in cache.

non_cacheable_kb.png

Esempi di pagine non memorizzabili in cache includono prodotti di confronto, carrello e pagine di pagamento.

I seguenti elenchi di pagine non vengono memorizzati in cache (le cache Fastly, Block e Layout vengono evitate). Ciò si verifica a causa della configurazione "memorizzabile in cache" nel layout.

Soluzione

Verificare se i file specificati sopra hanno l'impostazione cacheable="false". In caso affermativo, controlla se questa impostazione è necessaria o richiesta.

  • Se necessario, puoi spostare i blocchi non memorizzabili in cache in meccanismo di contenuto privato.
  • Se non è necessario, rimuovere l'attributo cacheable="false" e svuotare la cache di layout.
NOTE
Per Adobe Commerce su infrastruttura cloud 2.4.1 e versioni successive, puoi utilizzare Strumento di analisi a livello di sito per verificare automaticamente se la cache a pagina intera non è configurata correttamente.

Lettura correlata

Panoramica della cache di Adobe Commerce nella documentazione per gli sviluppatori.

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a