Questo articolo fornisce una soluzione per i casi in cui il file robots.txt
in Adobe Commerce è configurato correttamente, ma visualizza comunque le impostazioni predefinite o non viene aggiornato. Per risolvere questo problema, assicurati che l’indicizzazione da parte dei motori di ricerca sia abilitata.
Descrizione
Ambiente
Adobe Commerce sull’infrastruttura cloud 2.3.x, 2.4.x
Problema
Impossibile modificare le impostazioni predefinite di robots.txt
in Adobe Commerce.
Passaggi da riprodurre:
Risultato previsto:
Nel file robots.txt
viene visualizzato il contenuto personalizzato salvato.
Risultato effettivo:
Il file robots.txt
non viene modificato e continua a mostrare il contenuto predefinito.
Causa
L'indicizzazione da parte dei motori di ricerca è disabilitata, impedendo l'applicazione del contenuto robots.txt
personalizzato.
Risoluzione
Abilita l’indicizzazione tramite i motori di ricerca. Per istruzioni dettagliate, consulta Configurare l'indicizzazione tramite il motore di ricerca nella documentazione per gli sviluppatori.