Il problema di autorizzazione della cartella var/export Adobe Commerce su cloud
Questo articolo fornisce una soluzione a un problema che impedisce l'esportazione dei dati di prodotto a causa di un problema di autorizzazioni dei file sul server nella cartella var/export/email
. I sintomi includono esportazioni di prodotti e cataloghi non disponibili nell’interfaccia utente, ma visibili quando si utilizza SSH.
Prodotti e versioni interessati
Adobe Commerce su infrastruttura cloud, 2.3.0-2.3.7-p2, 2.4.0-2.4.3-p1
Problema
Impossibile esportare i file nella cartella var/export/email
o var/export/archive
.
La distribuzione non è riuscita a causa delle autorizzazioni su var/export/email
o var/export/email/archive
perché la cartella di archivio viene creata tramite e-mail e se eseguo solo l'esportazione/e-mail a volte c'è ancora un problema), a parte l'aggiunta di qualcosa all'account per la sottocartella var/export/email/archive
.
Passaggi da riprodurre:
In Amministrazione, vai a Sistema > Trasferimento dati > Esporta.
Selezionare i file CSV da salvare nella cartella var/export/
.
Risultato previsto:
I file CSV sono visibili e possono essere esportati.
Risultato effettivo:
I file CSV non sono visibili. Viene inoltre visualizzato un messaggio di autorizzazione negata: RecursiveDirectoryIterator::__costrutto(https://experienceleague.adobe.com/app/id%20progetto%3E/var/export/email?lang=it): impossibile aprire dir: autorizzazione negata
Viene visualizzato lo stesso messaggio per tutti i tipi di esportazione: Advanced Pricing, Customer Finances, Customer Main File e Customer Addresses.
Causa
La causa è una cartella creata all'interno di /var
con autorizzazioni imperfette: d-wxrwsr-T
. Il bit permanente T significa che gli utenti possono eliminare solo i file di loro proprietà, ma l'eseguibile mancante significa che non possono creare file nella directory.
Ciò viene spesso notato quando il sistema crea una cartella denominata export
, che contiene una cartella denominata email
, che contiene una cartella denominata archive
.
Per verificare se la directory dispone di queste autorizzazioni non configurate correttamente, eseguire il comando seguente in CLI/Terminal:
ls -ld var/export/
Se le autorizzazioni non sono configurate correttamente, l’output sarà:
d-wxrwsr-T 3 web web 4096 Aug 15 19:12 var/export/
Soluzione
Per risolvere questo problema, aggiorna le autorizzazioni delle cartelle a 777 e quindi tutti i file in modo ricorsivo, eseguendo i seguenti comandi:
chmod 777 var/export/
chmod 777 var/export/email/
chmod 777 var/export/email/archive/
chmod 777 -R var/export/
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