Errore di timeout del gateway 504 durante il salvataggio di una categoria con più di 1k prodotti

Questo articolo suggerisce una soluzione per il problema di timeout che potrebbe verificarsi quando si eseguono operazioni con categorie di grandi dimensioni (1k+ prodotti).

Prodotti e versioni interessati:

  • Adobe Commerce sull’infrastruttura cloud 2.3.3
  • Adobe Commerce on-premise 2.3.3
  • Magento Open Source 2.3.3

Problema

Prerequisiti: l'opzione Archivi > Configurazione > CATALOGO > Catalogo > Usa percorso categorie per URL prodotto è impostata su per la visualizzazione archivio.

Passaggi da riprodurre

  1. In Amministrazione Commerce, vai a Catalogo > Categorie.
  2. Apri una categoria grande, ad esempio più di 1000 prodotti assegnati.
  3. Aggiungi un prodotto alla categoria.
  4. Fai clic su Salva categoria.

Risultato previsto:

Categoria salvata correttamente.

Risultato effettivo:

Dopo cinque minuti di salvataggio del processo, viene visualizzata la pagina di errore di timeout del gateway 504.

Causa

Il processo richiede più tempo del timeout configurato dal server.

Soluzione

Se si disabilita l'opzione Genera URL "categoria/prodotto" Riscrittura, verranno rimosse dal database tutte le riscritture degli URL di categoria/prodotto e verrà ridotto in modo significativo il tempo necessario per le operazioni con categorie di grandi dimensioni.

WARNING
Se questa opzione viene disattivata, la rimozione permanente delle riscritture degli URL di categoria/prodotto non sarà più possibile ripristinarle.

Per disabilitare l'opzione Genera URL "categoria/prodotto" Riscrive:

  1. In Amministrazione Commerce, passa a Archivi > Configurazione > CATALOGO > Catalogo.
  2. Nell'angolo superiore sinistro della pagina di configurazione, nel campo Ambito, imposta l'ambito di configurazione su Configurazione predefinita.
  3. Impostare Genera URL "categoria/prodotto" Riscrive in No.
  4. Fai clic su Salva configurazione.
  5. Pulisci cache eseguendo bash bin/magento cache:clean o nell'amministratore di Commerce in Sistema > Strumenti > Gestione cache.

Ora è possibile aggiungere prodotti alle categorie o spostare le categorie con un numero elevato di prodotti. Queste operazioni richiederanno molto meno tempo e non dovrebbero causare timeout.

Lettura correlata

Reindirizzamenti automatici ai prodotti nella guida utente.

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a