Notes de mise à jour du dernier pack de services Adobe Experience Manager 6.5 aem-service-pack-release-notes

Informations sur la version release-information

Produit
Adobe Experience Manager 6.5
Version
6.5.19.0
Type
Mise à jour du pack de services
Date
Jeudi 7 décembre 2023
URL de téléchargement
Distribution logicielle 

Éléments compris dans Experience Manager 6.5.19.0 what-is-included-in-aem-6519

Experience Manager 6.5.19.0 comprend de nouvelles fonctionnalités, des améliorations importantes demandées par les clientes et les clients, des correctifs de bugs ainsi que des améliorations en termes de performances, de stabilité et de sécurité, publiées depuis la version initiale 6.5 en avril 2019. Installez ce pack de services dans Experience Manager 6.5.

Principales fonctionnalités et améliorations

Voici quelques-unes des fonctionnalités et améliorations clés de cette version :

  • Activation de la personne Éditeur de page/Composant d’image Sites pour référencer des ressources à partir du service cloud Assets à distance. (SITES-13448, SITES-13433)
  • AEM prend désormais en charge le tri côté serveur pour accélérer la navigation du projet en vue Liste. Les nœuds de projet sont triés en fonction de la colonne sélectionnée par l’utilisateur ou l’utilisatrice avant d’apparaître dans l’interface.

Forms

  • Nouveaux composants principaux de formulaires adaptatifs  : des onglets verticaux, des conditions générales et une case à cocher sont ajoutés pour améliorer l’évolutivité des formulaires.

    • Composant de case à cocher  : les formulaires adaptatifs basés sur les composants principaux peuvent désormais inclure un composant de case à cocher. Il permet aux utilisateurs et utilisatrices de faire des choix binaires, en sélectionnant ou en désélectionnant une option particulière. Il s’affiche généralement sous la forme d’une petite case sur laquelle vous pouvez cliquer ou appuyer pour basculer entre deux états : cochée et décochée. La case à cocher est un élément de formulaire courant, utilisé pour présenter un choix oui/non ou vrai/faux.

    • Composant Conditions générales  : les formulaires adaptatifs basés sur les composants principaux peuvent désormais inclure un composant Conditions générales. Il permet aux personnes créant les formulaires d’introduire une section spécifique dans le formulaire, dans laquelle les utilisateurs et utilisatrices peuvent consulter les conditions générales ou les accords juridiques associés à l’utilisation d’un service, d’un produit ou d’une plateforme. Ce composant est conçu pour informer les utilisateurs et utilisatrices des règles, des réglementations et des obligations qu’ils acceptent en envoyant le formulaire.

      Composants Onglets verticaux, Conditions générales et Case à cocher

    • Composant Onglets verticaux  : les formulaires adaptatifs basés sur les composants principaux peuvent désormais organiser le contenu des formulaires en une liste verticale d’onglets, ce qui assure une disposition structurée et navigable. L’utilisation d’onglets verticaux dans un formulaire peut améliorer l’expérience globale de l’utilisateur ou de l’utilisatrice en simplifiant la navigation et en améliorant l’organisation du contenu du formulaire, en particulier lorsqu’un formulaire contient plusieurs sections ou des informations complexes.

  • Version 64 bits d’AEM Forms Designer  : la version 64 bits d’AEM Forms Designer offre des performances, une évolutivité et une gestion de la mémoire améliorées pour optimiser votre expérience de création de formulaires. Grâce à l’architecture 64 bits, vous pouvez aborder facilement des projets plus volumineux et plus complexes, assurant ainsi des workflows de conception transparents et une efficacité optimisée. Améliorez encore vos capacités de conception de formulaire et accueillez l’avenir d’AEM Forms Designer avec cette version de pointe.

  • Connexion d’une Forms adaptative à une liste Microsoft® SharePoint: AEM Forms fournit une intégration prête à l’emploi pour envoyer les données de formulaire directement vers la liste SharePoint, ce qui vous permet d’utiliser les fonctionnalités de listes SharePoint. Vous pouvez configurer une liste Microsoft® SharePoint comme source de données pour un modèle de données de formulaire et utiliser l’action Envoyer à l’aide du modèle de données de formulaire pour connecter un formulaire adaptatif à la liste SharePoint.

  • Prise en charge de la configuration des propriétés de document d’enregistrement pour les fragments de formulaire adaptatif  : vous pouvez désormais personnaliser facilement vos fragments de formulaire adaptatif et ses champs dans l’éditeur de formulaire adaptatif.

  • XMLFM 64 bits  : l’itération 64 bits de XMLFM améliore les performances, l’évolutivité et la gestion de la mémoire. Il s’agit du premier service natif 64 bits déployé côté serveur. En exploitant sa capacité intrinsèque à accéder à des ressources de mémoire plus importantes par rapport à son équivalent 32 bits, XMLFM 64 bits permet une gestion transparente des charges de travail de rendu plus lourdes. Ce jalon représente non seulement un bond en avant en termes de performances, mais il introduit également des améliorations clés du framework de service natif dans le serveur AEM Forms. Cette mise à jour permet au serveur AEM Forms de prendre en charge n’importe quel service natif 64 bits en toute transparence.

Problèmes corrigés dans le Pack de services 19 fixed-issues

Sites sites-6519

Accessibilité sites-accessibility-6519

  • Sur une page AEM Sites, lorsque vous effectuez un zoom avant de 200 %, les liens Copie de la langue et Rapport CSV dans le rail Références disparaissent. (SITES-11011)

Interface utilisateur d’administration sites-adminui-6519

  • La fonctionnalité Canal AEM Screens Aperçu ne fonctionne pas ou ne s’affiche pas dans le tableau de bord. (SITES-15730)
  • Lors d’une opération de déplacement de page, si l’interface utilisateur ne peut pas afficher les références mais indique qu’elles sont automatiquement republiées, elles ne sont pas republiées. (SITES-16435)
  • Dans AEM 6.5 avec Pack de services 16 ou 17, dans la vue Liste des sites pour lesquels la colonne « Workflow » est activée, vous ne pouvez pas trier la liste en fonction des éléments de cette colonne. Aucun tri n’est effectué. (SITES-15385)
  • Pour un modèle de page de redirection, le champ de redirection est devenu obligatoire. Cependant, la validation du champ obligatoire n’est pas appliquée ni ne fonctionne dans ces deux scénarios : lorsqu’une page est créée sans valeur de redirection obligatoire ; il n’est pas possible de créer de page de redirection. La validation ne fonctionne pas lors de la navigation à l’aide de raccourcis clavier. Lorsque le champ est marqué comme non valide, elle ne se poursuit pas. (SITES-15903)
  • Certains Liens entrants n’étaient pas inclus dans le nombre affiché dans le panneau Références. Par exemple, le panneau affichait Liens entrants (6) mais il y avait en fait neuf liens entrants. (SITES-14816)

Interface utilisateur classique sites-classicui-6519

  • Après l’installation du correctif dans SITES-15827, les titres des boîtes de dialogue qui avaient un espace entre les mots étaient remplacés par " ". Les sauts de ligne étaient également supprimés. (SITES-16089)
  • Les titres des boîtes de dialogue codés entraînent désormais un double codage du titre. (SITES-15841)
  • La mise à jour des serveurs AEM du Pack de services 6.5.16 vers 6.5.17 entraînait un double codage des titres des boîtes de dialogue de l’interface utilisateur classique. (SITES-15634)

Content Fragments sites-contentfragments-6519

  • Un message d’erreur de serveur interne s’affiche dans l’éditeur de fragments de contenu. (SITES-13550)
  • La mise à jour de la bibliothèque org.json par le biais de NPR-41291 provoquait des conversions d’erreur de données dans le DefaultDataTypeConverter du bundle cfm-impl. La conversion du type de données doit être plus flexible. (SITES-16473)
  • Obtention du message pop-up d’erreur « Cette version de fragment de contenu ne peut pas être comparée à la version actuelle en raison d’un contenu incompatible. » Les fragments de contenu doivent être comparables, mais ce n’est pas le cas. (SITES-16317)
  • Modification de l’URL JS du sélecteur de ressources de
    https://experience.adobe.com/solutions/CQ-assets-selectors/assets/resources/assets-selectors.js
    vers
    https://experience.adobe.com/solutions/CQ-assets-selectors/static-assets/resources/assets-selectors.js (SITES-16068)
  • Adaptez le nouveau schéma de réponse de l’API de métadonnées Polaris à l’intégration CFM-Polaris. (SITES-15166)
  • Tous les fragments de contenu doivent être répertoriés là où le fragment de contenu sélectionné est référencé. Au lieu de cela, les références de ressources dans le panneau de référence de fragment de contenu affichent 0 (zéro) référence. (SITES-15036)

Back-end principal sites-core-backend-6519

  • Améliorez StyleImpl. (SITES-15164)
  • Améliorez la version/branche 650 du pipeline WCM pour pouvoir exécuter des tests d’intégration pour ses modules. (SITES-12938)

Intégration de campagne sites-campaign-integration-6519

  • Sur le composant de signature (/apps/fpl/components/campaign/signature), l’externaliseur de liens ne fonctionnait pas. Le domaine n’était pas annexé à la source de l’image, si le commentaire HTML situé au-dessus de la balise de l’image était supprimé. Ce problème a été détecté uniquement avec le composant de signature dans l’environnement de production, et non dans l’environnement d’évaluation. (SITES-16120)

Composants de base (hérités) sites-foundation-components-legacy-6519

  • Le composant Recherche de sites Adobe Experience Manager (AEM) rompt l’interface utilisateur. (SITES-15087)

Éditeur de requête GraphQL sites-graphql-query-editor-6519

  • L’interface utilisateur de l’éditeur GraphQL ne vous permet pas de parcourir toutes les requêtes persistantes lorsqu’il y a un nombre élevé de requêtes (plus de 25, par exemple). (SITES-16008)
  • L’éditeur GraphQL n’enregistre pas le statut de publication des requêtes persistantes. Le bouton Annuler la publication s’affiche dans l’éditeur GraphQL, mais l’icône indiquant que la requête persistante est publiée n’apparaît pas. Une actualisation de la page affiche que la requête persistante n’est même pas publiée. (SITES-15858)

Lancements sites-launches-6519

  • Les modifications du référentiel ne sont pas enregistrées en raison de conflits Oak0001 lorsque plusieurs pages sont en cours de modification ou que du contenu est en cours de création. Il est normal d’effectuer une nouvelle tentative dans un tel cas, mais cela ne se produit pas. (SITES-14840)

MSM - Live Copies sites-msm-live-copies-6519

  • Le bouton Déploiement MSM ne fonctionne pas dans l’interface utilisateur graphique tactile. (SITES-16991)
  • La référence de lien n’est pas mise à jour dans un fragment d’expérience lors de la création d’une Live Copy ou du déploiement d’un fragment d’expérience. (SITES-15460)

Éditeur de page sites-pageeditor-6519

  • Dans Forms > Thèmes, si vous avez ouvert un thème dans l’éditeur de thèmes, que vous avez apporté des modifications que vous enregistrées, puis que vous avez cliqué sur Aperçu, qu’une icône de chargement est visible, mais que l’aperçu réel ne se charge pas. (SITES-17164)
  • La sélection de plusieurs types de fichiers de document sur le filtre de type de ressource ne fonctionne pas sur la console de page. Aucun résultat n’est trouvé même si les résultats d’un type de fichier particulier sont disponibles. Par conséquent, les auteurs et les autrices ne peuvent pas filtrer plusieurs documents. Ils ou elles doivent utiliser plusieurs types de documents et les filtrer un par un. (SITES-14047)
  • Après la mise à niveau d’une instance à partir d’AEM 6.5.17 et d’AEM 6.5.18, depuis l’éditeur de page, si vous sélectionnez Publier la page, vous accédez à une URL qui n’existe pas. La personne doit être redirigée vers l’assistant de publication. (SITES-15856)
  • Copie redondante du Presse-papiers d’AEM lors d’un collage à partir du Presse-papiers du système d’exploitation. (SITES-15704)
  • Dans Ressources, la sélection de Documents puis, sous Filtertype, la sélection de Microsoft® Word ou Microsoft® Excel n’affichent aucun résultat, même si des fichiers des deux types existent. (SITES-14837)

Assets assets-6519

  • Lorsque vous créez ou enregistrez un dossier public, trois groupes sont créés dans un tableau de bord d’administration. (ASSETS-26700)
  • Impossible de différencier les ressources de publication dans Experience Manager ou Brand Portal. (NPR-41320)
  • Dans le panneau de recherche, lorsque vous sélectionnez des cases à cocher et désélectionnez l’une d’entre elles, toutes les cases sont décochées. (ASSETS-26377)

Dynamic Media assets-dm-6519

  • Une fois qu’une ressource est chargée dans AEM, le workflow update_asset est déclenché. Le workflow ne se termine jamais. En examinant les instances de workflow, le workflow se termine jusqu’à l’étape de chargement du produit. L’étape suivante est le chargement par lots de Scene7. L’utilisateur ou l’utilisatrice peut constater que la ressource se trouve dans Scene7 à partir de l’application Dynamic Media Classic. (ASSETS-30443)
  • Un servlet (point d’entrée d’API) personnalisé renvoie un nom de fichier Dynamic Media (Scene7) incorrect. Cela se produit lorsqu’une ressource est supprimée et remplacée par une ressource du même nom. Le servlet personnalisé renvoie l’ancien nom de fichier Dynamic Media (Scene7), tandis qu’un appel API « jcr » renvoie le nom de fichier correct. (ASSETS-29476)
  • Même après la désactivation de la synchronisation au niveau du dossier, les journaux affichent le déclencheur de « Scene7 ReplicateOnModifyListener ». ReplicateOnModifyListener/Worker doit ignorer le traitement des ressources de dossier et des fragments de contenu autres que Dynamic Media. (ASSETS-26705)
  • Les personnes souffrant d’une déficience visuelle sont affectées si le focus n’est pas visible dans les éléments de liste déroulante (Contenu uniquement, Afficher, Plus d’options) en modes noir et blanc à contraste élevé. (ASSETS-25759)
  • Les personnes souffrant d’une déficience visuelle sont affectées si le rapport de contraste de luminosité du texte sur une page est inférieur à 4.5:1. (ASSETS-25756)
  • Les lecteurs d’écran ne délivrent pas le message pop-up affiché après l’envoi des données. (ASSETS-25755)
  • Les lecteurs d’écran ne reconnaissent pas les repères dans la page (Dynamic Media ; création d’un profil de codage vidéo), lorsqu’ils naviguent à l’aide de la touche de raccourci de repère/région D/R. (ASSETS-25752)
  • Les lecteurs d’écran ne reconnaissent pas plusieurs repères dans la page (Dynamic Media ; création d’une vidéo interactive), lorsqu’ils naviguent à l’aide de la touche de raccourci de repère/région D/R. (ASSETS-25750)
  • Les lecteurs d’écran (NVDA/JAWS/Narrator) ne reconnaissent pas les repères dans Modifier la ressource lors de la navigation à l’aide des touches de raccourci D/R. (ASSETS-25744)
  • L’utilisateur ou l’utilisatrice obtient un message de traitement asynchrone vide/faux, mais la ressource connectée est publiée avec succès. (ASSETS-29342)

Forms forms-6519

Adaptive Forms

  • Lorsqu’un utilisateur ou une utilisatrice ajoute une barre d’outils au formulaire adaptatif, le libellé du conteneur de formulaires affiche un comportement imprévisible, car il n’adopte pas la langue préférée sélectionnée par la personne pour Forms. (FORMS-11371)
  • Dans l’espace de travail AEM Forms, le champ déroulant sélectionne la première option par défaut sur l’interface utilisateur. (FORMS-11346)
  • La configuration de la langue dans AEM n’est pas modifiée si vous utilisez des paramètres régionaux à cinq caractères et que le séparateur décimal n’est pas correctement rendu dans la lettre. (FORMS-11344)
  • Lorsqu’un utilisateur ou une utilisatrice génère la sortie XML à l’aide du processus Workbench, l’opération échoue pour certains fichiers. (FORMS-11314)
  • Lorsqu’un utilisateur ou une utilisatrice génère un aperçu du document d’enregistrement (DOR) dans des langues autres que l’anglais, cela ne fonctionne pas. (FORMS-11106)
  • Lorsqu’un utilisateur ou une utilisatrice convertit certains fichiers image avec PDFG sur une instance OSGI basée sur Linux® avec JDK11, la conversion n’a pas lieu. (FORMS-11105)
  • Lorsqu’un utilisateur ou une utilisatrice installe le module complémentaire AEM Forms, cela dégrade le panneau de l’arborescence de contenu dans AEM Sites. (FORMS-10912)
  • Lorsqu’un utilisateur ou une utilisatrice copie des dates à l’aide d’un lecteur d’écran NVDA à partir du composant de sélecteur de date, la lecture n’est pas correcte. (FORMS-10805)
  • Dans l’éditeur de règles des formulaires, l’utilisateur ou l’utilisatrice ne peut pas définir la valeur du bouton radio/de la case à cocher lorsque le type de valeur de données est Booléen. (FORMS-10713)
  • Lorsqu’un utilisateur ou une utilisatrice ajoute des éléments dans un formulaire adaptatif, l’ajout se fait dans l’ordre inverse à celui d’une liste déroulante. (FORMS-10456)
  • Lorsqu’une liste déroulante est effacée à l’aide de l’éditeur de règles, la première valeur fournie s’affiche toujours, même si la valeur a été effacée. (FORMS-9963)
  • Les utilisateurs et utilisatrices ne peuvent pas accéder au titre du formulaire à l’aide de lecteurs d’écran tels que NVDA. (FORMS-8815)
  • Les utilisateurs et utilisatrices ne peuvent pas accéder au Sub Title d’un formulaire à l’aide de lecteurs d’écran tels que NVDA. (FORMS-8814)
  • Dans la page source du formulaire HTML, l’attribut de clé d’accès est vide et ne fonctionne pas. (FORMS-5753)
  • Dans la boîte de dialogue À propos de Workspace, la mention « Adobe Experience Manager – Forms » est présentée sous forme de texte. (FORMS-5748)

Forms Designer forms-designer-6519

  • Lorsqu’un utilisateur ou une utilisatrice tente de lire des formulaires PDF non interactifs par le biais de lecteurs d’écran, certains éléments de liste ne sont pas lus ou sont ignorés. (LC-3921645)
  • Lorsqu’un utilisateur ou une utilisatrice parcourt les champs modifiables à l’aide de tabulations, tous les champs de formulaire du PDF ne sont pas parcourus de manière homogène. (LC-3921631)
  • L’ordre des balises est modifié de manière aléatoire dans le PDF, même si le balisage dans le concepteur de formulaires est correct. (LC-3921313)
  • Une liste ne s’affiche pas correctement dans les balises d’Adobe Acrobat Reader ou Adobe Acrobat DC. (LC-3921306)
  • Les niveaux d’en-tête correctement attribués dans le concepteur de formulaires sont changés aléatoirement en balise <P> dans Adobe Acrobat. (LC-3921305)
  • Dans un tableau, l’identifiant d’un objet quelconque ne peut pas être modifié une fois qu’il a été attribué. (LC-3921134)
  • Si des cellules fusionnées se trouvent dans le tableau, aucune interface utilisateur graphique n’est disponible pour définir la plage (ligne et colonne) et la portée dans un tableau complexe du concepteur de formulaires AEM. (LC-3919532)
  • Lorsqu’un utilisateur ou une utilisatrice tente de générer des documents PDF après avoir installé le package de modules complémentaires Forms sur le pack de services AEM Forms 6.5.15.0, la procédure échoue de manière intermittente et affiche l’erreur :
    • OutputServiceException AEM_OUT_001_003:Unexpected Exception: 0 Out of Memory Caused by: org.omg.CORBA.COMM_FAILURE: null (LC-3921530)

Foundation foundation-6519

  • La création d’une copie de langue au niveau racine de la langue n’ajuste pas les chemins d’accès dans la page. Dans le cas où la copie de langue a été créée, pas pour la racine de langue mais pour les pages qui la composent, le chemin d’accès a correctement changé. (NPR-41364)
  • L’info-bulle « Présentation de la date relative » ne peut être fermée qu’en appuyant sur Échap (ESC) sur le clavier. L’info-bulle doit se fermer lorsque l’utilisateur ou l’utilisatrice sélectionne une partie de l’interface utilisateur. (NPR-41394)
  • Chaîne non localisée Something went wrong while adding the private key. lors de l’ajout d’un fichier de clé privée incorrect dans Modifier l’utilisateur  > Keystore. (NPR-41366)
  • Des icônes sont nécessaires pour Microsoft® SharePoint et Microsoft® One Drive dans l’environnement AEM 6.5. (NPR-41354)
  • Chaîne « UserId/Password mismatch » non localisée. dans la boîte de dialogue Sécurité  > Utilisateur  > Créer. (NPR-41245)
  • Le code de fenêtre contextuelle et les gestionnaires d’événements sont chargés deux fois, rompant les interfaces utilisateur basées sur Coral3 créées par l’utilisateur ou l’utilisatrice. (NPR-41171)
  • La désélection ne fonctionne pas correctement après l’utilisation de « Sélectionner tout » dans la console AEM Sites. (NPR-41304)

Intégrations integrations-6519

  • Les liens SMS dans une campagne par e-mail AEM ne sont pas correctement écrits ; ils contiennent un élément d’ancrage HTML. (NPR-41211)
  • Les libellés utilisés sur l’écran de configuration du compte ne doivent pas utiliser de nouveau type d’informations d’identification. (NPR-41210)
  • Déplacement du planificateur d’import de rapports Analytics de ManagedPollConfig vers des tâches Sling. Lorsque deux structures d’analyse différentes ont été associées avec des suites de rapports différentes à deux sites différents, ManagedPollConfig n’en analyse qu’une. (NPR-41209)
  • Lorsque la valeur est réinitialisée sur la valeur par défaut, le bouton de période précédemment sélectionné reste activé. Dans le tableau de bord Content Insight d’AEM, la période est définie par défaut sur la semaine et affiche les informations sur le contenu sous forme de données hebdomadaires. Désormais, si l’utilisateur ou l’utilisatrice sélectionne d’autres options de période, telles que l’heure, le jour, le mois et l’année, les données changent en fonction de la valeur sélectionnée. Cependant, si les valeurs sont réinitialisées, par défaut, la période visible est la semaine, mais l’option de période précédemment sélectionnée est toujours sélectionnée. (NPR-41246)

Oak oak-6519

  • Utilitaire de rétroportage permettant de comptabiliser les écritures de limite dans AEM en cas de retard de l’indexation asynchrone. (NPR-40985)

Plateforme foundation-platform-6519

  • Les requêtes QueryBuilder avec crochets sont incorrectement traduites en xpath. (NPR-41298)

Projets de traduction foundation-translation-6519

  • Lors de la création de la copie de langue de la page « A », elle doit automatiquement créer les copies de langue des pages, des fragments d’expérience, des fragments de contenu et des ressources référencés. En outre, la nouvelle copie de langue de la page « A » sur le nouveau chemin d’accès doit avoir ses références mises à jour sur les nouvelles copies de langue respectives des pages, des fragments d’expérience, des fragments de contenu et des ressources. (NPR-41076)

Workflow foundation-workflow-6519

  • Impossible d’effectuer une tâche dans la boîte de réception. Seule une valeur « non définie » est observée dans le menu déroulant lorsque vous essayez d’effectuer la tâche et de sélectionner une action. Cela signifie que les utilisateurs et les utilisatrices ne peuvent pas appliquer le Pack de services AEM 6.5.18. (NPR-41402 et NPR-41473)
  • Impossible d’effectuer les tâches dans la boîte de réception. Il n’existe aucune valeur (« non définie » uniquement) dans la liste déroulante lorsque vous essayez d’exécuter la tâche pour les fichiers zip, les rapports de ressources, le déplacement (succès ou échec) ou l’expiration de la ressource. (NPR-41305)
  • Lorsqu’un utilisateur ou une utilisatrice sélectionne Outils  > Workflow  > instances, sélectionne le workflow en cours d’exécution, puis Afficher la charge utile, cela génère une page d’erreur 500. (NPR-41325)

Installer Experience Manager 6.5.19.0 install

  • Experience Manager 6.5.19.0 nécessite Experience Manager 6.5. Consultez la documentation de mise à niveau pour des instructions détaillées.
  • Le téléchargement du Pack de services est disponible dans la Distribution logicielle d’Adobe.
  • Lors d’un déploiement avec MongoDB et plusieurs instances, installez Experience Manager 6.5.19.0 sur l’une des instances de création à l’aide du gestionnaire de modules.
IMPORTANT
Adobe ne recommande pas de supprimer ou de désinstaller le package Experience Manager 6.5.19.0. Par conséquent, avant d’installer le module, vous devez créer une sauvegarde du crx-repository au cas où vous auriez besoin de le restaurer.

Installation du pack de services sur Experience Manager 6.5 install-service-pack

  1. Redémarrez l’instance avant l’installation si l’instance est en mode de mise à jour (lorsque l’instance a été mise à jour à partir d’une version antérieure). Adobe recommande un redémarrage si le temps de disponibilité actuel d’une instance est élevé.

  2. Avant l’installation, prenez un instantané ou exécutez une sauvegarde récente de votre instance Experience Manager.

  3. Téléchargez le pack de services à partir de la Distribution logicielle

  4. Ouvrez le gestionnaire de modules et cliquez sur Charger le module pour charger le module. Pour en savoir plus, consultez la section Gestionnaire de modules.

  5. Sélectionnez le module, puis sélectionnez Installer.

  6. Pour mettre à jour le connecteur S3, arrêtez l’instance après l’installation du pack de services, remplacez le connecteur existant par un nouveau fichier binaire fourni dans le dossier d’installation, puis redémarrez l’instance. Consultez la section Entrepôt de données S3 Amazon.

NOTE
La boîte de dialogue de l’interface utilisateur du gestionnaire de packages se ferme parfois pendant l’installation du pack de services. Adobe recommande d’attendre que les journaux d’erreurs se stabilisent avant d’accéder au déploiement. Attendez les journaux spécifiques liés à la désinstallation de la mise à jour complète pour vous assurer que l’installation est réussie. En règle générale, ce problème se produit dans Safari mais peut se produire par intermittence sur n’importe quel navigateur.

Installation automatique

Vous pouvez utiliser deux méthodes différentes pour installer automatiquement Experience Manager 6.5.19.0.

  • Placez le package dans le dossier ../crx-quickstart/install lorsque le serveur est disponible en ligne. Le package est automatiquement installé.
  • Utilisez l’API HTTP à partir du gestionnaire de packages. Utilisez cmd=install&recursive=true afin que les packages imbriqués soient installés.
NOTE
Experience Manager 6.5.19.0 ne prend pas en charge l’installation en Bootstrap.

Validation de l’installation

Pour connaître les plateformes certifiées pour travailler avec cette version, reportez-vous à la section des exigences techniques.

  1. La page d’informations sur les produits (/system/console/productinfo) affiche le numéro de version mis à jour Adobe Experience Manager (6.5.19.0) sous Produits installés. .

  2. Tous les bundles OSGi sont au statut ACTIF ou FRAGMENT dans la console OSGi (utilisez la console web : /system/console/bundles).

  3. Le bundle OSGi org.apache.jackrabbit.oak-core est de la version 1.22.17 ou ultérieure (utiliser la console web : /system/console/bundles).

Installer le Pack de services pour Experience Manager Forms install-aem-forms-add-on-package

Pour obtenir des instructions sur l’installation du Pack de services sur Experience Manager Forms, voir les instructions d’installation du Pack de services Experience Manager Forms.

NOTE
La fonctionnalité de formulaires adaptatifs, disponible dans AEM 6.5 QuickStart, est conçue à des fins d’exploration et d’évaluation uniquement. Pour une utilisation à des fins de production, il est essentiel d’obtenir une licence valide pour AEM Forms, car la fonctionnalité de formulaires adaptatifs nécessite une licence appropriée.

Installer le package d’index GraphQL pour les fragments de contenu d’Experience Manager install-aem-graphql-index-add-on-package

La clientèle qui utilise GraphQL doit installer le fragment de contenu d’Experience Manager avec le package d’index GraphQL 1.1.1.

Vous pouvez ainsi ajouter la définition d’index requise selon les fonctionnalités que vous utilisez réellement.

L’échec de l’installation de ce package peut entraîner des requêtes GraphQL lentes ou en échec.

NOTE
N’installez ce package qu’une seule fois par instance ; il n’est pas nécessaire de le réinstaller avec chaque Pack de services.

UberJar uber-jar

UberJar pour Experience Manager 6.5.19.0 est disponible dans le référentiel central Maven.

Pour utiliser UberJar dans un projet Maven, consultez la section Utilisation d’UberJar et incluez la dépendance suivante dans le POM de votre projet :

<dependency>
     <groupId>com.adobe.aem</groupId>
     <artifactId>uber-jar</artifactId>
     <version>6.5.19</version>
     <scope>provided</scope>
</dependency>
NOTE
UberJar et les autres artefacts associés sont disponibles sur le référentiel central Maven au lieu du référentiel Maven public Adobe (repo.adobe.com). Le fichier UberJar principal est renommé uber-jar-<version>.jar. Il n’existe donc pas de classifier avec apis comme valeur pour la balise dependency.

Fonctionnalités obsolètes et supprimées removed-deprecated-features

Consultez les fonctionnalités obsolètes et supprimées.

Problèmes connus known-issues

  • Lié à Oak
    Depuis le pack de services 13 et les versions ultérieures, le journal d’erreur suivant a commencé à s’afficher, ce qui affecte le cache de persistance :

    code language-shell
    org.h2.mvstore.MVStoreException: The write format 1 is smaller than the supported format 2 [2.0.202/5]
    at org.h2.mvstore.DataUtils.newMVStoreException(DataUtils.java:1004)
        at org.h2.mvstore.MVStore.getUnsupportedWriteFormatException(MVStore.java:1059)
        at org.h2.mvstore.MVStore.readStoreHeader(MVStore.java:878)
        at org.h2.mvstore.MVStore.<init>(MVStore.java:455)
        at org.h2.mvstore.MVStore$Builder.open(MVStore.java:4052)
        at org.h2.mvstore.db.Store.<init>(Store.java:129)
    

    Ou

    code language-shell
    org.h2.mvstore.MVStoreException: The write format 1 is smaller than the supported format 2 [2.1.214/5].
    

    Pour résoudre cette exception, procédez comme suit :

    1. Supprimez les deux dossiers suivants de crx-quickstart/repository/

      • cache
      • diff-cache
    2. Installez le Pack de services ou redémarrez Experience Manager as a Cloud Service.
      Les nouveaux dossiers cache et diff-cache sont automatiquement créés et vous ne voyez plus d’exception liée à mvstore dans error.log.

  • Mettez à jour vos requêtes GraphQL qui peuvent avoir utilisé un nom d’API personnalisé pour votre modèle de contenu afin d’utiliser plutôt le nom par défaut du modèle de contenu.

  • Une requête GraphQL peut utiliser l’index damAssetLucene plutôt que l’index fragments. Il peut en résulter l’échec des requêtes GraphQL ou l’exécution de celles-ci peut prendre beaucoup de temps.

    Pour résoudre le problème, damAssetLucene doit être configuré pour inclure les deux propriétés suivantes sous /indexRules/dam:Asset/properties :

    • contentFragment

      • jcr:primaryType="nt:unstructured"
      • name="jcr:content/contentFragment"
      • propertyIndex="{Boolean}true"
      • type="Boolean"
    • model

      • jcr:primaryType="nt:unstructured"
      • name="jcr:content/data/cq:model"
      • ordered="{Boolean}true"
      • propertyIndex="{Boolean}true"
      • type="String"

    Une fois la définition d’index modifiée, une réindexation est nécessaire (reindex = true).

    Après ces étapes, les requêtes GraphQL doivent être plus rapides.

  • Lorsque vous tentez de déplacer, de supprimer ou de publier des fragments de contenu, des sites ou des pages, un problème se produit lorsque les références aux fragments de contenu sont récupérées, car la requête en arrière-plan échoue. En d’autres termes, la fonctionnalité ne fonctionne pas.
    Pour garantir le bon fonctionnement de cette opération, vous devez ajouter les propriétés suivantes au nœud de définition d’index /oak:index/damAssetLucene (aucune réindexation n’est requise) :

    code language-xml
    "tags": [
        "visualSimilaritySearch"
      ]
    "refresh": true
    
  • Lors de l’exécution d’une requête GraphQL avec des variables facultatives, si une valeur spécifique n’est pas fournie pour la variable facultative, la valeur de cette dernière sera considérée comme une valeur null implicite. Cela signifie que le filtre correspondra uniquement aux valeurs null pour la propriété correspondante.

    Par exemple, dans la requête ci-dessous, où aucune valeur n’est spécifiée pour la propriété lastName :

    code language-graphql
    query getAuthorsFilteredByLastName($authorLastName: String) {
    authorList(filter:
      {
        lastName: {_expressions: {value: $authorLastName}
        }}) {
      items {
        lastName
        }
      }
    }
    

    Uniquement les auteurs et autrices dont la propriété lastName est définie sur null seront renvoyés :

    code language-graphql
    {
    "data": {
      "authorList": {
        "items": [
          {
            "lastName": null
          }
        ]
      }
    }
    }
    
  • Si vous mettez à niveau votre instance Experience Manager de 6.5.0 à 6.5.4, jusqu’au dernier Service Pack sur Java™ 11, les exceptions RRD4JReporter s’affichent dans le fichier error.log. Pour arrêter les exceptions, redémarrez votre instance d’Experience Manager.

  • Les utilisateurs peuvent renommer un dossier dans une hiérarchie dans Assets et publier un dossier imbriqué dans Brand Portal. Toutefois, le titre du dossier n’est pas mis à jour dans Brand Portal jusqu’à ce que le dossier racine soit republié.

  • Les erreurs et messages d’avertissement suivants peuvent s’afficher lors de l’installation d’Experience Manager 6.5.x.x :

    • « Lorsque l’intégration d’Adobe Target est configurée dans Experience Manager à l’aide de l’API Target Standard (authentification IMS), l’exportation de fragments d’expérience vers Target entraîne la création de types d’offres incorrects. » Au lieu du type « Fragment d’expérience » / source « Adobe Experience Manager », Target crée plusieurs offres avec le type « HTML » / source « Adobe Target Classic ».
    • com.adobe.granite.maintenance.impl.TaskScheduler : aucune fenêtre de maintenance n’a été trouvée sur granite/operations/maintenance.
    • La validation côté serveur du formulaire adaptatif échoue lorsque des fonctions d’agrégat telles que SUM, MAX et MIN sont utilisées (CQ-4274424).
    • com.adobe.granite.maintenance.impl.TaskScheduler - Aucune fenêtre de maintenance n’a été trouvée sur granite/operations/maintenance.
    • La zone réactive d’une image interactive de Dynamic Media n’est pas visible lors de la prévisualisation du fichier via la visionneuse de bannières avec achat.
    • com.adobe.cq.social.cq-social-jcr-provider bundle com.adobe.cq.social.cq-social-jcr-provider:1.3.5 (395)[com.adobe.cq.social.provider.jcr.impl.SpiSocialJcrResourceProviderImpl(2302)] : temporisation en attente de modification d’enregistrement pour terminer la désinscription.
  • À partir de la version 6.5.15 d’AEM, le moteur JavaScript Rhino fourni par le lot org.apache.servicemix.bundles.rhino a un nouveau comportement d’hébergement. Les scripts qui utilisent le mode strict (use strict;) doivent déclarer correctement leurs variables, sinon ils ne seront pas exécutés et génèreront une erreur d’exécution.

Problèmes connus d’AEM Forms

Plateformes prises en charge

  • JDK 11.0.20 n’est pas pris en charge pour installer le programme d’installation AEM Forms on JEE. Seules la version JDK 11.0.19 ou les versions antérieures sont prises en charge pour installer le programme d’installation AEM Forms on JEE. (FORMS-10659)

Installation

  • Sur la plateforme JBoss® 7.1.4, lorsque l’utilisateur ou l’utilisatrice installe le pack de services Experience Manager 6.5.16.0, le déploiement de adobe-livecycle-jboss.ear échoue. (CQ-4351522, CQDOC-20159)

Installer le fragment de servlet (Pack de services AEM 6.5.14.0 ou version antérieure)

  • Si vous effectuez une mise à niveau vers le pack de services 6.5.15.0 ou une version ultérieure et que votre instance AEM fonctionne sur Tomcat 8.5.88, il est obligatoire d’installer le fragment de servlet avant de procéder à l’installation du pack de services 6.5.15.0 ou de toute version ultérieure.
  • Il est obligatoire d’installer le fragment de servlet pour tous les serveurs d’applications, à l’exception de ceux qui s’exécutent sur JBoss® EAP 7.4.0.

Pour installer le fragment de servlet :

  1. Téléchargez le fragment de servlet à partir de la Distribution logicielle.
  2. Démarrez le serveur d’applications.
  3. Attendez que les journaux se stabilisent et vérifiez l’état du bundle.
  4. Ouvrez les lots de la console web. L’URL par défaut est http://[Server]:[Port]/system/console/bundles.
  5. Cliquez sur Installer ou Mettre à jour.
  6. Sélectionner le fragment téléchargé
    org.apache.felix.http.servlet-api-1.2.0_fragment_full.jar
  7. Cliquez sur Installer ou Mettre à jour.
  8. Attendez que le serveur d’applications se stabilise.
  9. Arrêtez le serveur d’applications.

Formulaires adaptatifs

  • Lorsqu’un formulaire adaptatif est publié, toutes ses dépendances, y compris les stratégies, sont republiées, même si aucune modification ne leur a été apportée. (FORMS-10454)
  • Lorsqu’un utilisateur ou une utilisatrice choisit de configurer un champ pour la première fois dans un formulaire adaptatif, l’option permettant d’enregistrer une configuration ne s’affiche pas dans l’explorateur de propriétés. Sélectionner un autre champ du formulaire adaptatif à configurer dans le même éditeur pour résoudre le problème.
  • Lorsque des utilisateurs ou des utilisatrices exécutent l’action d’envoi, l’envoi échoue avec une erreur :
    javax.servlet.ServletException: java.lang.NoSuchMethodError
    Pour résoudre le problème, recompilez les scripts Sling tels que JSP, Java™ et Sightly. (FORMS-8542)
  • Après avoir installé le Pack de services AEM 6.5.14.0 et versions ultérieures, les utilisateurs et utilisatrices ne peuvent pas sélectionner de police dans l’interface utilisateur d’administration de JEE pour les documents PDF lorsqu’ils accèdent à Home > Services > PDF Generator > Adobe PDF Settings, car la liste des polices s’affiche vide. (FORMS-12095)
  • Le Forms adaptatif vous permet d’utiliser des fonctions personnalisées avec ECMAScript version 5 ou antérieure. Lorsqu’une fonction personnalisée utilise ECMAScript version 6 ou ultérieure, comme les fonctions "let", "const" ou flèches, l’éditeur de règles peut ne pas s’ouvrir correctement.

d’AEM Forms on JEE

  • Des vulnérabilités de sécurité critiques ont été signalées pour Struts 2 RCE, un framework d’applications web populaire et open source pour le développement d’applications web Java EE. Adobe a publié le pack de services 19.1 (6.5.19.1) pour AEM 6.5 afin de résoudre la vulnérabilité dans AEM Forms on JEE.

Communications interactives

    • Le service de préremplissage échoue avec une exception de pointeur null. (CQDOC-21355)

Bundles OSGi et packages de contenu inclus osgi-bundles-and-content-packages-included

Les documents texte suivants répertorient les bundles OSGi et les packages de contenu inclus dans Experience Manager 6.5.19.0 :

Sites web à accès limité restricted-sites

Ces sites Web sont disponibles uniquement pour les clients. Si vous êtes client et avez besoin d’un accès, contactez votre responsable de compte Adobe.

recommendation-more-help
19ffd973-7af2-44d0-84b5-d547b0dffee2