Échec du déploiement du pipeline lors de l’étape de création

Recherchez et ajoutez votre version de noeud au fichier ui.frontend/package.json si, lors de l’étape de création, le déploiement du pipeline échoue.

Description description

Environnement

Experience Manager as a Cloud Service

Problème/Symptômes

L’exécution du pipeline échoue pendant l’étape de création, en raison d’erreurs dans la variable ui.frontend code.

Vous observez des messages ERROR comme ci-dessous dans la section build.log fichier :

12:52:44,558 [ Exec Stream Pumper]  [ INFO]  ERROR in /build_root/build/<program>/ui.frontend/node_modules/@types/node/ts4.8/util.d.ts
12:52:44,559 [ Exec Stream Pumper]  [ INFO]  [ tsl]  ERROR in /build_root/build/<program>/ui.frontend/node_modules/@types/node/ts4.8/util.d.ts(1485,42)
12:52:44,561 [ Exec Stream Pumper]  [ INFO]  TS1005: ',' expected.
12:52:44,561 [ Exec Stream Pumper]  [ INFO]
12:52:44,561 [ Exec Stream Pumper]  [ INFO]  ERROR in /build_root/build/<program>/ui.frontend/node_modules/@types/node/ts4.8/util.d.ts
12:52:44,562 [ Exec Stream Pumper]  [ INFO]  [ tsl]  ERROR in /build_root/build/<program>/ui.frontend/node_modules/@types/node/ts4.8/util.d.ts(1485,44)
12:52:44,563 [ Exec Stream Pumper]  [ INFO]  TS1068: Unexpected token. A constructor, method, accessor, or property was expected.
12:52:44,563 [ Exec Stream Pumper]  [ INFO]
12:52:44,563 [ Exec Stream Pumper]  [ INFO]  ERROR in /build_root/build/<program>/ui.frontend/node_modules/@types/node/ts4.8/util.d.ts
12:52:44,564 [ Exec Stream Pumper]  [ INFO]  [ tsl]  ERROR in /build_root/build/<program>/ui.frontend/node_modules/@types/node/ts4.8/util.d.ts(1485,57)
12:52:44,564 [ Exec Stream Pumper]  [ INFO]  TS1005: ';' expected.
12:52:44,564 [ Exec Stream Pumper]  [ INFO]

Résolution resolution

Suivez les étapes ci-dessous :

  1. Recherchez dans la racine du référentiel Git, le fichier . pom.xml, et recherchez la version du noeud, par exemple, <nodeVersion>v10.13.0</nodeVersion>

  2. Localiser ui.frontend/package.json, et ajoutez les éléments déjà présents devDependencies objet : par exemple, "devDependencies" :

Remarque :

  1. Le v de < nodeVersion> 10.13.0 ne doit pas être copié.

  2. La version du nœud peut être différente dans votre cas. Par exemple : 12.22.7

recommendation-more-help
3d58f420-19b5-47a0-a122-5c9dab55ec7f