Demande de rejet de la passerelle PayPal - problème de facture en double

Cet article fournit un correctif pour la demande de rejet de la passerelle PayPal - problème de doublon de facture.

Lors de l’envoi du paiement, les clients peuvent voir une erreur pour une facture en double :

La passerelle PayPal a rejeté la demande. Le paiement a déjà été effectué pour cet InvoiceID (#10412: Dupliquer la facture)

Le problème se produit lorsque des factures avec les mêmes ID sont envoyées à PayPal plusieurs fois.

Pour résoudre le problème, autorisez plusieurs paiements par identifiant de facture dans les préférences de réception des paiements de PayPal. Lorsqu’elle est modifiée, PayPal accepte les paiements sans message d’erreur, même pour les factures avec des ID en double.

Versions affectées

  • Adobe Commerce sur site, toutes versions
  • Adobe Commerce sur l’infrastructure cloud, toutes les versions

Problème

Lors de l’envoi du paiement, les clients voient le message d’erreur :

... main.CRITICAL: Exception message: PayPal gateway has rejected request. Payment has already been made for this InvoiceID (#10412: Duplicate invoice).

PayPal ne peut pas traiter le paiement et terminer la commande.

Cause

Le message d’erreur s’affiche lorsque des factures avec le même ID sont envoyées à PayPal plusieurs fois.

Cela peut se produire lors de l’utilisation des mêmes informations d’identification sur plusieurs sites Adobe Commerce (même dans les environnements local et intermédiaire). Voici quelques scénarios particuliers :

  • Plusieurs magasins envoient des factures à PayPal et utilisent les mêmes identifiants de facture
  • Un nouveau magasin envoie une facture avec un identifiant qui a déjà été envoyé par un ancien magasin.

Par défaut, PayPal n'autorise pas le traitement de la même facture à deux reprises.

Solution

Modifiez votre profil PayPal afin de permettre plusieurs paiements par identifiant de facture. Vous devez effectuer ces modifications via PayPal.

  1. Connectez-vous à votre compte à l’adresse https://www.paypal.com.
  2. Cliquez sur Profil > Profil et paramètres (coin supérieur droit).
  3. Accédez à Mes outils de vente.
  4. Accédez à Obtenir un paiement et gérer mon risque > Bloquer les paiements et cliquez sur Mettre à jour.
  5. Préférences de vente, cliquez sur Préférences de réception des paiements.
  6. Sous Bloquer les paiements accidentels, sélectionnez Non, autorisez plusieurs paiements par identifiant de facture. paypal_allow_multiple_payments_per_facture_id.png1
  7. Faites défiler l’écran jusqu’au bas de l’écran et cliquez sur Enregistrer.

Informations supplémentaires

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a