Modes de paiement non affichés lors de l’extraction avec plusieurs adresses
Cet article explique que la plupart des méthodes de paiement ne s’affichent pas lors du passage en caisse lorsque plusieurs adresses de livraison sont spécifiées, car la fonctionnalité est uniquement mise en oeuvre pour Cybersource.
Produits et versions concernés
- Adobe Commerce On-Premise 2.x.x
- Adobe Commerce sur l’infrastructure cloud 2.x.x
Problème
Conditions préalables : dans l’administrateur Commerce, activez et configurez les méthodes de paiement PayPal et Cybersource, et activez la multidiffusion pour votre boutique.
Étapes à reproduire :
- Sur le storefront, ajoutez plusieurs produits au panier.
- Accédez à la page du panier.
- Cliquez sur Extraire avec plusieurs adresses.
- Connectez-vous ou créez un compte.
- Partage des produits entre les adresses sur la page Ship to Multiple Addresses.
- Cliquez sur Accéder à Informations d’expédition.
- Choisissez les méthodes de livraison pour chaque envoi.
- Cliquez sur Continuer vers les informations de facturation.
Résultat attendu : PayPal et Cybersource sont disponibles en tant qu’options de paiement.
Résultat réel : seule la cybersource apparaît comme option de paiement disponible.
Cause
Actuellement, Cybersource est le seul mode de paiement en direct pris en charge pour le paiement multiexpédition, à partir de la version 2.2.4. La prise en charge de la multilivraison sera probablement générée une par une pour chaque mode de paiement. Aucune date ou numéro de version exact ne peut être fournie pour le moment.