Impossible d’enregistrer le serveur principal Adobe Commerce de l’entité
Cet article fournit une solution pour lorsque vous ne parvenez pas à enregistrer une entité dans le serveur principal Adobe Commerce. Par exemple, lorsque vous ne pouvez pas modifier et enregistrer une règle cart_price
spécifique.
Produits et versions concernés
Ce problème peut affecter toutes les versions d’Adobe Commerce dont la taille de session maximale est configurée. Ceci a été ajouté à partir de Magento Open Source 2.3.7-p1 et Adobe Commerce (toutes les méthodes de déploiement) 2.4.3.
Problème
Lorsque vous essayez de reconfigurer votre magasin, la page se recharge et vos modifications ne sont pas enregistrées. Un message est visible dans var/log/system.log
:
[2021-11-27 00:30:52] report.WARNING : la taille de la session de 418056 a dépassé la taille maximale autorisée de la session de 256000. [][]
Étapes à reproduire :
Exemple de configuration de magasin non enregistrée :
- Sélectionnez une règle dans la boutique Adobe Commerce dans Production > Marketing > Règles de prix du panier.
- Sélectionnez une règle et définissez cette règle sur Inactive et enregistrez la modification.
Résultat attendu :
La règle est définie sur inactive.
Résultat réel :
- Chargements de page sans message.
- La règle est toujours définie sur active.
Cause
Ce problème est lié à la nouvelle fonctionnalité introduite récemment qui a eu un impact sur la taille de session maximale. Voir Gestion de session dans notre documentation destinée aux développeurs.
Solution
Augmentez la valeur "Taille de session maximale" dans (Magasins > Configuration > Avancé > Système > Sécurité > Taille de session maximale).
Lecture connexe
- Menu marketing dans notre guide d’utilisation.