Le service Redis est bloqué.

L’article recommande comment corriger Redis.

Produits et versions concernés

  • Adobe Commerce sur l’infrastructure cloud 2.2.x, 2.3.x
  • Adobe Commerce on-premise 2.2.x., 2.3x
  • Toutes les versions de Redis

Problème

Lenteur ou panne du site web en raison d’un débordement de mémoire dans Redis.

Cause

Un débordement de mémoire peut entraîner le blocage du service Redis. Pendant le pic, le service Redis peut nécessiter plus de mémoire que ce qui est actuellement alloué.

Solution

Pour vérifier la configuration actuelle et la mémoire utilisée, exécutez la commande suivante dans l’interface de ligne de commande. Il recherche la mémoire utilisée, le maximum de mémoire, les clés expulsées et le temps de réapprovisionnement en jours :

redis-cli -p REDIS_PORT -h REDIS_HOST info | egrep --color "(role|used_memory_peak|maxmemory|evicted_keys|uptime_in_days)"

Les variables REDIS_PORT et REDIS_HOST peuvent être récupérées à partir de app/etc/env.php.

Si la sortie de l’exécution de la requête ci-dessus indique que le pourcentage de mémoire libre est inférieur à 40 %, envoyez une demande à l’assistance Adobe Commerce demandant une augmentation du paramètre maxmemory dans Redis Server. Si la valeur des clés expulsées n’est pas "0" ou que la durée de réactivation en jours est égale à 0 (ce qui indique que Redis s’est bloqué aujourd’hui), vous devez également envoyer une demande au service clientèle d’Adobe Commerce demandant une enquête et un correctif pour ce problème.

Lecture connexe

Pour en savoir plus sur la mémoire Redis, reportez-vous à la section Optimisation de la mémoire Redis.

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a