Service Redis bloqué
L'article recommande comment réparer Redis.
Produits et versions concernés
- Adobe Commerce sur les infrastructures cloud 2.2.x. et 2.3.x
- Adobe Commerce on-premise 2.2.x., 2.3x
- Toutes les versions de Redis
Problème
Lenteur ou panne du site Web due à un dépassement de mémoire à Redis.
Cause
Un dépassement de mémoire peut entraîner le blocage du service Redis. Pendant les heures de pointe, le service Redis peut nécessiter plus de mémoire que celle actuellement allouée.
Solution
Pour vérifier la configuration actuelle et la mémoire utilisée, exécutez la commande suivante dans l’interface de ligne de commande. Il vérifie la mémoire utilisée, maxmemory, les clés évincées et le temps de reprise en jours :
redis-cli -p REDIS_PORT -h REDIS_HOST info | egrep --color "(role|used_memory_peak|maxmemory|evicted_keys|uptime_in_days)"
Les variables REDIS_PORT et REDIS_HOST peuvent être récupérées à partir de app/etc/env.php.
| code language-none |
|---|
|
Si la sortie de l’exécution de la requête ci-dessus indique que le pourcentage de mémoire libre est inférieur à 40 %, envoyez un ticket à l’assistance Adobe Commerce en demandant une augmentation du paramètre maxmemory dans Redis Server. Si la valeur des clés évincées n’est pas « 0 » ou si le temps d’attente de Redis en jours est égal à 0 (indiquant que Redis s’est bloqué aujourd’hui), vous devez également envoyer un ticket à l’assistance d’Adobe Commerce afin de demander une enquête et un correctif pour ce problème.
Lectures connexes
Pour en savoir plus sur la mémoire Redis, consultez Optimisation de la mémoire Redis.