Nouveaux clients non affichés dans la grille des clients après l’importation CSV
Cet article fournit un correctif pour le problème lorsque vous ne pouvez pas voir de nouveaux clients sous Customers > Tous les clients après une importation à partir d’un fichier .csv
. La solution consiste à définir l’indexeur customer_grid
sur le mode "Mettre à jour lors de l’enregistrement" et à réindexer manuellement la grille du client.
Versions affectées
- Adobe Commerce on-premise 2.2.0 et versions ultérieures
- Adobe Commerce sur l’infrastructure cloud 2.2.0 et versions ultérieures
Problème
Après avoir importé de nouveaux clients à partir d’un fichier .csv
à l’aide de la fonctionnalité d’importation native d’Adobe Commerce, il se peut que vous ne puissiez pas voir les nouveaux enregistrements de client sous Customers > Tous les clients dans l’administrateur tant que vous n’avez pas réindexé manuellement l’indexeur customer_grid
.
Cause
Le mode d’indexation "Mise à jour lors de la planification" dans Adobe Commerce 2.2.0 et versions ultérieures ne prend pas en charge l’indexeur customer_grid
en raison de problèmes de performances.
Solution
Configurez l'indexeur customer_grid
à réindexer à l'aide du mode "Mettre à jour lors de l'enregistrement". Pour ce faire, procédez comme suit :
- Connectez-vous à l’administrateur Commerce.
- Cliquez sur Système > Outils > Gestion des index.
- Cochez la case en regard de l’indexeur de grille client.
- Dans la liste déroulante Actions, sélectionnez Mettre à jour sur Enregistrer.
- Cliquez sur Submit.
Nous vous recommandons également de réindexer manuellement l’indexeur customer_grid
après avoir configuré le mode d’indexation pour vous assurer que l’index est à jour et peut fonctionner avec cron. Pour réindexer manuellement, utilisez la commande suivante :
bin/magento indexer:reindex customer_grid
Informations supplémentaires
Liens vers des sujets connexes dans notre documentation destinée aux développeurs :