Impossible d’enregistrer le serveur principal Adobe Commerce de l’entité

Cet article fournit une solution lorsque vous ne pouvez pas enregistrer une entité dans le serveur principal d’Adobe Commerce. Par exemple, lorsque vous ne pouvez pas modifier ni enregistrer une règle de cart_price spécifique.

Description description

Produits et versions concernés

Ce problème peut affecter toutes les versions d’Adobe Commerce pour lesquelles la taille de session maximale est configurée, y compris Magento Open Source 2.3.7-p1 et Adobe Commerce (toutes les méthodes de déploiement) versions 2.4.9-alpha, 2.4.8, 2.4.7, 2.4.6, 2.4.5, 2.4.4, 2.4.0-2.4.3, ainsi que Magento Open Source 2.3, 2.2, 2.1 et 2.0.

Problème/Symptômes

Lorsque vous essayez de reconfigurer votre boutique, la page se recharge et vos modifications ne sont pas enregistrées. Un message s’affiche dans var/log/system.log :

[ 2021-11-27 00:30:52]  report.WARNING: Session size of 418056 exceeded allowed session max size of 256000. [ ]  [ ]

Procédure à suivre

  1. Sélectionnez une règle dans la boutique Adobe Commerce : Règles de prix de production > de marketing > panier.
  2. Choisissez une règle, définissez-la sur Inactive et enregistrez la modification.

Résultat attendu

La règle est définie sur inactive.

Résultat réel

La page se recharge sans message. La règle reste active.

Cause

Ce problème est lié à une nouvelle fonctionnalité introduite récemment qui a eu un impact sur la taille de session maximale. Voir Gestion de session dans notre documentation destinée aux développeurs.

Résolution resolution

Augmentez la valeur Taille max. de session dans : Stocke > configuration > Sécurité du système > avancé > Taille max. > session.

Lecture connexe

Menu marketing dans notre guide de l'utilisateur.

recommendation-more-help
3d58f420-19b5-47a0-a122-5c9dab55ec7f