ACSD-54961 : L’utilisateur administrateur restreint ne peut pas mettre à jour en masse Product Review status

Le correctif ACSD-54961 corrige le problème lorsqu’un utilisateur administrateur restreint ne peut pas mettre à jour en masse Product Review status. Ce correctif est disponible lorsque la variable Quality Patches Tool (QPT) La version 1.1.40 est installée. L’ID de correctif est ACSD-54961. Veuillez noter que le problème doit être corrigé dans Adobe Commerce 2.4.7.

Produits et versions concernés

Le correctif est créé pour la version Adobe Commerce :

  • Adobe Commerce (toutes les méthodes de déploiement) 2.4.5-p4

Compatible avec les versions d’Adobe Commerce :

  • Adobe Commerce (toutes les méthodes de déploiement) 2.4.0 - 2.4.6-p3
NOTE
Le correctif peut s’appliquer à d’autres versions avec de nouvelles Quality Patches Tool versions. Pour vérifier si le correctif est compatible avec votre version d’Adobe Commerce, mettez à jour la variable magento/quality-patches vers la dernière version et vérifiez la compatibilité sur la page Quality Patches Tool: recherchez la page des correctifs.. Utilisez l’ID de correctif comme mot-clé de recherche pour localiser le correctif.

Problème

Un utilisateur administrateur restreint ne peut pas mettre à jour en masse Product Review status.

Étapes à reproduire:

  1. Créez un site web, un magasin et une vue de magasin supplémentaires.
  2. Ajoutez un produit au 2e magasin, puis ajoutez une révision.
  3. Créez un utilisateur administrateur restreint ayant accès uniquement au 2e magasin.
  4. Connectez-vous en tant qu’utilisateur administrateur restreint, puis accédez à ​ Marketings > Reviews > Mass Update, puis définissez la variable État to Approuvé ou En attente.

Résultats attendus:

L’utilisateur administrateur restreint peut mettre à jour les révisions à l’aide de la variable Mass Update action.

Résultats réels:

Une erreur se produit lors de la mise à jour des révisions à l’aide de Mass Update action.

La variable var/log/exception.log contient une erreur similaire :

report.CRITICAL: TypeError: array_intersect(): Argument #1 ($array) must be of type array, null given in app/code/Magento/AdminGws/Model/Models.php:439

Appliquer le correctif

Pour appliquer des correctifs individuels, utilisez les liens suivants en fonction de votre méthode de déploiement :

Lecture connexe

Pour en savoir plus sur Quality Patches Tool, voir :

Pour plus d’informations sur les autres correctifs disponibles dans QPT, reportez-vous à la section Quality Patches Tool: recherche de correctifs dans le Quality Patches Tool guide.

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a