Introducción a AEM Content y Commerce start

AEM Para empezar a usar Contenido de la y Commerce AEM, debe instalar el complemento Contenido de la y Commerce AEM para la versión 6.5 de la misma.

Requisito mínimo de software

AEM Paquete de servicio de.5 Se requiere 7 o posterior.

Incorporación onboarding

AEM La incorporación de Contenido de la y Commerce es un proceso de dos pasos:

  1. AEM Instalación del complemento Contenido de la y Commerce AEM para la versión 6.5 de la versión

  2. AEM Conéctese con su solución de comercio de

AEM Instalación del complemento Contenido de la y Commerce AEM para la versión 6.5 de la versión install-add-on

AEM Descargue e instale el complemento de Commerce AEM para la versión 6.5 de desde el Distribución de software portal.

AEM Inicie e instale el paquete de servicio necesario de 6.5 de. Se recomienda instalar el último Service Pack disponible.

NOTE
AEM Esto lo hará el CSE para los clientes de Managed Service de la.

AEM Conéctese a su sistema de Commerce connect

AEM Se puede conectar a cualquier sistema de comercio que tenga un punto final de GraphQL AEM accesible para su. Estos extremos suelen estar disponibles públicamente o pueden conectarse a través de conexiones privadas VPN o locales, según la configuración individual del proyecto.

CIF Opcionalmente, se puede proporcionar un encabezado de autenticación para utilizar funciones de autenticación adicionales que requieran autenticación.

Proyectos generados por el AEM Tipo de archivo del proyecto, y el AEM Tienda de referencia de Venia en que ya se incluye en la configuración predeterminada debe ajustarse.

Reemplace el valor del url in com.adobe.cq.commerce.graphql.client.impl.GraphqlClientImpl~default.cfg.json con el extremo GraphQL de su sistema de comercio. Esta configuración se puede realizar a través de la consola OSGI o implementando la configuración OSGI a través del proyecto. AEM Se admiten diferentes configuraciones para sistemas de ensayo y producción utilizando diferentes modos de ejecución de la.

AEM Los componentes principales y del complemento de Commerce CIF AEM y de contenido de la utilizan conexiones tanto del lado del servidor como del lado del cliente. CIF CIF Las herramientas de creación de complementos de componentes principales y de componentes de cliente se conectan de forma predeterminada a /api/graphql. CIF Esto se puede ajustar a través de la configuración del Cloud Service de si es necesario (consulte a continuación).

CIF El complemento de proporciona un servlet proxy de GraphQL en /api/graphql que se puede utilizar de forma opcional para desarrollo local. Para implementaciones de producción, se recomienda encarecidamente configurar un proxy inverso al extremo de GraphQL AEM de comercio a través de la instancia de Dispatcher de o en otras capas de red (como CDN).

Configuración de tiendas y catálogos catalog

El complemento y el CIF Componentes principales AEM se puede utilizar en varias estructuras de sitio de la conectadas a diferentes tiendas comerciales (o vistas de tiendas, etc.). CIF De forma predeterminada, el complemento de se implementa con una configuración predeterminada que se conecta a la tienda y al catálogo predeterminados de Adobe Commerce.

CIF Esta configuración se puede ajustar para el proyecto mediante la configuración del Cloud Service de la siguiendo estos pasos:

  1. AEM En la página de inicio, vaya a Herramientas > Cloud Service CIF > Configuración de la

  2. Seleccione la configuración de comercio que desee cambiar

  3. Abra las propiedades de configuración a través de la barra de acciones

CIF Configuración de Cloud Service de

Se pueden configurar las siguientes propiedades:

  • Cliente de GraphQL: seleccione el cliente de GraphQL configurado para la comunicación back-end comercial. Esto debería permanecer en modo predeterminado.

  • Vista de tienda: el identificador de la vista de tienda. Si está vacía, se utiliza la vista de tienda predeterminada.

  • Ruta del proxy de GraphQL: la ruta URL del proxy de GraphQL AEM que se utiliza para las solicitudes de proxy al extremo de GraphQL backend de comercio.

    note note
    NOTE
    En la mayoría de las configuraciones, el valor predeterminado /api/graphql no se debe cambiar. Solo la configuración avanzada que no utiliza el proxy de GraphQL proporcionado debe cambiar esta configuración.
  • Habilitar compatibilidad con UID de catálogo: habilite la compatibilidad con UID en lugar de con ID en las llamadas comerciales de GraphQL back-end.

    note note
    NOTE
    La compatibilidad con UID se ha introducido en Adobe Commerce 2.4.2. Habilite esta opción solo si el backend de Commerce admite un esquema GraphQL de la versión 2.4.2 o posterior.
  • Identificador de categoría raíz del catálogo: el identificador (UID o ID) de la raíz del catálogo de la tienda

    note caution
    CAUTION
    CIF A partir de la versión 2.0.0 de los componentes principales de, la compatibilidad con id se ha eliminado y reemplazado por uid. CIF Si el proyecto utiliza componentes principales de la versión 2.0.0 de la, debe habilitar la compatibilidad con UID de catálogo y utilizar un UID de categoría válido como "Identificador de categoría raíz de catálogo".

La configuración que se muestra arriba es como referencia. Los proyectos deben proporcionar sus propias configuraciones.

AEM Para obtener configuraciones más complejas que utilicen varias estructuras de sitio de la combinadas con diferentes catálogos de comercio, consulte la Configuración de varias tiendas de Commerce tutorial.

Recursos adicionales additional-resources

recommendation-more-help
19ffd973-7af2-44d0-84b5-d547b0dffee2