AEM: La versión del paquete OOTB es inferior a la esperada

Compruebe el propietario del archivo/directorio bajo crx-quickstart. AEM Si el archivo o directorio no es propiedad del usuario normal durante el proceso de, siga los pasos de la sección Resolución.

Descripción description

Entorno
Adobe Experience Manager AEM ()

Problema
En la consola OSGi > OSGi > paquetes, hay un paquete cuya versión es inferior a la esperada para el SP/CFP instalado.

Este problema no se trataría de un problema en solitario. AEM Por lo general, ocurre algo crítico (por ejemplo: error en el inicio de sesión de los usuarios) y la investigación revela esto como una causa intermedia.

Causa
Es posible que la actualización del paquete haya fallado durante la instalación del SP/CFP.

AEM Otra posible causa del error de actualización es que alguien comenzó como usuario raíz antes y después como usuario habitual de la aplicación.

Durante la ejecución como usuario raíz, crx-quickstart/launchpad/felix/bundleXX era propiedad de root.

AEM En el momento de la instalación del SP/CFP, el, que se ejecuta como usuario normal, no puede escribir en bundleXX, por lo que se produce un error en la actualización del paquete.

Resolución resolution

Solución

Compruebe el propietario del archivo/directorio bajo crx-quickstart.

AEM Si el archivo o directorio no es propiedad del usuario normal durante el proceso de, realice los siguientes pasos:

  1. Detenga AEM.
  2. Vuelva a cambiar el propietario por el usuario normal.
  3. Inicie AEM.
  4. Vuelva a instalar el SP/CFP.
recommendation-more-help
3d58f420-19b5-47a0-a122-5c9dab55ec7f