Configuración del proveedor de bloqueos

Antes de ejecutar este comando, debe hacer lo siguiente o usted debe instalar la aplicación:

Instalación segura

Para utilizar Secure Sockets Layer (SSL), también denominado HTTPS, tanto para el administrador como para la tienda, debe establecer todos los parámetros siguientes:

  • --use-secure: establezca en 1
  • --base-url-secure: establezca en una dirección URL segura (es decir, empezando por https://)
  • --use-secure-admin Configure como. 1

Más adelante en este tema se pueden encontrar más detalles sobre estos parámetros.

Configuración del bloqueo

Configure un proveedor de bloqueo para evitar el inicio de trabajos cron y grupos cron duplicados. (Requiere Adobe Commerce 2.2.x, 2.2.5 y posterior, y 2.3.3 y posterior).

Adobe Commerce utiliza la base de datos para guardar bloqueos de forma predeterminada. Si tiene varios nodos en sus servidores, le recomendamos que utilice Zookeeper como proveedor de bloqueos.

Si está ejecutando Adobe Commerce en una infraestructura en la nube, no es necesario configurar el proveedor de bloqueos. La aplicación configura el proveedor de bloqueo de archivos para proyectos Pro durante el proceso de aprovisionamiento. Consulte Variables de nube.

Uso de comandos

bin/magento setup:config:set [--<parameter_name>=<value>, ...]

Descripciones de parámetros

Nombre
Valor
¿Requerido?
--lock-provider
Bloquear nombre de proveedor: db, zookeeper, o file.

El proveedor de bloqueo predeterminado: db
No
--lock-db-prefix
El prefijo de base de datos específico para evitar conflictos de bloqueo al utilizar db bloquear proveedor.

El valor predeterminado: NULL
No
--lock-zookeeper-host
Host y puerto para conectarse al clúster de Zookeeper cuando se utiliza el zookeeper bloquear proveedor.

Por ejemplo: 127.0.0.1:2181
Sí, si se establece --lock-provider=zookeeper
--lock-zookeeper-path
El camino donde Zookeeper guarda las cerraduras.

La ruta predeterminada es: /magento/locks
No
--lock-file-path
Ruta de acceso donde se guardan los bloqueos de archivo.
Sí, si se establece --lock-provider=file
recommendation-more-help
0f8e7db5-0e9c-4002-a5b8-a0088077d995