Los métodos de pago no se muestran en el cierre de compra con varias direcciones

Este artículo explica que la mayoría de los métodos de pago no se muestran en el cierre de compra cuando se especifican varias direcciones de envío, ya que la funcionalidad solo se implementa para Cybersource.

Productos y versiones afectados

  • Adobe Commerce local 2.x.x
  • Adobe Commerce en infraestructura en la nube 2.x.x
NOTE
La integración principal de pagos de Adobe Commerce Cybersource está obsoleta desde la versión 2.3.3 y se eliminará completamente en la versión 2.4.0. En su lugar, use la extensión oficial del mercado.

Problema

Requisitos previos: en el administrador de Commerce, habilita y configura los métodos de pago de PayPal y Cybersource, y habilita el envío múltiple para tu tienda.

Pasos a seguir:

  1. En la tienda, agregue varios productos al carro de compras.
  2. Vaya a la página del carro de compras.
  3. Haga clic en Desproteger con varias direcciones.
  4. Inicie sesión o cree una cuenta.
  5. Divida los productos entre las direcciones de la página Enviar a varias direcciones.
  6. Haga clic en Ir a la información de envío.
  7. Seleccione los métodos de envío para cada envío.
  8. Haga clic en Continuar con la información de facturación.

Resultado esperado: PayPal y Cybersource están disponibles como opciones de pago.

Resultado real: Solo Cybersource aparece como la opción de pago disponible.

Causa

Actualmente, Cybersource es el único método de pago en vivo compatible para el pago multienvío, a partir de la versión 2.2.4. La compatibilidad con el envío múltiple probablemente se creará para cada método de pago uno por uno. Por el momento no se pueden proporcionar fechas exactas ni números de versión.

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a