Este artículo proporciona una solución para los casos en los que el archivo robots.txt
de Adobe Commerce está configurado correctamente, pero sigue mostrando la configuración predeterminada o no se puede actualizar. Para resolver este problema, asegúrese de que la indexación por motores de búsqueda esté habilitada.
Descripción
Entorno
Adobe Commerce en cloud Infrastructure 2.3.x, 2.4.x
Problema
No se puede cambiar la configuración predeterminada de robots.txt
en Adobe Commerce.
Pasos para reproducir:
Resultado esperado:
El archivo robots.txt
muestra el contenido personalizado guardado.
Resultado real:
El archivo robots.txt
no cambia y continúa mostrando el contenido predeterminado.
Causa
La indización por motores de búsqueda está deshabilitada, lo que impide que se aplique el contenido personalizado robots.txt
.
Resolución
Habilite la indexación por motores de búsqueda. Para obtener instrucciones detalladas, consulte Configurar la indexación mediante el motor de búsqueda en nuestra documentación para desarrolladores.