Campos bloqueados en el administrador de Commerce
Este artículo proporciona una solución para los casos en los que no se pueden modificar campos en el Administrador de Commerce.
Productos y versiones afectados
- Adobe Commerce local 2.3.x, 2.4.x
- Adobe Commerce en cloud Infrastructure 2.3.x, 2.4.x
Problema
Una vez guardado un cambio en la configuración de app/etc/env.php
o app/etc/config.php
, no puede modificar la configuración en el Administrador.
Pasos a seguir:
Nota: Este es un ejemplo: el problema puede afectar a todas las configuraciones que se han guardado.
- El comerciante guarda sus credenciales de métodos de entrega mediante el siguiente comando en el terminal:
./vendor/bin/ece-tools config:dump
. Esto guarda las credenciales en el archivoapp/etc/env.php
. - A continuación, el comerciante intenta cambiar las credenciales más adelante.
Resultados esperados:
El comerciante puede establecer los valores en la configuración del campo Administración y guardarlos.
Resultados reales:
Los campos del Administrador están bloqueados o los valores se pueden cambiar, pero no se guardarán en el Administrador.
Causa
Cuando la configuración se guarda en env.php
o config.php
, no podrá modificarla en el Administrador. Para permitir la edición de la configuración, deberá quitar la configuración de env.php
o config.php
.
Solución
Asegúrese de que la configuración no se haya guardado en app/etc/env.php
o app/etc/config.php
. Si se ha guardado, intente los siguientes pasos:
config.php
: quite la configuración y vuelva a implementar.env.php
: modifique esto directamente en el servidor, quite la configuración y ejecutebin/magento app:config:import
.
Lectura relacionada
- Exporte la configuración en nuestra documentación para desarrolladores.
- Establecer valores de configuración en nuestra documentación para desarrolladores.
- Adobe Commerce en la infraestructura en la nube: reduzca el tiempo de inactividad de la implementación con la administración de la configuración en nuestra base de conocimiento de asistencia.