salesRule etiquetas problemas al actualizar desde versiones < 2.4.5

El salesRule la funcionalidad de ensayo de etiquetas se ha introducido en Adobe Commerce 2.4.5. El cambio puede provocar problemas al actualizar desde Adobe Commerce < 2.4.5 a cualquier versión >= 2.4.5. Después de la actualización, existe la posibilidad de que salesRule las etiquetas no coinciden. Para solucionar el problema, se debe aplicar un parche justo después de la actualización a una versión más reciente de Adobe Commerce.

Productos y versiones afectados

Adobe Commerce en infraestructura en la nube < 2.4.5

Parche

Utilice el siguiente parche adjunto:

ACSD-50625_2.4.5-P1.patch.zip

Cómo aplicar el parche

  1. Siga los pasos de Realización de una actualización en la guía de Commerce.
  2. Aplique el parche adjunto antes de la Update metadata fase.
    (También puede aplicar el parche después de completar el Update metadata fase, pero entonces debe ejecutar bin/magento setup:upgrade una vez más).
  3. Continúe con el resto de los pasos indicados en Realización de una actualización.
recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a