Error de implementación: no se puede aplicar el parche de MDVA-43395

Este artículo proporciona una solución al problema, donde al intentar aplicar el parche MDVA-43395 se produce un error en la implementación.

Productos y versiones afectados

  • Adobe Commerce en la infraestructura en la nube (todas las versiones)

Problema

No puede aplicar el parche MDVA-43395.

Causa

Los comerciantes en la nube no necesitan aplicar el parche MDVA-43395 por separado si tienen magento/magento-cloud-patch 1.0.16 instalado, que ya incluye el parche.

Solución

Para resolver el problema, elimine los parches MDVA-43395 y MDVA-43443 de la m2-hotfixes y vuelva a implementarlo.

Si pudo aplicar el parche MDVA-43443 a través de la m2-hotfixes , aún tendría que eliminarlo como se ha mencionado anteriormente. Las versiones futuras de Adobe Commerce tendrán estos parches ya contenidos, por lo que podría provocar errores en la implementación si se actualizara más tarde.

Para comprobar si se ha aplicado el parche, ejecute el vendor/bin/magento-patches -n status |grep 43443 comando.
Si muestra varios resultados como este, debe quitar el parche MDVA-43443 del m2-hotfixes carpeta:

$ vendor/bin/magento-patches -n status |grep 43443
║ MDVA-43443              │ Parser token new fix                                         │ Other           │ Adobe Commerce Support │ Applied     │ Patch type: Required                                     ║
║ N/A                     │ ../m2-hotfixes/MDVA-43443_EE_2.4.2-p2_COMPOSER_v1.patch      │ Other           │ Local                  │ Applied     │ Patch type: Custom                                       ║

Lectura relacionada

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a