要求

TVSDK對媒體內容、清單內容、DRM和軟體版本有特定要求。

系統和軟體要求

要使用TVSDK,請確保您的硬體、作業系統和應用程式版本都符合下面列出的最低要求。

作業系統 Android 4.0或更高版本(最低API級別14)
CPU 1 GHz單核或等效
RAM 256 MB
GPU 播放所需的硬體GPU
建築 x86,通過Houdini、ARM64、ARMv7和ARMv8

內容和清單要求

檢查流和播放清單(清單)(包括DRM加密密鑰)的限制和要求。

Adobe訪問DRM 如果受DRM保護的流是多比特率(MBR),則用於MBR的DRM加密密鑰應與所有比特率流中使用的密鑰相同。
廣告變型清單 必須與主內容的格式副本具有相同的比特率格式副本。

#EXT-X-VERSION要求

版本 #EXT-X-VERSION 的 .m3u8 清單檔案會影響應用程式可用的功能以及 EXT 標籤有效。

下面是關於 #EXT-X-VERSION 標籤,它指定HLS協定版本:

  • 版本必須與HLS播放清單中的功能和屬性相匹配;否則,可能會出現回放錯誤。 有關詳細資訊,請參見 HTTP即時流規範

  • Adobe建議至少使用HLS第2版在基於TVSDK的客戶端中回放。

    客戶端和伺服器必須通過以下方式實現版本:

至少使用此版本 使用這些功能
EXT-X — 版本:2 IV屬性 EXT-X鍵 標籤。
EXT-X — 版本:3
  • 浮點 滅絕 持續時間值

    The duration tags ( #EXTINF: <duration>,<title>) in version 2 were rounded to integer values. 版本3及更高版本要求準確指定持續時間(以浮點形式)。

EXT-X — 版本:4
  • EXT-X-BYTERANGE 標籤
  • EXT-X-I — 幀 — 流 — INF 標籤
  • 僅EXT-X-I — 幀 標籤
  • EXT-X-MEDIA 標籤
  • 音頻 視頻 屬性 EXT-X — 流 — INF 標籤
  • TVSDK備用音頻

本頁內容