要求

TVSDK需要媒體內容、清單內容和軟體版本的特定屬性。

System and software requirements

To use TVSDK, ensure that your hardware, operating system, and application versions all meet the minimum requirements listed below.

Operating system: iOS 6.0 or later

Content and manifest requirements

Check the restrictions and requirements for streams and playlists (manifests), including DRM encryption keys.

Content segment key frames Each content segment must begin with a key frame.
即時/線性視頻中的序列號 必須在任何給定時間為主內容匹配所有比特率格式副本。

#EXT-X-VERSION要求

版本 #EXT-X-VERSION 的 .m3u8 檔案會影響應用程式可用的功能以及 EXT 標籤在播放清單/清單中有效。

#EXT-X-VERSION

  • The version must match the features and attributes in the HLS playlist; otherwise, playback errors might occur.

    🔗

  • If the tag is not included in the master or media playlists, or if no version is specified, version 1 is used by default. Content that does not comply with version 1 will not play.

  • Adobe recommends using at least version 2 for playback in TVSDK-based clients.

Clients and servers must implement the versions in the following way:

Use at least this version To use these features
EXT-X — 版本:2 IV屬性 EXT-X鍵 標籤。
  • Version 3 and above require durations to be exact in floating point.

  • TVSDK features such as ad insertion and seamless ABR

  • 僅EXT-X-I — 幀 標籤
  • EXT-X-MEDIA 標籤
  • 音頻 視頻 屬性 EXT-X — 流 — INF 標籤
  • TVSDK備用音頻

本頁內容