22.1 Configure seu ambiente

Objetivos

Para trabalhar com o Project Firefly, é necessário ter certas ferramentas instaladas em sua máquina local.

Ferramentas necessárias

  • NodeJS (pelo menos v10). Ele também deve instalar npm juntos. Recomendamos usar nvm para gerenciar a instalação e as versões do NodeJS em seu computador.

  • Adobe I/O CLI.

Instalar NodeJS

  • Vá para https://nodejs.org.
  • Use o instalador pronto para usar baseado em SO para instalar o NodeJS em sua máquina.

DownloadNodeJS

Instalar Adobe I/O CLI

Nova instalação

Para instalar o Adobe I/O CLI

  • Abra uma janela de linha de comando ou terminal em seu SO:
  • Executar % npm install -g @adobe/aio-cli

Isso instalará o Adobe I/O CLI em seu computador.

Atualizar instalação existente

Se você já tiver a CLI do Adobe I/O em sua máquina local:

  • Certifique-se de ter a versão mais recente do Adobe I/O CLI instalada.
    Para a CLI do Adobe I/O, você pode verificar a versão por
    % aio -v

e compare com
% npm show @adobe/aio-cli version

AdobeIOUpdate

No exemplo acima, a versão reportada do Adobe I/O é 3.5.0, enquanto npm mostra que há uma versão atualizada (3.7.0) disponível. A versão atual, no momento da gravação desse módulo de ativação, é 5.0.1, mas verifique a versão mais recente de acordo com as instruções acima.

  • Se sua CLI do Adobe I/O estiver desatualizada, atualize-a executando
    % npm install -g @adobe/aio-cli

Você verá a saída como abaixo.

saída via rádio

  • Para garantir que todos os plug-ins principais também sejam atualizações, execute
    % aio update

Você pode ser avisado se deseja atualizar plug-ins. Responda com y ou Y para fazer isso.

aio-update-plugins

Você terminou de configurar a CLI do Adobe I/O e o NodeJS subjacente em seu computador.


ObservaçãoAlém de verificar a versão na CLI do Adobe I/O, sempre que uma nova versão da CLI do Adobe I/O for atualizada, você verá uma mensagem como a abaixo. Esta mensagem dura 7 dias após uma nova versão.

› Warning: @adobe/aio-cli update available from 3.3.0 to 3.4.1.
›   Run npm install -g @adobe/aio-cli to update.

Você terminou este exercício.

Próxima etapa: 22.2 Introdução ao Project Firefly

Voltar ao módulo 22

Voltar para todos os módulos

Nesta página