22.1 환경 설정

목표

Project Firefly에서 작업하려면 로컬 컴퓨터에 특정 도구를 설치해야 합니다.

필수 도구

  • NodeJS (최소 v10). 또한 npm도 함께 설치해야 합니다. 컴퓨터에서 nvm을 사용하여 NodeJS 설치 및 버전을 관리하는 것이 좋습니다.

  • Adobe I/O CLI.

NodeJS 설치

  • https://nodejs.org으로 이동합니다.
  • OS 기반의 즉시 사용 가능한 설치 프로그램을 사용하여 컴퓨터에 NodeJS를 설치합니다.

DownloadNodeJS

Adobe I/O CLI 설치

새 설치

Adobe I/O CLI​를 설치하려면

  • OS에서 명령줄 또는 터미널 창을 엽니다.
  • 실행 % npm install -g @adobe/aio-cli

시스템에 Adobe I/O CLI가 설치됩니다.

기존 설치 업데이트

로컬 시스템에 Adobe I/O CLI가 이미 있는 경우:

  • 최신 버전의 Adobe I/O CLI가 설치되어 있는지 확인하십시오.
    Adobe I/O CLI의 경우
    % aio -v

그리고
% npm show @adobe/aio-cli version

AdobeIOUpdate

위의 예에서 보고된 Adobe I/O 버전은 3.5.0, npm은 업데이트된 버전(3.7.0)이 있음을 보여줍니다. 이 지원 모듈을 작성할 때 현재 버전은 5.0.1이지만 위 지침에 따라 최신 버전을 확인하십시오.

  • Adobe I/O CLI가 오래된 경우 실행
    % npm install -g @adobe/aio-cli

아래와 같이 출력물이 표시됩니다.

aio-output

  • 모든 핵심 플러그인도 업데이트되도록 하려면
    % aio update

플러그인을 업데이트할지 여부를 묻는 메시지가 나타날 수 있습니다. 이렇게 하려면 y 또는 Y로 응답합니다.

aio-update-plugins

이제 시스템에 Adobe I/O CLI 및 기본 NodeJS 설정을 완료했습니다.

참고
Adobe I/O CLI에서 버전을 확인하는 것 이외에, 새 버전의 Adobe I/O CLI가 업데이트될 때마다 아래와 같은 메시지가 표시됩니다. 이 메시지는 새 릴리스 후 7일 동안 지속됩니다.

› Warning: @adobe/aio-cli update available from 3.3.0 to 3.4.1.
›   Run npm install -g @adobe/aio-cli to update.

이 연습 다 끝냈어요.

다음 단계:22.2 프로젝트 소개

모듈 22로 돌아가기

모든 모듈로 돌아가기

이 페이지에서는