22.1 Configuration de votre environnement

Objectifs

Pour travailler avec Project Firefly, vous devez installer certains outils sur votre machine locale.

Outils requis

  • NodeJS (au moins v10). Il doit également installer npm ensemble. Nous vous recommandons d’utiliser nvm pour gérer l’installation et les versions de NodeJS sur votre ordinateur.

  • Interface de ligne de commande d’Adobe I/O.

Installation de NodeJS

  • Accédez à https://nodejs.org.
  • Utilisez le programme d’installation prêt à l’emploi de votre système d’exploitation pour installer NodeJS sur votre ordinateur.

DownloadNodeJS

Installation de Adobe I/O CLI

Nouvelle installation

Pour installer l’interface de ligne de commande Adobe I/O

  • Ouvrez une fenêtre de ligne de commande ou de terminal sur votre système d’exploitation :
  • Exécuter % npm install -g @adobe/aio-cli

Cette opération installe l’interface de ligne de commande Adobe I/O sur votre machine.

Mettre à jour l'installation existante

Si vous disposez déjà de l’interface de ligne de commande Adobe I/O sur votre ordinateur local :

  • Assurez-vous que la dernière version de l’interface de ligne de commande Adobe I/O est installée.
    Pour l’interface de ligne de commande Adobe I/O, vous pouvez vérifier la version
    % aio -v

et le comparer à
% npm show @adobe/aio-cli version

AdobeIOUpdate

Dans l’exemple ci-dessus, la version d’Adobe I/O rapportée est 3.5.0, tandis que npm montre qu’une version mise à jour (3.7.0) est disponible. La version actuelle, au moment de la rédaction de ce module d'activation, est 5.0.1, mais assurez-vous de vérifier la dernière version conformément aux instructions ci-dessus.

  • Si votre interface de ligne de commande Adobe I/O est obsolète, mettez-la à jour en exécutant
    % npm install -g @adobe/aio-cli

Vous verrez la sortie comme ci-dessous.

aio-output

  • Pour vous assurer que tous vos modules externes principaux sont également mis à jour, exécutez
    % aio update

Vous pouvez être invité à mettre à jour les modules externes. Répondez par y ou Y pour ce faire.

aio-update-plugins

Vous avez maintenant terminé de configurer l’interface de ligne de commande Adobe I/O et NodeJS sous-jacent sur votre ordinateur.


Remarque : En dehors de la vérification de la version de votre interface de ligne de commande Adobe I/O, chaque fois qu’une nouvelle version de l’interface de ligne de commande Adobe I/O est mise à jour, un message s’affiche comme ci-dessous. Ce message dure 7 jours après une nouvelle version.

› Warning: @adobe/aio-cli update available from 3.3.0 to 3.4.1.
›   Run npm install -g @adobe/aio-cli to update.

Vous avez terminé cet exercice.

Étape suivante : 22.2 Présentation du projet Firefly

Revenir au module 22

Revenir à tous les modules

Sur cette page