22.1 Umgebung einrichten

Ziele

Um mit Project Firefly arbeiten zu können, müssen Sie bestimmte Werkzeuge auf Ihrem lokalen Computer installiert haben.

Erforderliche Tools

  • NodeJS (mindestens v10). Es sollte auch npm zusammen installiert werden. Es wird empfohlen, die NodeJS-Installation und -Versionen auf Ihrem Computer mit nvm zu verwalten.

  • Adobe I/O-CLI.

NodeJS installieren

  • Wechseln Sie zu https://nodejs.org.
  • Verwenden Sie das im Lieferumfang enthaltene Installationsprogramm, um NodeJS auf Ihrem Computer zu installieren.

DownloadNodeJS

Adobe I/O CLI installieren

Neue Installation

So installieren Sie die Adobe I/O CLI

  • Öffnen Sie ein Befehlszeilenfenster oder ein Terminalfenster auf Ihrem Betriebssystem:
  • Ausführen % npm install -g @adobe/aio-cli

Dadurch wird Adobe I/O CLI auf Ihrem Computer installiert.

Vorhandene Installation aktualisieren

Wenn Sie bereits Adobe I/O CLI auf Ihrem lokalen Computer installiert haben:

  • Vergewissern Sie sich, dass Sie die neueste Version von Adobe I/O CLI installiert haben.
    Für die Adobe I/O-CLI können Sie die Version
    % aio -v

und vergleichen Sie es mit
% npm show @adobe/aio-cli version

AdobeIOUpdate

Im obigen Beispiel ist die gemeldete Version von Adobe I/O 3.5.0, während npm zeigt, dass eine aktualisierte Version (3.7.0) verfügbar ist. Die aktuelle Version zum Zeitpunkt des Schreibens dieses Moduls ist 5.0.1, aber überprüfen Sie die neueste Version gemäß den oben stehenden Anweisungen.

  • Wenn Ihre Adobe I/O-CLI veraltet ist, aktualisieren Sie sie, indem Sie
    % npm install -g @adobe/aio-cli

Die Ausgabe wird wie folgt angezeigt.

aio-output

  • Um sicherzustellen, dass alle Core-Plugins ebenfalls aktualisiert werden, führen Sie
    % aio update

Möglicherweise werden Sie aufgefordert, Plugins zu aktualisieren. Antworten Sie mit y oder Y, um dies zu tun.

aio-update-plugins

Sie haben die Einrichtung der Adobe I/O-CLI und der zugrunde liegenden NodeJS auf Ihrem Computer abgeschlossen.

Wenn eine neue Version der Adobe I/O CLI aktualisiert wird, wird eine Meldung wie unten dargestellt,
abgesehen von der Überprüfung der Version auf Ihrer Adobe I/O CLI. Diese Meldung dauert 7 Tage nach einer neuen Version.

› Warning: @adobe/aio-cli update available from 3.3.0 to 3.4.1.
›   Run npm install -g @adobe/aio-cli to update.

Sie haben diese Übung beendet.

Nächster Schritt: 22.2 Einführung in das Projekt Firefly

Zurück zu Modul 22

Zurück zu allen Modulen

Auf dieser Seite