SDK iOS 4.x pour solutions Experience Cloud

Le SDK iOS 4.x pour solutions Experience Cloud permet de mesurer les applications iPhone et iPad Apple natives, de diffuser du contenu ciblé dans vos applications, ainsi que d’exploiter et de collecter des données d’audience grâce à Audience Manager.

IMPORTANT

À partir de la version 4.21.0, le SDK iOS dispose d’une version minimale requise de Xcode 12. Si vous utilisez Cocoapods pour gérer les dépendances au sein de votre application, le SDK Adobe requiert la version 1.10.0 ou une version ultérieure de Cocoapods.

Si vous utilisez la version 4.21.0 ou une version ultérieure, consultez la documentation en tenant compte des modifications suivantes :

  • Chaque fois qu’un fichier de bibliothèque binaire est mentionné, son remplaçant XCFramework doit être utilisé à la place :
    • AdobeMobileLibrary.a > AdobeMobile.xcframework
    • AdobeMobileLibrary_Extension.a > AdobeMobileExtension.xcframework
    • AdobeMobileLibrary_Watch.a > AdobeMobileWatch.xcframework
    • AdobeMobileLibrary_TV.a > AdobeMobileTV.xcframework
  • Si vous ajoutez manuellement les XCFrameworks Adobe à votre projet, vérifiez qu’ils ne sont pas incorporés.
IMPORTANT

Le SKU du module complémentaire de marketing mobile Adobe Analytics est nécessaire pour permettre aux Mobile Services d’accéder aux fonctionnalités d’acquisition mobile, de lien profond, de géolocalisation et de messagerie mobile. Pour en savoir plus, contactez votre CSM Adobe.

IMPORTANT

Le SDK iOS 4.x pour solutions Experience Cloud prend désormais en charge iOS 13 et Xcode 11. Pour garantir une compatibilité fluide, utilisez les dernières versions des SDK iOS 4.x. Pour plus d’informations sur la dernière version, voir les notes de mise à jour.

Nouvelle mise à jour du SDK Adobe Experience Platform Mobile

Vous recherchez des informations et de la documentation concernant le SDK d’Adobe Experience Platform Mobile ? Cliquez ici pour consulter la documentation la plus récente.

Nous avons lancé, en septembre 2018, une version majeure du SDK. Ces nouveaux SDK Adobe Experience Platform Mobile peuvent être configurés via Experience Platform Launch.

Informations à retenir :

  • iOS 8 ou version ultérieure compatible.

    Pour iOS 11 ou version ultérieure, vous devez disposer du SDK version 4.13.8 ou ultérieure.

  • Dans la version 4.2 de ce SDK ou une version ultérieure, tous les accès sont désormais envoyés par HTTP POST.

    Cela n’a aucun impact sur les données collectées ou reprises dans les rapports, mais vous devez utiliser un analyseur de paquets qui prend en charge l’inspection des données POST pour afficher les accès.

  • Si vous procédez à une mise à niveau depuis une version précédente (2.x ou 3.x), consultez le Guide de la migration 4.x.

Documentation utilisateur Adobe Mobile

Adobe Mobile Services offre une nouvelle interface utilisateur qui réunit les fonctionnalités de marketing mobile pour les applications mobiles issues d’Adobe Experience Cloud. Adobe Mobile offre une intégration en toute transparence des fonctionnalités d’analyse et de ciblage des applications issues des solutions Adobe Analytics, Adobe Audience Manager et Adobe Target, ainsi que du service d’identification Adobe Experience Platform.

Pour en savoir plus sur l’interface utilisateur de Mobile Services et lire la documentation utilisateur, reportez-vous à Adobe Mobile Services.

Utilisation de Bloodhound

IMPORTANT

Depuis le 30 avril 2017, Adobe Bloodhound fait l’objet d’une élimination progressive. Depuis le 1er mai 2017, plus aucune amélioration n’y est apportée et aucune assistance d’ingénierie supplémentaire ou assistance Adobe Expert Care n’est fournie.

Sur cette page