Installazione

Java

Per installare la libreria Java, aggiungi questa dipendenza al POM del progetto:

<dependency>
   <groupId>com.livefyre</groupId>
   <artifactId>livefyre</artifactId>
   <version>2.0.3</version>
</dependency>

La libreria Java ha dipendenze dai seguenti moduli:

<dependency>
   <groupId>com.sun.jersey</groupId>
   <artifactId>jersey-client</artifactId>
   <version>[1.18.1,)</version>
</dependency>
<dependency>
   <groupId>com.google.code.gson</groupId>
   <artifactId>gson</artifactId>
   <version>[2.3,)</version>
</dependency>
<dependency>
   <groupId>com.google.guava</groupId>
   <artifactId>guava</artifactId>
   <version>[18.0,)</version>
</dependency>
<dependency>
   <groupId>org.apache.commons</groupId>
   <artifactId>commons-lang3</artifactId>
   <version>[3.0.1,)</version>
</dependency>
<dependency>
   <groupId>org.bitbucket.b_c</groupId>
   <artifactId>jose4j</artifactId>
   <version>[0.4.1,)</version>
</dependency>

Per ulteriori informazioni, leggi i documenti Java o vedi l’origine su GitHub.

NodeJS

Per installare la libreria NodeJS, esegui questa riga:

$ npm install livefyre

La libreria NodeJS ha dipendenze dai seguenti moduli:

"restler":">=3.2.0",
"validator":"=3.5.0",
"jsonwebtoken": ">=5.0.0"

Per ulteriori informazioni, leggi i documenti NodeJs o vedi l’origine su GitHub.

Collegamenti: Restler, Validator, jsonwebtoken.

PHP

Per installare la libreria PHP con Composer, aggiungilo al tuo compositore.json:

"require": {
   "livefyre/livefyre-php-utils": "2.0.4"
}

Quindi installa utilizzando:

composer.phar install

Se non utilizzi Compositore, ottieni la versione più recente della libreria utilizzando:

git clone https://github.com/Livefyre/livefyre-php-utils

Per utilizzare la libreria, aggiungi quanto segue al tuo script PHP:

require_once("/path/to/livefyre-php-utils/src/Livefyre.php");

La libreria PHP ha dipendenze dai seguenti moduli:

"ext-json": "*",
"rmccue/requests": ">=1.0"
"firebase/php-jwt": ">=2.0"

Per ulteriori informazioni, leggi i documenti PHP o vedi l'origine su GitHub.

Collegamenti: ext-json, Richieste, PHP-JWT

Pitone

Per installare la libreria Python, esegui questa riga:

$ pip install livefyre

La libreria Python ha dipendenze dai seguenti moduli:

PyJWT >= 1.0.1
requests >= 2.2.1
python-dateutil >= 2.2
enum34 == 1.0
ordereddict == 1.1 if sys.version_info[:2] < 2.7

Per ulteriori informazioni, leggi i documenti Python o vedi l’origine su GitHub.

Collegamenti: PyJWT, Richieste, Python-Dateutil, Enum34, OrderedDict

Ruby

Per installare la libreria Ruby, aggiungi questa riga al file Gemfile della tua applicazione:

gem 'livefyre'

Oppure installalo tu stesso:

$ gem install livefyre

La libreria Ruby ha dipendenze dai seguenti moduli:

"jwt", '~> 1.4', ">= 1.4.1"
"rest-client", '~> 1.8', ">= 1.8.0"
"addressable", '~> 2.3', ">= 2.3.6"

Per ulteriori informazioni, leggi i documenti Ruby o vedi l'origine su GitHub.

Collegamenti: Ruby JWT, REST Client, Addressable

In questa pagina