Installation

Java

Pour installer la bibliothèque Java, ajoutez cette dépendance au POM de votre projet :

<dependency> 
   <groupId>com.livefyre</groupId> 
   <artifactId>livefyre</artifactId> 
   <version>2.0.3</version> 
</dependency>

La bibliothèque Java comporte des dépendances sur les modules suivants :

<dependency> 
   <groupId>com.sun.jersey</groupId> 
   <artifactId>jersey-client</artifactId> 
   <version>[1.18.1,)</version> 
</dependency> 
<dependency> 
   <groupId>com.google.code.gson</groupId> 
   <artifactId>gson</artifactId> 
   <version>[2.3,)</version> 
</dependency> 
<dependency> 
   <groupId>com.google.guava</groupId> 
   <artifactId>guava</artifactId> 
   <version>[18.0,)</version> 
</dependency> 
<dependency> 
   <groupId>org.apache.commons</groupId> 
   <artifactId>commons-lang3</artifactId> 
   <version>[3.0.1,)</version> 
</dependency> 
<dependency> 
   <groupId>org.bitbucket.b_c</groupId> 
   <artifactId>jose4j</artifactId> 
   <version>[0.4.1,)</version> 
</dependency> 

Pour plus d’informations, lisez la documentation Java ou consultez la source sur GitHub.

NodeJS

Pour installer la bibliothèque NodeJS, exécutez la ligne suivante :

$ npm install livefyre

La bibliothèque NodeJS possède des dépendances sur les modules suivants :

"restler":">=3.2.0", 
"validator":"=3.5.0", 
"jsonwebtoken": ">=5.0.0" 

Pour plus d’informations, lisez la documentation NodeJs ou consultez la source sur GitHub.

Liens : Redémarrer, Validator, jsonwebtoken.

PHP

Pour installer la bibliothèque PHP avec le compositeur, ajoutez-la à votre compositeur.json :

"require": { 
   "livefyre/livefyre-php-utils": "2.0.4" 
}

Installez ensuite à l’aide de :

composer.phar install 

Si vous n’utilisez pas le compositeur, obtenez la dernière version de la bibliothèque à l’aide de :

git clone https://github.com/Livefyre/livefyre-php-utils 

Pour utiliser la bibliothèque , ajoutez le code suivant à votre script PHP :

require_once("/path/to/livefyre-php-utils/src/Livefyre.php"); 

La bibliothèque PHP dépend des modules suivants :

"ext-json": "*", 
"rmccue/requests": ">=1.0" 
"firebase/php-jwt": ">=2.0" 

Pour plus d’informations, lisez la documentation PHP ou consultez la source sur GitHub.

Liens : ext-json, Demandes, PHP-JWT

Python

Pour installer la bibliothèque Python, exécutez la ligne suivante :

$ pip install livefyre

La bibliothèque Python comporte des dépendances sur les modules suivants :

PyJWT >= 1.0.1  
requests >= 2.2.1  
python-dateutil >= 2.2  
enum34 == 1.0  
ordereddict == 1.1 if sys.version_info[:2] < 2.7 

Pour plus d’informations, consultez la documentation Python ou la source sur GitHub.

Liens : PyJWT, Demandes, Python-Dateutil, Enum34, OrderedDrapporte

Ruby

Pour installer la bibliothèque Ruby, ajoutez la ligne suivante au fichier Gemfile de votre application :

gem 'livefyre' 

Ou installez-le vous-même :

$ gem install livefyre

La bibliothèque Ruby possède des dépendances sur les modules suivants :

"jwt", '~> 1.4', ">= 1.4.1"  
"rest-client", '~> 1.8', ">= 1.8.0"  
"addressable", '~> 2.3', ">= 2.3.6" 

Pour plus d’informations, lisez la documentation Ruby ou consultez la source sur GitHub.

Liens : Ruby JWT, Client REST, Adressable

Sur cette page