Installation

Java

Um die Java-Bibliothek zu installieren, fügen Sie dem POM Ihres Projekts diese Abhängigkeit hinzu:

<dependency> 
   <groupId>com.livefyre</groupId> 
   <artifactId>livefyre</artifactId> 
   <version>2.0.3</version> 
</dependency>

Die Java-Bibliothek ist von den folgenden Modulen abhängig:

<dependency> 
   <groupId>com.sun.jersey</groupId> 
   <artifactId>jersey-client</artifactId> 
   <version>[1.18.1,)</version> 
</dependency> 
<dependency> 
   <groupId>com.google.code.gson</groupId> 
   <artifactId>gson</artifactId> 
   <version>[2.3,)</version> 
</dependency> 
<dependency> 
   <groupId>com.google.guava</groupId> 
   <artifactId>guava</artifactId> 
   <version>[18.0,)</version> 
</dependency> 
<dependency> 
   <groupId>org.apache.commons</groupId> 
   <artifactId>commons-lang3</artifactId> 
   <version>[3.0.1,)</version> 
</dependency> 
<dependency> 
   <groupId>org.bitbucket.b_c</groupId> 
   <artifactId>jose4j</artifactId> 
   <version>[0.4.1,)</version> 
</dependency> 

Weitere Informationen finden Sie in den Java-Dokumenten oder in der Quelle unter GitHub.

NodeJS

Führen Sie folgende Zeile aus, um die NodeJS-Bibliothek zu installieren:

$ npm install livefyre

Die NodeJS-Bibliothek ist von den folgenden Modulen abhängig:

"restler":">=3.2.0", 
"validator":"=3.5.0", 
"jsonwebtoken": ">=5.0.0" 

Weitere Informationen finden Sie im Dokument NodeJs oder in der Quelle unter GitHub.

Links: Restler, Validator, jsonwebtoken.

PHP

Um die PHP-Bibliothek mit Composer zu installieren, fügen Sie Ihrer composer.json Folgendes hinzu:

"require": { 
   "livefyre/livefyre-php-utils": "2.0.4" 
}

Installieren Sie anschließend mithilfe von:

composer.phar install 

Wenn Sie not Composer verwenden, rufen Sie die neueste Version der Bibliothek unter folgender Verwendung ab:

git clone https://github.com/Livefyre/livefyre-php-utils 

Um die Bibliothek zu verwenden, fügen Sie dem PHP-Skript Folgendes hinzu:

require_once("/path/to/livefyre-php-utils/src/Livefyre.php"); 

Die PHP-Bibliothek ist von den folgenden Modulen abhängig:

"ext-json": "*", 
"rmccue/requests": ">=1.0" 
"firebase/php-jwt": ">=2.0" 

Weitere Informationen finden Sie in den PHP-Dokumenten oder in der Quelle unter GitHub.

Links: ext-json, Anforderungen, PHP-JWT

Python

Um die Python-Bibliothek zu installieren, führen Sie folgende Zeile aus:

$ pip install livefyre

Die Python-Bibliothek ist von den folgenden Modulen abhängig:

PyJWT >= 1.0.1  
requests >= 2.2.1  
python-dateutil >= 2.2  
enum34 == 1.0  
ordereddict == 1.1 if sys.version_info[:2] < 2.7 

Weitere Informationen finden Sie in den Python-Dokumenten oder in der Quelle unter GitHub.

Links: PyJWT, Anforderungen, Python-Dateutil, Enum34, OrderedDict

Ruby

Um die Ruby-Bibliothek zu installieren, fügen Sie die folgende Zeile zur Gemfile Ihrer Anwendung hinzu:

gem 'livefyre' 

Oder installieren Sie es selbst:

$ gem install livefyre

Die Ruby-Bibliothek ist von den folgenden Modulen abhängig:

"jwt", '~> 1.4', ">= 1.4.1"  
"rest-client", '~> 1.8', ">= 1.8.0"  
"addressable", '~> 2.3', ">= 2.3.6" 

Weitere Informationen finden Sie in den Ruby-Dokumenten oder in der Quelle unter GitHub.

Links: Ruby JWT, REST Client, Addressable

Auf dieser Seite