Herramientas para desarrolladores de AEM para Eclipse

Información general

AEM Developer Tools para Eclipse es un complemento Eclipse basado en el complemento Eclipse para Apache Sling publicado bajo la Licencia Apache 2.

Oferta varias características que facilitan el desarrollo de AEM:

  • Integración perfecta con instancias de AEM mediante el conector de servidor Eclipse
  • Sincronización para paquetes de contenido y OSGi
  • Compatibilidad con depuración con capacidad de intercambio de código en caliente
  • Arranque simple de AEM proyectos mediante un Asistente para la creación de proyectos específico
  • Fácil edición de las propiedades de JCR

Requisitos

Antes de utilizar las herramientas de desarrollo de AEM, debe:

NOTA

En macOS, debe hacer clic con el botón derecho en Eclipse.app y luego seleccionar Mostrar contenido del paquete para encontrar su eclipse.ini.

Cómo instalar las herramientas para desarrolladores de AEM para Eclipse

Una vez que haya cumplido los requisitos anteriores, puede instalar el complemento de la siguiente manera:

  1. Abra el sitio Web de herramientas para desarrolladores de AEM.

  2. Copie el Vínculo de instalación.

    Tenga en cuenta que, como alternativa, puede descargar un archivo en lugar de utilizar el vínculo de instalación. Esto permite la instalación sin conexión, pero se perderán las notificaciones de actualización automática de esta manera.

  3. En Eclipse, abra el menú Ayuda.

  4. Haga clic en Instalar nuevo software.

  5. Haga clic en Agregar….

  6. En Nombre escriba AEM Developer Tools.

  7. En Ubicación copie la dirección URL de instalación.

  8. Haga clic en Agregar.

  9. Compruebe los complementos AEM y Sling.

  10. Haga clic en Siguiente.

  11. En la ventana Instalar detalles, haga clic en Siguiente nuevamente.

  12. Acepte los acuerdos de licencia y haga clic en Finalizar.

  13. Haga clic en RestartNow para reiniciar Eclipse.

La perspectiva AEM

En Eclipse, una perspectiva determina las acciones y vistas disponibles en una ventana y permite la interacción orientada a la tarea con los recursos en Eclipse. Para obtener más información sobre Perspectiva, consulte la documentación de Eclipse.

Las Herramientas de desarrollo AEM para Eclipse proporcionan una Perspectiva AEM que le oferta el control total sobre sus proyectos e instancias de AEM. Para abrir la Perspectiva de AEM:

  1. En la barra de menús Eclipse, seleccione Ventana -> Perspectiva -> Abrir perspectiva -> Otro.
  2. Seleccione AEM en el cuadro de diálogo y haga clic en Abrir.

La perspectiva AEM en Eclipse

Proyecto de módulo múltiple de muestra

Las herramientas para desarrolladores de AEM para Eclipse incluyen un proyecto multimódulo de muestra que le ayuda a ponerse al día rápidamente con la configuración de un proyecto en Eclipse, además de servir como guía de prácticas recomendadas para varias funciones de AEM. Obtenga más información sobre el arquetipo del proyecto.

Siga estos pasos para crear el proyecto de ejemplo:

  1. En el menú Archivo > Nuevo > Proyecto, vaya a la sección AEM y seleccione AEM Ejemplo de proyecto de módulos múltiples.

    AEM ejemplo de proyecto multimódulo

  2. Haga clic en Siguiente.

    NOTA

    Este paso puede tardar un momento, ya que m2eclipse necesita analizar los catálogos de arquetipos.

  3. Elija com.adobe.granite.archetypes : sample-project-archetype : <highest-number> en el menú y haga clic en Siguiente.

    Seleccionar versión de arquetipo

  4. Proporcione los siguientes campos para el proyecto de ejemplo:

    • Nombre
    • Id. de grupo
    • ID del artefacto
    • appId : es posible que tenga que expandir las opciones ​avanzadas para establecer este valor.
    • appTitle : Es posible que tenga que expandir las opciones ​avanzadas para establecer este valor.
    • Paquete : es posible que tenga que expandir las opciones ​avanzadas para establecer este valor.

    Definir propiedades de arquetipo

  5. Haga clic en Siguiente.

  6. A continuación, configure un servidor AEM al que se conectará Eclipse.

    Para utilizar la función de depurador, debe haber empezado a AEM en modo de depuración, lo que se puede lograr, por ejemplo, añadiendo lo siguiente a la línea de comandos:

        -nofork -agentlib:jdwp=transport=dt_socket,server=y,suspend=n,address=10123
    

    Conectar con AEM servidor

  7. Haga clic en Finalizar. Se crea la estructura del proyecto.

    NOTA

    En una instalación nueva (más concretamente, cuando nunca se han descargado dependencias), es posible que el proyecto se cree con errores. En este caso, siga el procedimiento descrito en Resolución de definiciones de proyecto no válidas.

Cómo importar proyectos existentes

Puede utilizar la función Nuevo proyecto para crear la estructura adecuada:

  1. Siga las instrucciones para crear un Proyecto Módulo múltiple de muestra y tendrá los siguientes proyectos creados para usted, lo que permitirá una saludable separación de preocupaciones:

    • PROJECT.ui.apps para /apps y /etc contenido
    • PROJECT.ui.content para /content que se crea
    • PROJECT.core para los paquetes Java (se volverán interesantes en cuanto desee agregar código Java)
    • PROJECT.it.launcher y PROJECT.it.tests para pruebas de integración
  2. Reemplace el contenido del proyecto PROJECT.ui.apps por las carpetas apps y etc del paquete:

    1. En el panel Explorador de proyectos, despliegue PROJECT.ui.apps > src > main > content > jcr_root > apps.
    2. Haga clic con el botón derecho en la carpeta apps y elija Mostrar en > Explorador del sistema.
    3. Elimine las carpetas apps y etc que debe ver y coloque aquí las carpetas apps y etc del paquete de contenido.
    4. En Eclipse, haga clic con el botón derecho en el proyecto PROJECT.ui.apps y elija Actualizar.
  3. A continuación, haga lo mismo con el PROJECT.ui.content y sustituya su carpeta de contenido por la del paquete:

    1. En el panel Explorador de proyectos, despliegue PROJECT.ui.content > src > main > content > jcr_root > content.
    2. Haga clic con el botón derecho en la carpeta de contenido más profunda y elija Mostrar en -> Explorador del sistema.
    3. Elimine la carpeta de contenido que debería ver y coloque aquí la carpeta de contenido del paquete de contenido.
    4. En Eclipse, haga clic con el botón derecho en el proyecto PROJECT.ui.content y elija Actualizar.
  4. Ahora tiene que actualizar los filter.xml archivos de estos dos proyectos para que correspondan al contenido del paquete de contenido. Para ello, abra el archivo META-INF/vault/filter.xml del paquete de contenido en un editor de texto/código independiente.

    • Este es un ejemplo de cómo puede verse su archivo filter.xml:
    <?xml version="1.0" encoding="UTF-8"?>
    <workspaceFilter version="1.0">
        <filter root="/apps/foo?lang=es"/>
        <filter root="/apps/foundation/components/bar?lang=es"/>
        <filter root="/etc/designs/foo?lang=es"/>
        <filter root="/content/foo?lang=es"/>
        <filter root="/content/dam/foo?lang=es"/>
        <filter root="/content/usergenerated/content/foo?lang=es"/>
    </workspaceFilter>
    
  5. En cuanto al contenido del paquete que se dividió en dos proyectos, también tendrá que dividir estas reglas de filtro en dos y actualizar en consecuencia los archivos filter.xml de los dos proyectos.

    1. En Eclipse, abra PROJECT.ui.apps/src/main/content/META-INF/filter.xml.

    2. Reemplace el contenido del elemento <workspaceFilter> por las reglas del paquete que inicio con /apps y /etc

      • Por ejemplo:

        <?xml version="1.0" encoding="UTF-8"?>
        <workspaceFilter version="1.0">
           <filter root="/apps/foo?lang=es"/>
           <filter root="/apps/foundation/components/bar?lang=es"/>
           <filter root="/etc/designs/foo?lang=es"/>
        </workspaceFilter>
        
    3. A continuación, abra PROJECT.ui.content/src/main/content/META-INF/filter.xml.

    4. Reemplace las reglas con las del paquete que inicio con /content.

      • Por ejemplo:

        <?xml version="1.0" encoding="UTF-8"?>
        <workspaceFilter version="1.0">
           <filter root="/content/foo?lang=es"/>
           <filter root="/content/dam/foo?lang=es"/>
           <filter root="/content/usergenerated/content/foo?lang=es"/>
        </workspaceFilter>
        
  6. Asegúrese de guardar todos los cambios. Ahora puede sincronizar ese nuevo contenido con su instancia de AEM.

  7. En el panel Servidores, asegúrese de que la conexión se ha iniciado y, si no, de que no se ha iniciado el inicio.

  8. Haga clic en el icono Limpiar y publicar.

Una vez finalizado, el paquete se debe ejecutar en la instancia y, al guardarlo, cualquier cambio se sincronizará automáticamente con la instancia.

Si desea volver a crear un paquete a partir de su proyecto, haga clic con el botón derecho en PROJECT.ui.apps o PROJECT.ui.content y elija Ejecutar como -> Instalación de Maven.

Ahora tiene una carpeta de destinatario que se ha creado con el paquete dentro (llamada, por ejemplo, PROJECT.ui.apps-0.0.1-SNAPSHOT.zip).

Solución de problemas

Resolución de definiciones de proyecto no válidas

Para resolver dependencias no válidas y la definición del proyecto, siga estos pasos:

  1. Seleccione todos los proyectos creados.
  2. Haga clic con el botón secundario.
  3. En el menú contextual, seleccione Maven -> Actualizar proyectos.
  4. Marque Forzar actualizaciones de instantáneas/versiones.
  5. Haga clic en Aceptar.

Eclipse descarga las dependencias necesarias. Esto puede tomar un momento.

Más información

El sitio web oficial del IDE de Apache Sling para Eclipse le proporciona información útil:

La siguiente documentación oficial de Eclipse puede ayudarle a configurar su entorno:

En esta página

Adobe Summit Banner

A virtual event April 27-28.

Expand your skills and get inspired.

Register for free
Adobe Summit Banner

A virtual event April 27-28.

Expand your skills and get inspired.

Register for free
Adobe Maker Awards Banner

Time to shine!

Apply now for the 2021 Adobe Experience Maker Awards.

Apply now
Adobe Maker Awards Banner

Time to shine!

Apply now for the 2021 Adobe Experience Maker Awards.

Apply now