Ferramentas de desenvolvedor do AEM para Eclipse

Visão geral

O AEM Developer Tools for Eclipse é um plug-in Eclipse com base no Plug-in do Eclipse para o Apache Sling lançado sob a licença do Apache 2.

Ela oferece vários recursos que facilitam AEM desenvolvimento:

  • Integração perfeita com instâncias AEM por meio do Eclipse Server Connector
  • Sincronização de pacotes de conteúdo e OSGi
  • Suporte à depuração com capacidade de troca dinâmica de código
  • Inicialização simples de projetos de AEM por meio de um Assistente de criação de projeto específico
  • Edição fácil das propriedades do JCR

Requisitos

Antes de usar as Ferramentas do desenvolvedor do AEM, é necessário:

OBSERVAÇÃO

No macOS, é necessário clicar com o botão direito do mouse em Eclipse.app e depois selecione Mostrar conteúdo do pacote para encontrar seu eclipse.ini.

Como instalar as ferramentas de desenvolvedor do AEM para o Eclipse

Uma vez que tenha cumprido o requisitos acima, você pode instalar o plug-in da seguinte maneira:

  1. Abra o Site da Web das Ferramentas do Desenvolvedor do AEM.

  2. Copie o Link de instalação.

    Observe que, como alternativa, você pode baixar um arquivo em vez de usar o link de instalação. Isso permite a instalação offline, mas você perderá as notificações de atualização automáticas dessa maneira.

  3. No Eclipse, abra o Ajuda menu.

  4. Clique em Instalar novo software.

  5. Clique em Adicionar….

  6. Em Nome enter AEM Developer Tools.

  7. Em Localização copie o URL de instalação.

  8. Clique em Adicionar.

  9. Verifique ambos AEM e Sling plug-ins.

  10. Clique em Avançar.

  11. No Detalhes da instalação , clique em Próximo novamente.

  12. Aceite os contratos de licença e clique em Concluir.

  13. Clique em ReiniciarAgora para reiniciar o Eclipse.

A perspectiva AEM

No Eclipse, uma Perspectiva determina as ações e visualizações disponíveis em uma janela e permite a interação orientada por tarefas com recursos no Eclipse. Para obter mais detalhes sobre a Perspectiva, consulte o Documentação do Eclipse.

As Ferramentas de desenvolvimento de AEM para o Eclipse fornecem uma Perspectiva AEM que oferece controle total sobre seus projetos e instâncias de AEM. Para abrir a Perspectiva de AEM:

  1. Na barra de menu Eclipse , selecione Window -> Perspectiva -> Abrir perspectiva -> Outras.
  2. Selecionar AEM na caixa de diálogo e clique em Abrir.

A perspectiva AEM no Eclipse

Exemplo de projeto de vários módulos

O AEM Developer Tools for Eclipse vem com uma amostra de projeto de vários módulos que ajuda você a se familiarizar rapidamente com a configuração do projeto no Eclipse, além de servir como um guia de práticas recomendadas para vários recursos AEM. Saiba mais sobre o Arquétipo de projeto.

Siga estas etapas para criar o projeto de amostra:

  1. No Arquivo > Novo > Projeto navegue até o menu AEM e selecione AEM exemplo de projeto de vários módulos.

    AEM exemplo de projeto de vários módulos

  2. Clique em Avançar.

    OBSERVAÇÃO

    Esta etapa pode demorar um pouco, pois m2eclipse precisa digitalizar os catálogos de arquétipo.

  3. Choose com.adobe.granite.archetypes : sample-project-archetype : <highest-number> no menu e, em seguida, clique em Próximo.

    Selecionar versão do arquétipo

  4. Forneça os seguintes campos para o projeto de amostra:

    • Nome
    • ID do Grupo
    • Id Do Artefato
    • appId - Talvez seja necessário expandir o Avançado para definir esse valor.
    • appTitle - Talvez seja necessário expandir o Avançado para definir esse valor.
    • Embalagem - Talvez seja necessário expandir o Avançado para definir esse valor.

    Definir propriedades de arquétipo

  5. Clique em Avançar.

  6. Em seguida, configure um servidor AEM ao qual o Eclipse se conectará.

    Para usar o recurso do depurador, é necessário ter iniciado o AEM no modo de depuração - o que pode ser feito, por exemplo, adicionando o seguinte à linha de comando:

        -nofork -agentlib:jdwp=transport=dt_socket,server=y,suspend=n,address=10123
    

    Conectar-se ao servidor AEM

  7. Clique em Concluir. A estrutura do projeto é criada.

    OBSERVAÇÃO

    Em uma nova instalação (mais especificamente, quando as dependências maven nunca foram baixadas), você pode criar o projeto com erros. Neste caso, siga o procedimento descrito em Resolvendo Definição de Projeto Inválida.

Como Importar Projetos Existentes

Você pode usar o Novo projeto para criar a estrutura correta para você:

  1. Siga as instruções para criar um Exemplo de projeto de vários módulos e você terá os seguintes projetos criados para você, o que permitirá uma saudável separação de preocupações:

    • PROJECT.ui.apps para /apps e /etc conteúdo
    • PROJECT.ui.content para /content criado
    • PROJECT.core para pacotes Java (eles se tornarão interessantes assim que você quiser adicionar o código Java)
    • PROJECT.it.launcher e PROJECT.it.tests para testes de integração
  2. Substitua o conteúdo de sua PROJECT.ui.apps com o apps e etc pastas do seu pacote:

    1. No painel Explorador de projetos , expanda PROJECT.ui.apps > src > main > content > jcr_root > apps.
    2. Clique com o botão direito do mouse no apps e escolha Mostrar em > Explorador de sistema.
    3. Exclua o apps e etc pastas que você deve ver e colocar aqui a variável apps e etc pastas do seu pacote de conteúdo.
    4. No Eclipse, clique com o botão direito do mouse no PROJECT.ui.apps e escolha Atualizar.
  3. Em seguida, faça o mesmo para o PROJECT.ui.content e substitua a pasta de conteúdo pela do pacote:

    1. No painel Explorador de projetos , expanda PROJECT.ui.content > src > main > content > jcr_root > content.
    2. Clique com o botão direito do mouse na pasta de conteúdo mais profunda e escolha Mostrar em -> Explorador de sistema.
    3. Exclua a pasta de conteúdo que deve ser exibida e coloque aqui a pasta de conteúdo do seu pacote de conteúdo.
    4. No Eclipse, clique com o botão direito do mouse no PROJECT.ui.content e escolha Atualizar.
  4. Agora é necessário atualizar o filter.xml Os arquivos desses dois projetos correspondem ao conteúdo do seu pacote de conteúdo. Para isso, abra o META-INF/vault/filter.xml arquivo do seu pacote de conteúdo em um editor de texto/código separado.

    • Este é um exemplo de como o filter.xml o arquivo pode parecer:
    <?xml version="1.0" encoding="UTF-8"?>
    <workspaceFilter version="1.0">
        <filter root="/apps/foo"/>
        <filter root="/apps/foundation/components/bar"/>
        <filter root="/etc/designs/foo"/>
        <filter root="/content/foo"/>
        <filter root="/content/dam/foo"/>
        <filter root="/content/usergenerated/content/foo"/>
    </workspaceFilter>
    
  5. Quanto ao conteúdo do seu pacote que foi dividido em dois projetos, você também precisará dividir essas regras de filtro em dois e atualizar adequadamente a variável filter.xml arquivos dos dois projetos.

    1. No Eclipse, abra PROJECT.ui.apps/src/main/content/META-INF/filter.xml.

    2. Substitua o conteúdo da variável <workspaceFilter> com as regras do seu pacote que começam com /apps e /etc

      • Por exemplo:

        <?xml version="1.0" encoding="UTF-8"?>
        <workspaceFilter version="1.0">
           <filter root="/apps/foo"/>
           <filter root="/apps/foundation/components/bar"/>
           <filter root="/etc/designs/foo"/>
        </workspaceFilter>
        
    3. Em seguida, abra PROJECT.ui.content/src/main/content/META-INF/filter.xml.

    4. Substitua as regras pelas do seu pacote que começam com /content.

      • Por exemplo:

        <?xml version="1.0" encoding="UTF-8"?>
        <workspaceFilter version="1.0">
           <filter root="/content/foo"/>
           <filter root="/content/dam/foo"/>
           <filter root="/content/usergenerated/content/foo"/>
        </workspaceFilter>
        
  6. Salve todas as alterações. Agora você pode sincronizar o novo conteúdo para a instância do AEM.

  7. No painel Servidores, verifique se a conexão foi iniciada e, se não for iniciada.

  8. Clique no botão Limpar e publicar ícone .

Depois de concluído, seu pacote deverá estar em execução na instância e, ao salvar, qualquer alteração será sincronizada automaticamente com a instância.

Para reconstruir um pacote do seu projeto, clique com o botão direito do mouse no PROJECT.ui.apps ou PROJECT.ui.content e escolha Executar como -> Instalação do Maven.

Agora você tem uma pasta de destino que foi criada com seu pacote interno (chamada de PROJECT.ui.apps-0.0.1-SNAPSHOT.zip).

Resolução de problemas

Resolvendo Definição de Projeto Inválida

Para resolver dependências inválidas e definição de projeto, proceda da seguinte maneira:

  1. Selecione todos os projetos criados.
  2. Clique com o botão direito do mouse.
  3. No menu de contexto, selecione Maven -> Atualizar projetos.
  4. Verificar Forçar atualizações de instantâneos/versões.
  5. Clique em OK.

O Eclipse baixa as dependências necessárias. Isso pode levar um momento.

Mais informações

O site oficial Apache Sling IDE tooling for Eclipse fornece informações úteis:

O seguinte funcionário Eclipse a documentação pode ajudar a configurar seu ambiente:

Nesta página