メタデータプロファイル

メタデータプロファイルを使用すると、フォルダー内のアセットにデフォルトのメタデータを適用できます。メタデータプロファイルを作成し、フォルダーに適用します。後からフォルダーにアップロードしたすべてのアセットは、メタデータプロファイルで設定したデフォルトのメタデータを継承します。

メタデータプロファイルの追加

  1. ツール/アセット/メタデータプロファイル​に移動し、作成​をクリックします。

  2. メタデータプロファイルのタイトル(「サンプルメタデータ」など)を入力し、「送信」をタップします。メタデータプロファイルの「フォームを編集」が表示されます。

  3. コンポーネントをクリックし、「設定」タブでプロパティを設定します。例えば、説明​コンポーネントをクリックして、そのプロパティを編集します。説明​コンポーネントについて、次のプロパティを編集します。

    • フィールドラベル - メタデータプロパティの表示名。ユーザーの参照用のみで使用します。

    • プロパティにマッピング – このプロパティの値には、リポジトリ内の保存場所となるアセットノードへの相対パスまたは名前を指定します。この値は、パスがアセットのノード下にあることを示すので、必ず「./」から始めます。

      「プロパティにマップ」​に指定した値は、アセットのメタデータノードの下にプロパティとして保存されます。例えば、を指定するとします。 /jcr:content/metadata/dc:desc をプロパティに マップの名前として指定した場合、アセットのメタデータノード Adobe Experience Manager Assets に値が dc:desc 格納されます。

    • デフォルト値 - メタデータコンポーネントのデフォルト値を追加するには、このプロパティを使用します。例えば、「My description」と指定すると、この値がアセットのメタデータノードの dc:desc プロパティに割り当てられます。

      メモ

      新しいメタデータプロパティ(/jcr:content/metadataノードに存在しない)にデフォルト値を追加しても、初期設定では、アセットのプロパティページにプロパティとその値が表示されません。 プロパティページで新しいプロパティを表示するには、対応するスキーマフォームを変更します。

  4. (オプション)「フォームを作成」タブから、「フォームを編集」にコンポーネントを追加し、「設定」タブでプロパティを設定します。次のプロパティが「フォームを作成」タブで使用できます。

コンポーネント プロパティ
セクションヘッダー フィールドラベル、説明
1 行のテキスト フィールドラベル、プロパティにマッピング、デフォルト値
複数値テキスト フィールドラベル、プロパティにマッピング、デフォルト値
数値 フィールドラベル、プロパティにマッピング、デフォルト値
日付 フィールドラベル、プロパティにマッピング、デフォルト値
標準タグ フィールドラベル、プロパティにマッピング、デフォルト値、説明
  1. 完了」をクリックします。メタデータプロファイルが、メタデータプロファイル​ページのプロファイルのリストに追加されます。

メタデータプロファイルのコピー

  1. メタデータプロファイル​ページで、コピーを作成するメタデータプロファイルを選択します。
  2. ツールバーの​コピー​をクリックします。
  3. メタデータプロファイルをコピー​ダイアログで、メタデータプロファイルの新しいコピーのタイトルを入力します。
  4. コピー」をクリックします。メタデータプロファイルのコピーが、メタデータプロファイル​ページのプロファイルのリストに表示されます。

メタデータプロファイルの削除

  1. メタデータプロファイル​ページで、削除するプロファイルを選択します。
  2. ツールバーの​メタデータプロファイル​を削除をクリックします。
  3. ダイアログで、「削除」をクリックして、削除操作を確定します。メタデータプロファイルがリストから削除されます。

フォルダーへのメタデータプロファイルの適用

メタデータプロファイルをフォルダに割り当てると、サブフォルダは自動的にそのプロファイルを親フォルダから継承します。 サブプロファイルーに別のサブフォルダーが適用されると、継承が停止します。 1つのフォルダーに割り当てるメタデータプロファイルは1つのみです。 したがって、アセットのアップロード、保存、使用およびアーカイブを行うフォルダー構造を慎重に検討します。

フォルダに別のメタデータプロファイルを割り当てた場合、新しいプロファイルは以前のプロファイルを上書きします。以前に存在したフォルダーアセットは変更されません。 新しいプロファイルは、変更後にフォルダーに追加されるアセットに適用されます。 特定のフォルダーまたはすべてのアセットにグローバルにメタデータプロファイルを適用できます。

プロファイルが割り当てられているフォルダーは、ユーザーインターフェイスでカード名にプロファイルの名前が表示されます。

後で変更した既存のメタデータプロファイルが存在するフォルダー内のアセットを再処理できます。

特定のフォルダーへのメタデータプロファイルの適用

ツール​メニュー内から、またはフォルダー内にいる場合は「プロパティ」から、メタデータプロファイルをフォルダーに適用できます。この節では、メタデータプロファイルをフォルダーに適用する両方の方法について説明します。

既にプロファイルが割り当てられているフォルダーには、フォルダー名のすぐ下にプロファイルの名前が表示されます。

後で変更した既存のビデオプロファイルが存在するフォルダー内のアセットを再処理できます。

プロファイルユーザーインターフェイスからのフォルダーへのメタデータプロファイルの適用

  1. ツール/アセット/メタデータプロファイル​に移動します。
  2. 1 つまたは複数のフォルダーに適用するメタデータプロファイルを選択します。
  3. メタデータプロファイルをフォルダーに適用」をクリックし、新しくアップロードされたアセットの受信に使用するフォルダーまたは複数のフォルダーを選択し、「完了」をクリックします。 既にプロファイルが割り当てられているフォルダーには、フォルダー名のすぐ下にプロファイルの名前が表示されます。

「プロパティ」からのフォルダーへのメタデータプロファイルの適用

  1. 左側のレールで、「アセット」をクリックし、メタデータプロファイルを適用するフォルダーに移動します。
  2. フォルダーで、をクリックするか、チェックマークをクリックして選択し、「プロパティ」をクリックします。
  3. メタデータプロファイル」タブを選択し、ドロップダウンメニューからプロファイルを選択して、「保存」をクリックします。 既にプロファイルが割り当てられているフォルダーには、フォルダー名のすぐ下にプロファイルの名前が表示されます。

メタデータプロファイルのグローバルな適用

フォルダーにプロファイルを適用する以外に、グローバルに1つを適用して、任意のフォルダーのExperience Manager Assetsにアップロードされたコンテンツに選択したプロファイルが適用されるようにすることもできます。

後で変更した既存のメタデータプロファイルが存在するフォルダー内のアセットを再処理できます。

メタデータプロファイルをグローバルに適用するには、次のいずれかをおこないます。

  • https://<AEM server>/mnt/overlay/dam/gui/content/assets/foldersharewizard.html/content/damに移動し、適切なプロファイルを適用して、「保存」をクリックします。

  • CRXDE Lite で、/content/dam/jcr:content ノードに移動します。追加プロパティmetadataProfile:/etc/dam/metadata/dynamicmedia/<name of metadata profile>。「すべて保存」をクリックします。

フォルダーからのメタデータプロファイルの削除

フォルダーからメタデータプロファイルを削除すると、サブフォルダーは自動的に親フォルダーのプロファイルの削除状態を継承します。ただし、フォルダー内で実行されたファイルの処理はそのまま維持されます。

ツール​メニュー内で、またはフォルダー内にいる場合は「プロパティ」で、メタデータプロファイルをフォルダーから削除できます。このセクションでは、メタデータプロファイルをフォルダーから削除する両方の方法について説明します。

プロファイルユーザーインターフェイスを使用したフォルダーからのメタデータプロファイルの削除

  1. AEMロゴをクリックし、ツール/アセット/メタデータプロファイル​に移動します。

  2. 1 つまたは複数のフォルダーから削除するメタデータプロファイルを選択します。

  3. フォルダーからメタデータプロファイルーを削除」をクリックし、プロファイルーの削除に使用するフォルダーまたは複数のフォルダーを選択して、「完了」をクリックします。

    名前がフォルダー名の下に表示されなくなっていることで、メタデータプロファイルがフォルダーに適用されていないことを確認できます。

「プロパティ」を使用したフォルダーからのメタデータプロファイルの削除

  1. AEMロゴをクリックし、アセット​に移動して、メタデータプロファイルを削除するフォルダーに移動します。
  2. フォルダーのチェックマークをクリックして選択し、「プロパティ」をクリックします。
  3. メタデータプロファイル」タブを選択し、ドロップダウンメニューから「なし」を選択して、「保存」をクリックします。既にプロファイルが割り当てられているフォルダーには、フォルダー名のすぐ下にプロファイルの名前が表示されます。

このページ

Adobe Summit Banner

A virtual event April 27-28.

Expand your skills and get inspired.

Register for free
Adobe Summit Banner

A virtual event April 27-28.

Expand your skills and get inspired.

Register for free
Adobe Maker Awards Banner

Time to shine!

Apply now for the 2021 Adobe Experience Maker Awards.

Apply now
Adobe Maker Awards Banner

Time to shine!

Apply now for the 2021 Adobe Experience Maker Awards.

Apply now