Gestire i predefiniti per immagini

I predefiniti per immagini consentono ad Adobe Experience Manager Assets di distribuire dinamicamente immagini di dimensioni diverse, in formati diversi o con altre proprietà immagine generate in modo dinamico. Ogni predefinito per immagini rappresenta un insieme predefinito di comandi di ridimensionamento e formattazione per la visualizzazione delle immagini. Quando crei un predefinito per immagini, scegli una dimensione per la distribuzione delle immagini. È inoltre possibile scegliere i comandi di formattazione in modo che l'aspetto dell'immagine sia ottimizzato quando l'immagine viene distribuita per la visualizzazione.

Gli amministratori possono creare predefiniti per l’esportazione delle risorse. Gli utenti possono scegliere un predefinito al momento dell’esportazione delle immagini, che riformatta anche le immagini in base alle specifiche specificate dall’amministratore.

Puoi anche creare predefiniti immagine reattivi. Se applichi un predefinito immagine reattiva alle risorse, questo cambia a seconda del dispositivo o delle dimensioni dello schermo su cui vengono visualizzate. È possibile configurare i predefiniti immagine per l’utilizzo di CMYK nello spazio colore, oltre a RGB o Grigio.

Questa sezione descrive come creare, modificare e gestire in genere i predefiniti per immagini. È possibile applicare un predefinito immagine a un'immagine in qualsiasi momento in cui viene visualizzata in anteprima. Consulta Applicare i predefiniti immagine.

NOTA

La funzione Smart imaging funziona con i predefiniti per immagini esistenti e utilizza funzionalità intelligenti all’ultimo millisecondo di distribuzione per ridurre ulteriormente le dimensioni dei file immagine in base al browser o alla velocità di connessione di rete. Per ulteriori informazioni, consulta Smart imaging .

Informazioni sui predefiniti per immagini

Come una macro, un predefinito per immagini è un insieme predefinito di comandi di ridimensionamento e formattazione salvati con un nome. Per comprendere il funzionamento dei predefiniti per immagini, supponiamo che il sito web richieda che ogni immagine del prodotto venga visualizzata in dimensioni diverse, in formati diversi e nei tassi di compressione per la distribuzione desktop e mobile.

Puoi creare due predefiniti immagine: uno con 500 x 500 pixel per la versione desktop e 150 x 150 pixel per la versione mobile. È possibile creare due predefiniti per immagini, uno denominato Enlarge per visualizzare le immagini a 500x500 pixel e uno chiamato Thumbnail per visualizzare le immagini a 150 x 150 pixel. Per fornire immagini con le dimensioni Enlarge e Thumbnail, in Experience Manager viene trovata la definizione di Ingrandisci predefinito immagine e Predefinito immagine miniatura. Quindi, Experience Manager genera in modo dinamico un'immagine con le specifiche di dimensione e formattazione di ciascun predefinito per immagini.

Le immagini a dimensioni ridotte quando vengono consegnate in modo dinamico possono perdere nitidezza e dettagli. Per questo motivo, ogni predefinito per immagini contiene controlli di formattazione per l’ottimizzazione di un’immagine quando viene distribuita con una particolare dimensione. Questi controlli assicurano che le immagini siano nitide e chiare quando vengono inviate al sito Web o all'applicazione.

Gli amministratori possono creare i predefiniti per immagini. Per creare un predefinito per immagini, puoi iniziare da zero o da uno esistente e salvarlo con un nuovo nome.

Gestire i predefiniti per immagini

Per gestire i predefiniti immagine in Experience Manager, seleziona il logo Experience Manager per accedere alla console di navigazione globale, quindi fai clic sull’icona Strumenti e passa a Risorse > Predefiniti immagine.

6_5_tools-assets-imagepresets

NOTA

Eventuali predefiniti immagine creati sono disponibili anche come rappresentazioni dinamiche quando visualizzi l’anteprima o la distribuzione delle risorse.

non è necessario pubblicare i predefiniti per immagini quando i predefiniti per immagini vengono pubblicati automaticamente.

Consulta Pubblicare predefiniti immagine.

NOTA

Il sistema mostra diverse rappresentazioni quando selezioni Rappresentazioni nella Vista dettagli di una risorsa. Puoi aumentare o diminuire il numero di predefiniti immagine da visualizzare. Consulta Aumenta il numero di predefiniti immagine visualizzati.

Formati di file Adobe Illustrator (AI), PostScript® (EPS) e PDF

Se desideri supportare l’acquisizione di file AI, EPS e PDF in modo da poter generare rappresentazioni dinamiche di questi formati di file, controlla le seguenti informazioni prima di creare i predefiniti per immagini.

Il formato di file Adobe Illustrator è una variante di PDF. Le principali differenze, nel contesto dell’attività di Experience Manager, sono le seguenti:

  • I documenti Adobe Illustrator sono costituiti da una singola pagina con più livelli. Ogni livello viene estratto come risorsa secondaria PNG sotto la risorsa principale Illustrator.
  • I documenti PDF sono costituiti da una o più pagine. Ogni pagina viene estratta come una risorsa PDF a pagina singola sotto il documento PDF principale con più pagine.

Le risorse secondarie vengono create dal componente Create Sub Asset process all’interno del flusso di lavoro complessivo DAM Update Asset. Per visualizzare questo componente del processo all'interno del flusso di lavoro, passa a Strumenti > Flusso di lavoro > Modelli > Aggiorna risorsa DAM > Modifica.

Puoi visualizzare le risorse secondarie o le pagine quando apri la risorsa, selezionare il menu Contenuto e selezionare Risorse secondarie o Pagine. Le risorse secondarie sono risorse reali. In altre parole, le pagine PDF sono estratte dal componente del flusso di lavoro Create Sub Asset . Vengono quindi memorizzati come page1.pdf, page2.pdf e così via, sotto la risorsa principale. Una volta memorizzati, il flusso di lavoro DAM Update Asset li elabora.

Per utilizzare Dynamic Media per visualizzare in anteprima e generare rappresentazioni dinamiche per file AI, EPS o PDF, sono necessari i seguenti passaggi di elaborazione:

  1. Nel flusso di lavoro DAM Update Asset, il componente di processo Rasterize PDF/AI Image Preview Rendition rasterizza la prima pagina della risorsa originale, utilizzando la risoluzione configurata, in un rendering cqdam.preview.png.

  2. Il rendering cqdam.preview.png viene quindi ottimizzato in un PTIFF dal componente di processo Dynamic Media Process Image Assets all’interno del flusso di lavoro.

NOTA

Nel flusso di lavoro Risorsa di aggiornamento DAM, il passaggio Miniature EPS genera le miniature per i file EPS.

Proprietà dei metadati delle risorse PDF/AI/EPS

Proprietà metadati Descrizione
dam:Physicalwidthinpollici Larghezza documento in pollici.
dam:Physicalheightinpollici Altezza del documento in pollici.

Puoi accedere alle opzioni dei componenti del processo Rasterize PDF/AI Image Preview Rendition tramite il flusso di lavoro DAM Update Asset .

Seleziona Adobe Experience Manager in alto a sinistra, vai a Strumenti > Flusso di lavoro > Modelli. Nella pagina Modelli flusso di lavoro , seleziona Risorsa di aggiornamento DAM, quindi nella barra degli strumenti seleziona Modifica. Nella pagina del flusso di lavoro Aggiorna risorsa DAM , tocca due volte il componente di processo Rasterize PDF/AI Image Preview Rendition per aprire la relativa finestra di dialogo Proprietà passaggio .

Rasterizzare le opzioni di rendering anteprima immagine PDF/AI

Argomenti per rasterizzare il flusso di lavoro PDF o AI

Argomenti per rasterizzare il flusso di lavoro PDF o AI

Argomento del processo Impostazione predefinita Descrizione
Tipi mime application/pdf
application/postscript
application/illustrator
Elenco di tipi di mime di documenti considerati documenti PDF o Illustrator.
Larghezza max. 2048 Larghezza massima del rendering di anteprima generato, in pixel.
Altezza max. 2048 Altezza massima in pixel del rendering di anteprima generato.
Risoluzione 72 Risoluzione per rasterizzare la prima pagina, in ppi (pixel per pollice).

Utilizzando gli argomenti di processo predefiniti, la prima pagina di un documento PDF/AI viene rasterizzata a 72 ppi e l’immagine di anteprima generata è dimensionata a 2048 x 2048 pixel. Per una distribuzione tipica, puoi aumentare la risoluzione fino a un minimo di 150 ppi o più. Ad esempio, un documento con dimensioni lettera USA a 300 ppi richiede rispettivamente una larghezza e un'altezza massime di 2550 x 3300 pixel.

Larghezza massima e Altezza massima limitano la risoluzione a cui rasterizzare. Ad esempio, se i valori massimi sono invariati e la risoluzione è impostata su 300 ppi, un documento Lettera USA viene rasterizzato a 186 ppi. Cioè, il documento è di 1581 x 2046 pixel.

Il componente di processo Rasterize PDF/AI Image Preview Rendition ha un valore massimo definito per garantire che non crei immagini troppo grandi nella memoria. Immagini di grandi dimensioni possono sovraccaricare la memoria fornita alla JVM (Java™ Virtual Machine). È necessario prestare attenzione a fornire alla JVM memoria sufficiente per gestire il numero configurato di flussi di lavoro paralleli, ognuno dei quali ha il potenziale per creare un'immagine alle dimensioni massime configurate.

Formato di file InDesign (INDD)

Se desideri supportare l’acquisizione di file INDD in modo da poter generare il rendering dinamico di questo formato di file, controlla le seguenti informazioni prima di creare i predefiniti per immagini.

Per i file InDesign, le risorse secondarie vengono estratte solo se Adobe InDesign Server è integrato con Experience Manager. Le risorse di riferimento sono collegate in base ai relativi metadati. InDesign Server non è necessario per il collegamento. Tuttavia, le risorse a cui si fa riferimento devono essere presenti in Experience Manager prima che i file InDesign vengano elaborati affinché i collegamenti possano essere creati tra i file InDesign e le risorse a cui si fa riferimento.

Il componente Processo di estrazione file multimediali nel flusso di lavoro DAM Update Asset esegue diversi script di estensione preconfigurati per elaborare i file InDesign.

I percorsi ExtendScript negli argomenti del processo di estrazione di file multimediali

I percorsi ExtendScript negli argomenti del componente del processo di estrazione di file multimediali nel flusso di lavoro Aggiorna risorsa DAM .

I seguenti script vengono utilizzati dall’integrazione Dynamic Media:

Nome ExtendScript Predefiniti Descrizione
ThumbnailExport.jsx Genera un rendering PPI a 300 thumbnail.jpg ottimizzato e trasformato in un rendering PTIFF dal componente di processo Dynamic Media Process Image Assets.
JPEGPagesExport.jsx Genera una risorsa secondaria JPEG PPI 300 per ogni pagina. La risorsa secondaria JPEG è una risorsa reale memorizzata nella risorsa InDesign. Viene inoltre ottimizzato e trasformato in PTIFF dal flusso di lavoro DAM Update Asset .
PDFPagesExport.jsx No Genera una risorsa secondaria PDF per ogni pagina. La risorsa secondaria PDF viene elaborata come descritto in precedenza. Poiché il PDF contiene una sola pagina, non vengono generate risorse secondarie.

Configurare le dimensioni delle miniature delle immagini

Puoi configurare le dimensioni delle miniature configurando tali impostazioni nel flusso di lavoro Aggiorna risorsa DAM . Nel flusso di lavoro sono disponibili due passaggi per configurare la dimensione delle miniature delle risorse immagine. Una (Risorse di immagine di processo Dynamic Media) viene utilizzata per le risorse di immagini dinamiche. L'altro (Elabora miniature) viene utilizzato per la generazione di miniature statiche o quando tutti gli altri processi non riescono a generare miniature. Indipendentemente dal fatto che sia deve avere le stesse impostazioni.

Con il passaggio Risorse di immagine di processo di elementi multimediali dinamici, le miniature vengono generate da Image Server e questa configurazione è indipendente da quella applicata al passaggio Elabora miniature. La generazione delle miniature tramite il passaggio Elabora miniature rappresenta il modo più lento e laborioso di creare le miniature, in termini di utilizzo della memoria.

Il dimensionamento delle miniature è definito nel seguente formato: larghezza:height:centro, ad esempio 80:80:false. La larghezza e l’altezza determinano le dimensioni in pixel della miniatura. Il valore centrale è falso o vero. Se è impostato su true, indica che l'immagine in miniatura ha esattamente le dimensioni specificate nella configurazione. Se l'immagine ridimensionata è più piccola, viene centrata all'interno della miniatura.

NOTA
  • Le dimensioni delle miniature per i file EPS sono configurate nel passaggio Miniature EPS, nella scheda Argomenti sotto Miniature.

  • Le dimensioni delle miniature per i video sono configurate nel passaggio Miniature FFmpeg , nella scheda Processo in Argomenti.

Per configurare le dimensioni delle miniature delle immagini:

  1. Passa a Strumenti > Flusso di lavoro > Modelli > Aggiorna risorsa DAM > Modifica.

  2. Seleziona il passaggio Dynamic Media Process Image Assets e seleziona la scheda Miniature . Modifica le dimensioni delle miniature in base alle esigenze, quindi seleziona OK.

    6_5_dinamicmediaprocesseassets-thumbnailstab

  3. Seleziona il passaggio Elabora miniature , quindi seleziona la scheda Miniature . Modifica le dimensioni delle miniature in base alle esigenze, quindi seleziona OK.

    NOTA

    I valori nell’argomento miniature del passaggio Elabora miniature devono corrispondere all’argomento miniature nel passaggio Risorse di immagine di processo di elementi multimediali dinamici.

  4. Seleziona Salva per salvare le modifiche al flusso di lavoro.

Aumenta o diminuisce il numero di predefiniti immagine visualizzati

I predefiniti immagine creati sono disponibili come rappresentazioni dinamiche quando visualizzi in anteprima le risorse. L'Experience Manager mostra varie rappresentazioni dinamiche quando si visualizza una risorsa da Vista dettagli > Rendering. Puoi aumentare o diminuire il limite di rappresentazioni visualizzate.

Per aumentare o diminuire il numero di predefiniti immagine visualizzati:

  1. Passa a CRXDE Lite (https://localhost:4502/crx/de).

  2. Passa al nodo di elenco dei predefiniti immagine in /libs/dam/gui/coral/content/commons/sidepanels/imagepresetsdetail/imgagepresetslist

    Increase_decreasethenumberofimagepresetsthatdisplay

  3. Nella proprietà limit, modifica Valore, che corrisponde a 15 per impostazione predefinita, inserendo un numero a piacere.

  4. Passa alla sorgente dati del predefinito immagine in /libs/dam/gui/coral/content/commons/sidepanels/imagepresetsdetail/imgagepresetslist/datasource

    chlimage_1-495

  5. Nella proprietà limit , modifica il numero impostandolo sul numero desiderato, ad esempio {empty requestPathInfo.selectors[1] ? "20" : requestPathInfo.selectors[1]}

  6. Selezionare Salva tutto.

Creare predefiniti immagine

Crea i predefiniti per immagini in modo da poter applicare le impostazioni in modo coerente tra le immagini durante l’anteprima o la pubblicazione.

NOTA

Se si utilizza Internet Explorer 9, la creazione di un predefinito non viene visualizzata nell’elenco dei predefiniti subito dopo il salvataggio. Per risolvere questo problema, disattiva la cache per IE9.

Se desideri supportare l’acquisizione di file AI, PDF ed EPS in modo da poter generare il rendering dinamico di questi formati di file, controlla le seguenti informazioni prima di creare i predefiniti per immagini.

Consulta Formati di file Adobe Illustrator (AI), PostScript® (EPS) e PDF.

Se desideri supportare l’acquisizione di file INDD in modo da poter generare il rendering dinamico di questo formato di file, controlla le seguenti informazioni prima di creare i predefiniti per immagini.

Vedere Formato del file InDesign (INDD).

Per creare predefiniti immagine:

  1. Ad Experience Manager, seleziona il logo Experience Manager per accedere alla console di navigazione globale, quindi vai a Strumenti > Risorse > Predefiniti immagini.

  2. Seleziona Crea.

    chlimage_1-496

    NOTA

    Per rendere dinamico questo predefinito immagine, cancella i valori nei campi larghezza e altezza, lasciandoli vuoti.

  3. Nella finestra Modifica predefinito immagine, immetti i valori desiderati nelle schede Base e Avanzate, compreso un nome. Le opzioni sono descritte in Opzioni predefinito immagine. I predefiniti vengono visualizzati nel riquadro a sinistra e possono essere usati all’istante con altre risorse.

    6_5_imagepreset-edit

  4. Seleziona Salva.

Creazione di un predefinito per immagini reattive

Per creare un predefinito per immagini reattive, esegui i passaggi descritti in Creare predefiniti immagine. Quando immetti l'altezza e la larghezza nella finestra Modifica predefinito immagine, cancella i valori e lasciali vuoti.

Lasciandoli vuoti, indica ad Experience Manager che questo predefinito per immagini è reattivo. Se necessario, puoi regolare gli altri valori.

NOTA

Per visualizzare i pulsanti URL e RESS quando applichi un predefinito immagine a una risorsa, essa deve essere pubblicata.

chlimage_1-79

I predefiniti immagine e le risorse immagine vengono pubblicati automaticamente.

Opzioni del predefinito immagine

Quando crei o modifichi i predefiniti immagine, hai le opzioni descritte in questa sezione. Inoltre, l’Adobe consiglia di iniziare con le seguenti opzioni di "best practice":

  • Formato scheda (Base) - Seleziona JPEG o un altro formato che rispetta i tuoi requisiti. Tutti i browser web supportano il formato immagine JPEG, in quanto offre un buon compromesso tra dimensioni ridotte dei file e qualità delle immagini. Tuttavia, le immagini in formato JPEG usano uno schema di compressione che causa la perdita di dati, con possibile introduzione di artefatti di immagine indesiderati, qualora l’impostazione di compressione sia troppo bassa. Per questo motivo, Adobe consiglia di impostare la qualità di compressione su 75. Questa impostazione offre un buon compromesso tra la qualità delle immagini e le dimensioni ridotte dei file.

  • Attiva nitidezza semplice: non selezionare Attiva nitidezza semplice (il filtro di nitidezza offre un controllo inferiore rispetto alle impostazioni Maschera definizione dettagli).

  • Nitidezza: Modalità di ricampionamento - Seleziona Bi-Cubic.

Opzioni della scheda Base

Campo Descrizione
Nome Inserisci un nome descrittivo senza spazi vuoti. Per aiutare gli utenti a identificare questo predefinito per immagini, includi nel nome la specifica della dimensione dell’immagine.
Larghezza e altezza Immettere in pixel le dimensioni in cui l'immagine viene distribuita. Larghezza e altezza devono essere maggiori di 0 pixel. Se uno dei due valori è 0, non viene creato alcun predefinito. Se entrambi i valori sono vuoti, viene creato un predefinito per immagini reattive.
Formato Scegli un formato dal menu.
La scelta di ​JPEGoffre le seguenti altre opzioni:
Qualità - La scala di qualità JPEG è di 1-100. La scala è visibile quando si trascina il cursore.
Attiva il downsampling della crominanza JPG : poiché l'occhio è meno sensibile alle informazioni sui colori ad alta frequenza rispetto alla luminanza ad alta frequenza, le immagini JPEG dividono le informazioni sulle immagini in componenti di luminanza e colore. Quando un'immagine JPEG viene compressa, il componente luminanza viene lasciato a risoluzione piena, mentre i componenti colore vengono sottoposti a sottocampionamento utilizzando una media di gruppi di pixel. Il sottocampionamento riduce il volume dei dati di mezzo o di un terzo, senza quasi alcun impatto sulla qualità percepita. Il campionamento non è applicabile alle immagini in scala di grigi. Questa tecnica riduce la quantità di compressione utile per le immagini con contrasto elevato (ad esempio, immagini con testo sovrapposto).

La scelta di ​GIFo GIF con alfa fornisce le seguenti opzioni aggiuntive di quantizzazione colore GIF:
Tipo - Seleziona Adattivo (predefinito), Web o Macintosh. Se si seleziona GIF con Alpha, l'opzione Macintosh non è disponibile.
Dither - Seleziona ​Diffusore o Disattivato.
Numero di colori - Immettere un numero 2 - 256.
Elenco colori - Inserisci un elenco separato da virgole. Ad esempio, per bianco, grigio e nero, immettere 000000,888888,ffffff.

La scelta di PDF, TIFF o TIFF con alfa offre questa opzione aggiuntiva:
Compressione - Seleziona un algoritmo di compressione. Le opzioni dell'algoritmo per i PDF sono None, Zip e Jpeg; per i TIFF sono Nessuno, LZW, Jpeg e Zip; e per TIFF con Alpha sono Nessuno, LZW e Zip.

La scelta di PNG, PNG con Alpha o ​EPS non fornisce opzioni aggiuntive.
Nitidezza Seleziona Abilita nitidezza semplice per applicare un filtro di nitidezza di base all'immagine dopo che tutte le proporzioni sono state applicate. La nitidezza può contribuire a compensare la sfocatura che può verificarsi quando si visualizza un'immagine con dimensioni diverse.

Opzioni avanzate della scheda

Campo Descrizione
Spazio colore Selezionare RGB, CMYK, o Scala di grigio per lo spazio colore.
Profilo colore Seleziona il profilo dello spazio colore di output in cui vuoi convertire la risorsa se è diverso dal profilo di lavoro.
Intento di rendering È possibile ignorare l'intento di rendering predefinito. Gli intenti di rendering determinano cosa succede ai colori che non possono essere riprodotti nel profilo del colore di destinazione (fuori gamma). L’Intento di rendering viene ignorato se non è compatibile con il profilo ICC.
  • Selezionare Perceptual per comprimere la gamma totale da uno spazio colore a un altro spazio colore quando uno o più colori nell'immagine originale non rientrano nella gamma dello spazio colore di destinazione.
  • Selezionare Colorimetrico relativo quando un colore nello spazio colore corrente non rientra nell'intervallo di colori di destinazione. Inoltre, è possibile mapparlo al colore più vicino possibile all'interno della gamma dello spazio colore di destinazione senza influire su altri colori.
  • Selezionare Saturazione per riprodurre la saturazione del colore dell'immagine originale durante la conversione nello spazio colore di destinazione.
  • Selezionare Colorimetrico assoluto per abbinare esattamente i colori senza alcuna regolazione per il punto bianco o il punto nero che alteri la luminosità dell'immagine.
Compensazione punto nero Seleziona questa opzione se il profilo di output supporta questa funzione. La compensazione blackpoint viene ignorata se non è compatibile con il profilo ICC specificato.
Dithering Selezionare questa opzione per evitare o ridurre gli artefatti di striatura del colore.
Tipo di nitidezza

Selezionare Nessuno, Nitidezza o Maschera definizione dettagli.

  • Selezionare Nessuno per disattivare la nitidezza.
  • Selezionare Nitidezza per applicare all'immagine un filtro di nitidezza di base dopo che è stata effettuata la modifica in scala. La nitidezza può contribuire a compensare la sfocatura che può verificarsi quando si visualizza un'immagine con dimensioni diverse.
  • Seleziona Maschera definizione dettagli per regolare con precisione un effetto filtro di nitidezza sull'immagine ricampionata verso il basso finale. Puoi controllare l’intensità dell’effetto, il raggio in pixel e una soglia di contrasto da ignorare. L’effetto utilizza le stesse opzioni del filtro “Maschera definizione dettagli” di Photoshop.

In Maschera definizione dettagli sono disponibili le seguenti opzioni:

  • Importo : controlla la quantità di contrasto applicata ai pixel del bordo. Il valore predefinito del numero reale è 1,0. Per le immagini ad alta risoluzione, è possibile aumentarlo fino a 5,0. Considera il valore come una misura dell'intensità del filtro.
  • Raggio : determina il numero di pixel intorno ai pixel del bordo che influiscono sulla nitidezza. Per le immagini ad alta risoluzione, immetti un numero reale da 1 a 2. Un valore basso rende più nitidi solo i pixel del bordo; un valore elevato rende più nitida una banda più ampia di pixel. Il valore corretto dipende dalle dimensioni dell’immagine.
  • Soglia : determina l’intervallo di contrasto da ignorare quando viene applicato il filtro Maschera definizione dettagli. In altre parole, questa opzione determina la differenza tra i pixel da rendere più nitidi rispetto all’area circostante, prima che vengano considerati pixel del bordo e resi più nitidi. Per evitare di introdurre rumore, prova con valori interi compresi tra 2 e 20.
  • Applica a : determina se la non nitidezza viene applicata a ogni colore o luminosità.
Modalità ricampionamento Selezionare un'opzione Modalità di ricampionamento. Queste opzioni consentono di aumentare la nitidezza dell’immagine durante il ricampionamento verso il basso:
  • Bi-Lineare - Il metodo di ricampionamento più veloce. Alcuni artefatti di aliasing sono evidenti.
  • Bi-Cubic - Aumenta l'utilizzo della CPU ma produce immagini più nitide con artefatti di aliasing meno evidenti.
  • Sharp2 - Può produrre risultati leggermente più nitidi rispetto a Bi-Cubic, ma a un costo di CPU ancora più elevato.
  • Bi-Sharp : seleziona il ricampatore predefinito di Photoshop per ridurre le dimensioni dell'immagine, che si chiama Adobe Photoshop bicubic sharperin.
  • Ogni colore e luminosità - ogni metodo può essere basato sul colore o sulla luminosità. Per impostazione predefinita, è selezionato Ogni colore.
Risoluzione di stampa Selezionare una risoluzione per stampare l'immagine; Il valore predefinito è 72 pixel.
Modificatore immagine

Oltre alle comuni impostazioni immagine disponibili nell’interfaccia utente, Dynamic Media supporta numerose modifiche avanzate alle immagini che puoi specificare nel campo Modificatori immagine . Questi parametri sono definiti nel riferimento al comando Image Server Protocol.

Importante: Le seguenti funzionalità elencate nell’API non sono supportate:

  • Comandi di base per il modello e il rendering del testo: text= textAngle= textAttr= textFlowPath= textFlowXPath= textPath= e textPs=
  • Comandi di localizzazione: locale= e req=xlate
  • req=set non è disponibile per l'utilizzo generale.
  • req=mbrset
  • req=saveToFile
  • req=targets
  • template=
  • Servizi Dynamic Media non principali: SVG, Image Rendering e Web-to-Print

Consente di definire le opzioni del predefinito immagine con i modificatori di immagine

Oltre alle opzioni disponibili nelle schede Base e Avanzate , è possibile definire modificatori di immagine per fornire ulteriori opzioni durante la definizione dei predefiniti per immagini. Il rendering delle immagini si basa sull’API di rendering delle immagini di Dynamic Media ed è definito in dettaglio in Riferimento al protocollo HTTP.

Di seguito sono riportati alcuni esempi di base delle operazioni che puoi eseguire con i modificatori di immagini.

NOTA

Alcuni modificatori di immagini non possono essere utilizzati in Experience Manager.

  • op_invert - Inverte ogni componente del colore per ottenere un effetto immagine negativo.

    &op_invert=1
    

    6_5_imagepreset-edit-invert

  • op_blur - Applica un filtro di sfocatura all'immagine.

    &op_blur=7
    

    6_5_imagepreset-edit-blur

  • Comandi combinati - op_blur e op-invert

    &op_invert=1&op_blur=7
    

    chlimage_1-80

  • op_bright - riduce o aumenta la luminosità.

    &op_brightness=58
    

    6_5_imagepreset-edit-luminosità

  • opac - Regola l'opacità dell'immagine. Consente di ridurre l’opacità in primo piano.

    opac=29
    

    6_5_imagepreset-edit-opacity

Modificare i predefiniti per immagini

  1. Ad Experience Manager, seleziona il logo Experience Manager per accedere alla console di navigazione globale, quindi vai a Strumenti > Risorse > Predefiniti immagini.

    6_5_imagepreset-editpreset

  2. Seleziona un predefinito e seleziona Modifica. Viene visualizzata la finestra Modifica predefinito immagine.

  3. Apporta le modifiche desiderate e seleziona Salva per salvarle o Annulla per annullare le modifiche.

Pubblicare predefiniti per immagini

I predefiniti immagine vengono pubblicati automaticamente.

Eliminare i predefiniti per immagini

  1. In Experience Manager, seleziona il logo Experience Manager per accedere alla console di navigazione globale e fai clic sull’icona Strumenti .
  2. Passa a Risorse > Predefiniti immagini.
  3. Seleziona un predefinito, quindi seleziona Elimina. Dynamic Media conferma che si desidera eliminarlo. Seleziona Elimina per rimuovere o selezionare Annulla per tornare ai predefiniti immagine.

In questa pagina